Download it now!
Bug 74455 - Replace Print File Directly with the regular Print function in the toolbar
Summary: Replace Print File Directly with the regular Print function in the toolbar
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.3.0.0.alpha0+ Master
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:4.3.0
Keywords:
: 49917 (view as bug list)
Depends on:
Blocks: Print-Directly
  Show dependency treegraph
 
Reported: 2014-02-03 16:35 UTC by Stefan Knorr (astron)
Modified: 2017-09-24 09:47 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Knorr (astron) 2014-02-03 16:35:03 UTC
Rationale:
+ printing, when done wrong, can waste lots of time & paper
  => try to prevent printing without confirmation, as any number of this
     can go wrong
    + wrong printer
    + wrong range
    + wrong colour/bw setting
    (to only name the most common ones)
+ many other applications (e.g. GNOME applications, MS Office) also do not
  print without confirmation by default
Comment 1 Commit Notification 2014-02-03 17:06:52 UTC
Michael Meeks committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0f7542a7a74a24b3cdb69f7e860caacbfcd2cc23

fdo#74455 - hide direct printing button and replace with new print dialog.



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 2 V Stuart Foote 2015-02-07 19:33:39 UTC
*** Bug 49917 has been marked as a duplicate of this bug. ***