Bug 74482 - FORMATTING: Calc hangs when formating Chinese date format on 2 adjacient cells
Summary: FORMATTING: Calc hangs when formating Chinese date format on 2 adjacient cells
Status: RESOLVED DUPLICATE of bug 72470
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2014-02-04 01:26 UTC by water.qian
Modified: 2014-02-07 21:50 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
screen capture (126.71 KB, image/jpeg)
2014-02-04 01:26 UTC, water.qian
Details

Note You need to log in before you can comment on or make changes to this bug.
Description water.qian 2014-02-04 01:26:51 UTC
Created attachment 93329 [details]
screen capture

Problem description: Calc hangs when formatting Chinese date format "month date" on 2 adjacent cells. If you formatting only 1 cell or 2 cells not adjacent, it is ok.

Steps to reproduce:
1. Start Libreoffice Calc.
2. Enter date 2014/2/4 in cell B1. 
3. Enter date 2014/2/5 in cell B2.
4. Select both cells. 
5. Press Ctrl + 1.
6. Select Language: simplified chinese. 
   Select date format M"月"D"日"
7. Press OK and it hangs.

If you format B1 and B3, it is OK.
If you format B1 and B2 in English date format, it is OK too.

Current behavior:
 Calc hangs.

Expected behavior:
 Cells formatted as Chinese date format.


              
Operating System: Windows XP
Version: 4.2.0.4 release
Comment 1 Kohei Yoshida 2014-02-07 05:22:12 UTC
Likely a duplicate of Bug 72470.
Comment 2 m.a.riosv 2014-02-07 21:50:20 UTC
No issue now with:
Win7x64Ultimate
Version: 4.2.1.0.0+ Build ID: 63950ec72806489b41c2109f5c3840dcf22f4c6c
         TinderBox: Win-x86@42, Branch:libreoffice-4-2, Time: 2014-02-07_00:47:07

Certainly you are right Kohei, seems patches in bug 72470 has been solved the bug.

Change the status as duplicate of 72470

*** This bug has been marked as a duplicate of bug 72470 ***