Bug 74483 - EDITING: calc hangs while copy and paste
Summary: EDITING: calc hangs while copy and paste
Status: RESOLVED DUPLICATE of bug 72470
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: possibleRegression
Depends on: 72470
Blocks:
  Show dependency treegraph
 
Reported: 2014-02-04 01:39 UTC by patkyliu
Modified: 2015-12-15 10:53 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
CSV file to test the bug. (703 bytes, text/csv)
2014-02-04 09:50 UTC, vono
Details

Note You need to log in before you can comment on or make changes to this bug.
Description patkyliu 2014-02-04 01:39:32 UTC
Problem description:

Steps to reproduce:
1. ....
2. ....
3. ....

Current behavior:

Expected behavior:

              
Operating System: Windows XP
Version: 4.2.0.4 release
Last worked in: 4.1.5.1 rc
Comment 1 Tim Lloyd 2014-02-04 04:02:40 UTC
Hi,

Details about the file would be handy, what were you trying to copy & paste? Has this issue just arisen in the file? 

Any info would be appreciated

Cheers
Comment 2 vono 2014-02-04 09:49:21 UTC
Problem description:
Transpose paste hang LO Calc.

Steps to reproduce:
Using an UTF-8 locale (at least, import a CSV file as UTF-8, see the CSV attachment)

- select the 2 first rows
- create a new sheet
- right click on the first cell A1 -> paste special
- In the Option part of the dialogue box, check "Transpose"
- Click Ok

Current behavior:
-> Hang, The program stop respond, use 100% CPU, probably in an infinite loop.
Maybe this is related to your new string code.

Expected behavior:
The paste work, with the transpose.

Operating System:
GNU/Linux (Ubuntu 12.04 64bits) with official LibreOffice 4.2.0.4 (Build Id 05dceb5d363845f2cf968344d7adab8dcfb2ba71)
Comment 3 vono 2014-02-04 09:50:14 UTC
Created attachment 93350 [details]
CSV file to test the bug.
Comment 4 vono 2014-02-04 09:59:49 UTC
Note: in fact, it do not seems to like the UTF-8 string "中文 (简体) (zh-cn)" in the CSV file...
A simple copy/paste of it hang Calc too.
Comment 5 Tim Lloyd 2014-02-06 08:43:46 UTC
confirmed on windows XP and Fedora 20 as per the steps defined by yono. LO 4.2.0.4 Changing status to NEW
Comment 6 Kohei Yoshida 2014-02-07 05:45:53 UTC
Please test this again after the fix for Bug 72470 is in.
Comment 7 m.a.riosv 2014-02-07 23:17:42 UTC
Retested, works for me with:
Win7x64Ultimate
Version: 4.2.1.0.0+ Build ID: 63950ec72806489b41c2109f5c3840dcf22f4c6c
        TinderBox: Win-x86@42, Branch:libreoffice-4-2, Time: 2014-02-07_00:47:07

Bug is still reproducible with 4.2.0.4 after copying the cell a couple of times..

Changed status: duplicate 72470, please if you are not agree reopen it.

*** This bug has been marked as a duplicate of bug 72470 ***
Comment 8 Robinson Tryon (qubit) 2015-12-15 10:53:45 UTC
Migrating Whiteboard tags to Keywords: (possibleRegression)
[NinjaEdit]