Bug 74495 - Fatal error when using ISCHECKFORPRODUCTUPDATES=0 with msi-install
Summary: Fatal error when using ISCHECKFORPRODUCTUPDATES=0 with msi-install
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Michael Stahl (CIB)
URL:
Whiteboard: target:4.3.0 target:4.2.1
Keywords: regression
Depends on:
Blocks:
 
Reported: 2014-02-04 09:04 UTC by andreas.lindeborg
Modified: 2014-02-04 19:39 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
fatal error dialog (50.15 KB, application/jpeg)
2014-02-04 09:04 UTC, andreas.lindeborg
Details

Note You need to log in before you can comment on or make changes to this bug.
Description andreas.lindeborg 2014-02-04 09:04:27 UTC
Created attachment 93347 [details]
fatal error dialog

When installing with Swedish msi using property ISCHECKFORPRODUCTUPDATES=0 and
then checking the setting under Verktyg(Tools) - Alternativ(Options) and selecting Online-uppdatering (Online Update) Libreoffice will crash with fatal error.
(I believe the ISCHECKFORPRODUCTUPDATES=0 is supposed to hide the Online Update menu)

See attached jpg for error.
Comment 1 Andras Timar 2014-02-04 13:06:01 UTC
ISCHECKFORPRODUCTUPDATES=0 only disables automatic check for updates, not the Online Update feature itself. Of course, it should not crash.
Comment 2 Andras Timar 2014-02-04 15:23:24 UTC
It is a regression from 2feb756dd5ff486a3972cf676f6f1d07017bf0f6. The ComponentCondition got lost. 

@mst: Do you plan to support ComponentCondition in AutoInstall?
Comment 3 Michael Stahl (CIB) 2014-02-04 15:27:16 UTC
what does ComponentCondition do? it looks like it's something that can be tweaked at install-time so we need to handle it specially...
Comment 4 Michael Stahl (CIB) 2014-02-04 15:53:53 UTC
so i hacked something up, which (after actually using --enable-online-update)
gives this on Linux:

workdir/ScpTarget/scp2/source/onlineupdate/module_onlineupdate.par-File auto_onlineupdate_lib_updchk
workdir/ScpTarget/scp2/source/onlineupdate/module_onlineupdate.par:     Name = libupdchklo.so;
workdir/ScpTarget/scp2/source/onlineupdate/module_onlineupdate.par-     UnixRights = 755;
workdir/ScpTarget/scp2/source/onlineupdate/module_onlineupdate.par-     Styles = (PACKED);
workdir/ScpTarget/scp2/source/onlineupdate/module_onlineupdate.par-     Dir = gid_Brand_Dir_Program;
workdir/ScpTarget/scp2/source/onlineupdate/module_onlineupdate.par-     ComponentCondition = "ISCHECKFORPRODUCTUPDATES=1";
workdir/ScpTarget/scp2/source/onlineupdate/module_onlineupdate.par-End

please test if it actually works on windows :)
Comment 5 Commit Notification 2014-02-04 15:54:48 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=79ab9d7b6ede19bc494770bba6cc59bd4618d5ae

fdo#74495: gbuild: AutoInstall: add support for ComponentCondition



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 6 Andras Timar 2014-02-04 16:23:38 UTC
(In reply to comment #3)
As the name says, the installation of a component (one or more file, or a registry entry in MSI world) can depend on a condition, such as a value of a property. In our case it was the ISCHECKFORPRODUCTUPDATES property, which can be set by the user install time. But there are other important cases, not yet converted to AutoInstall, such as a condition depending on the operating system version or 32/64 bit.

Thanks for the quick fix, I started a Windows build.
Comment 7 Commit Notification 2014-02-04 19:15:20 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a2045ea778ee0191528bdc69165ad382cc7c1cb1&h=libreoffice-4-2

fdo#74495: gbuild: AutoInstall: add support for ComponentCondition


It will be available in LibreOffice 4.2.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 Andras Timar 2014-02-04 19:39:25 UTC
It works, thanks.