Bug 74552 - EDITING: User defined header styles need demoting and promoting, even if they know their right outline level
Summary: EDITING: User defined header styles need demoting and promoting, even if they...
Status: RESOLVED DUPLICATE of bug 62032
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks: Bullet-Numbering-Dialog
  Show dependency treegraph
 
Reported: 2014-02-05 10:15 UTC by Emanuele Gissi
Modified: 2016-10-23 12:48 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
An example odt file (14.71 KB, application/vnd.oasis.opendocument.text)
2014-02-05 10:15 UTC, Emanuele Gissi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Emanuele Gissi 2014-02-05 10:15:46 UTC
Created attachment 93435 [details]
An example odt file

Problem description: 

User defined header styles do not behave as default header styles. The user needs to demote or promote each header paragraph in the text editor to the right level, even if the new styles know their right Outline level from Format > Styles and Formatting > Paragraph Styles
I add that outline level is correctly used by automatic table of contents.

This bug could be similar to:
https://www.libreoffice.org/bugzilla/show_bug.cgi?id=62032

Steps to reproduce:

1. Open: Format > Styles and Formatting > List Styles

2. Create new numbering style "Outline numbering for appendix"
perfectly identical to the wired "Outline numbering" except for numbering of the first level: use letters instead of numbers (eg. Appendix A)

3. Open: Format > Styles and Formatting > Paragraph Styles
and create new styles "Heading 1 Appendix", "Heading 2 Appendix", ... linked with corresponding "Heading 1", "Heading 2", ...

4. Set for each new style the correct Outline level:
- level 1 for "Heading 1 Appendix",
- level 2 for "Heading 2 Appendix",
- ...
and Numbering style: "Outline numbering for appendix"

5. Back in the text create a new headers for appendix: "Title of appendix level 1", "Title of appendix level 2", ...
then assign the right new style to each one: "Heading 1 Appendix", "Heading 2 Appendix", ...


Current behavior:

In the text, both "Title of appendix level 1", "Title of appendix level 2" appear as level 1:

A. Title of appendix level 1
B. Title of appendix level 2

I have to demote "title of appendix level 2" to obtain the desired behaviour:

A. Title of appendix level 1
A.1 Title of appendix level 2


Expected behavior:

I expect this second behavior automatically:

A. title of appendix level 1
A.1 title of appendix level 2

Each new appendix heading style knows its Outline level from Format > Styles and Formatting > Paragraph Styles

There should be no need to demote the appendix heading to obtain the desired behavior.

These new headings (eg. "Heading 1 Appendix"...) should be treated as much as possible as the default ones from Tools > Outline numbering

Thank you very much for your kind attention.
Operating System: Fedora
Version: 4.1.4.2 release
Comment 1 Cor Nouws 2014-02-05 11:28:02 UTC
Hi Emanuele,

thanks for the clear description of the problem, wish.

I recognise the behaviour (from a long time ago) and indeed, would be good to have it changed!

Set this to New and Enhancement.

Kind regards,
Cor
Comment 2 Albrecht Müller 2014-09-02 09:08:29 UTC

*** This bug has been marked as a duplicate of bug 62032 ***