Download it now!
Bug 74557 (SAVE_FILE_CORRUPTION) - Calc CORRUPT Excel (xls) files
Summary: Calc CORRUPT Excel (xls) files
Status: RESOLVED WORKSFORME
Alias: SAVE_FILE_CORRUPTION
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.1.4.2 release
Hardware: All All
: high critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-02-05 10:37 UTC by Nicolás
Modified: 2015-10-23 17:41 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
File corruption (save ok and dont open anymore) (226.50 KB, application/vnd.ms-excel)
2014-02-05 10:37 UTC, Nicolás
Details
Libreoffice Calc 4.0.x corruption example (466.00 KB, application/vnd.ms-excel)
2014-02-06 12:08 UTC, Nicolás
Details
Libreoffice Calc 4.0.x corruption example (2.19 MB, application/vnd.ms-excel)
2014-02-06 12:16 UTC, Nicolás
Details
attachment-31588-0.html (1.61 KB, text/html)
2014-02-27 11:03 UTC, Nicolás
Details
attachment-31588-1.dat (1 bytes, multipart/alternative)
2014-02-27 11:03 UTC, Nicolás
Details
Bug 74557 examples.7z (382.83 KB, application/x-7z-compressed)
2014-02-27 11:03 UTC, Nicolás
Details
attachment-25031-0.html (1.90 KB, text/html)
2014-03-12 15:29 UTC, Nicolás
Details
attachment-25031-1.dat (1 bytes, multipart/alternative)
2014-03-12 15:29 UTC, Nicolás
Details
Bug 74557 examples.zip (865.55 KB, application/zip)
2014-03-12 15:29 UTC, Nicolás
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nicolás 2014-02-05 10:37:23 UTC
Created attachment 93438 [details]
File corruption (save ok and dont open anymore)

I save correctly my file ALL DAY WORK and I LOST ALL WORK OF DAY (12hours)!!!!
The file open with a advert of incompatibility and i cant open it with no one program (excel, gnumeric, libreoffice, openoffice anything). I need the information in the file. i send de file. It's not de first time that the libreoffice do that the 4.0.xxx do that everytime (directly i decide not use it), but in 4.1.4.2 it's first time. I not travel to work on the file yesterday and loose everything i do!!!!!! What do that. Save ok yesterday and not open today.?????!!!. How can i repair the file please???!!!
Comment 1 Nicolás 2014-02-06 12:08:33 UTC
Created attachment 93522 [details]
Libreoffice Calc 4.0.x corruption example
Comment 2 Nicolás 2014-02-06 12:09:05 UTC
Sorry about my english and the message. I really  angry that day. But is really, under Windows Libreoffice 4.0.x (4.0.6 too) corrupt files very often to use it seriously. I probe it and decide to uninstall it to install 3.6.7 again thtats works ok. I begin to use 4.1.2 and works ok, the 4.2 have a seriusly problem with Excel interoperability. I use .xls everytime and work with it normaly under windows xp sp3 with files in .xls mode. Everytime the file open with corruption you don't know that happens before you open it. I think thats a save problem. samething happens when save, and the file don't save ok. Lost parts (the size is not the same i think). I attach and other 4.0.x corruption to see it. I do the work again and is not necesary repair the file. But i won't to know why Libreoffice corrupt often files (Windows+xls use), and its not a bad idea make a program that recover samething from file corrupt.
Comment 3 Nicolás 2014-02-06 12:16:15 UTC
Created attachment 93523 [details]
Libreoffice Calc 4.0.x corruption example

Libreoffice calc 4.0.6 corruption. File save ok and don't open anymore
(I think thats is a save problem)
Comment 4 Nicolás 2014-02-06 12:48:18 UTC
Comment on attachment 93522 [details]
Libreoffice Calc 4.0.x corruption example

"Precios_Actuales L01 OLD.xls" it's not a corruption file its a mistake upload it.
Comment 5 Nicolás 2014-02-06 12:54:37 UTC
Aditional information: 
All files are made with Excel 2000 in year 2002. From 2012 i adopt Libreoffice and reworked (or work) with them on Libreoffice 3.6.7 (before) and 4.1.4 (now), always in xls mode under WinXP. In few days move to Debian testing + Libreoffice 4.1.4 (i make same test and work ok).
Comment 6 sophie 2014-02-13 13:31:45 UTC
Reproduced with 4.1.5.3 under Debian and 4.2.0.4 under Ubuntu.
The error message displayed is: versions incompatibility - incorrect file version. Set as New - change plateform to all -
Comment 7 Kohei Yoshida 2014-02-27 04:01:05 UTC
Unfortunately, to investigate a save file corruption file we do need the original file prior to file corruption. Both of these files have already been corrupted, which will not give us anything to work on.
Comment 8 Nicolás 2014-02-27 11:03:38 UTC
Created attachment 94804 [details]
attachment-31588-0.html

Hi!:
     I have the original file, but not in exactly moment before it happens
i send you if you want. Thanks a lot. Nik.-

Send some examples is not the first time that happens most in 4.0.x (yes,
4.0.6 too).




2014-02-27 1:01 GMT-03:00 <bugzilla-daemon@freedesktop.org>:

>   *Comment # 7 <https://bugs.freedesktop.org/show_bug.cgi?id=74557#c7> on
> bug 74557 <https://bugs.freedesktop.org/show_bug.cgi?id=74557> from Kohei
> Yoshida <libreoffice@kohei.us> *
>
> Unfortunately, to investigate a save file corruption file we do need the
> original file prior to file corruption. Both of these files have already been
> corrupted, which will not give us anything to work on.
>
>  ------------------------------
> You are receiving this mail because:
>
>    - You reported the bug.
>
>
Comment 9 Nicolás 2014-02-27 11:03:38 UTC
Created attachment 94805 [details]
attachment-31588-1.dat
Comment 10 Nicolás 2014-02-27 11:03:38 UTC
Created attachment 94806 [details]
Bug 74557 examples.7z
Comment 11 Kohei Yoshida 2014-03-11 01:02:41 UTC
(In reply to comment #10)
> Created attachment 94806 [details]
> Bug 74557 examples.7z

Could you use normal zip compression?  I'm afraid I can't open 7z here (on Linux).  Thanks again.
Comment 12 Kohei Yoshida 2014-03-11 01:05:00 UTC
(In reply to comment #11)
> (In reply to comment #10)
> > Created attachment 94806 [details]
> > Bug 74557 examples.7z
> 
> Could you use normal zip compression?  I'm afraid I can't open 7z here (on
> Linux).  Thanks again.

Ah nevermind there is a utility for 7z on linux as well.
Comment 13 Kohei Yoshida 2014-03-11 01:33:47 UTC
One question. What's the difference between "Costos US Before Fail.xls" and "Costos US Good After Fail.xls"?
Comment 14 Nicolás 2014-03-12 15:29:25 UTC
Created attachment 95666 [details]
attachment-25031-0.html

Hi, i send you in .zip. Thanks



2014-03-10 22:02 GMT-03:00 <bugzilla-daemon@freedesktop.org>:

>   *Comment # 11 <https://bugs.freedesktop.org/show_bug.cgi?id=74557#c11>
> on bug 74557 <https://bugs.freedesktop.org/show_bug.cgi?id=74557> from
> Kohei Yoshida <libreoffice@kohei.us> *
>
> (In reply to comment #10 <https://bugs.freedesktop.org/show_bug.cgi?id=74557#c10>)> Created attachment 94806 [details] <https://bugs.freedesktop.org/attachment.cgi?id=94806> [details] <https://bugs.freedesktop.org/attachment.cgi?id=94806&action=edit>
> > Bug 74557 <https://bugs.freedesktop.org/show_bug.cgi?id=74557> examples.7z
>
> Could you use normal zip compression?  I'm afraid I can't open 7z here (on
> Linux).  Thanks again.
>
>  ------------------------------
> You are receiving this mail because:
>
>    - You reported the bug.
>
>
Comment 15 Nicolás 2014-03-12 15:29:25 UTC
Created attachment 95667 [details]
attachment-25031-1.dat
Comment 16 Nicolás 2014-03-12 15:29:25 UTC
Created attachment 95668 [details]
Bug 74557 examples.zip
Comment 17 Nicolás 2014-03-17 12:51:53 UTC
(In reply to comment #13)
> One question. What's the difference between "Costos US Before Fail.xls" and
> "Costos US Good After Fail.xls"?

I send you a diferent version files. After before fails is a file ok some day before the corrupt file, this file it's ok. The file corrupt its same day after this. I reworked the file before fails and use it with the new name after fail or corrupt. 
Thanks. Nik.-
Comment 18 tommy27 2014-05-12 19:46:26 UTC
bumped into this report while cleaning the mab4.1 list.

I think this not qualified as a MAB (most annoying bug) for the LibO community since it affects a single user and there are no clear instructions how to reproduce the issue as well.

removing from that list.
Comment 19 Björn Michaelsen 2014-07-12 20:18:14 UTC
Priority highest is reserved for MABs, please see: https://wiki.documentfoundation.org/MAB on when a bug qualifies for that.

Thus keeping this on priority high.
Comment 20 QA Administrators 2015-07-18 17:44:50 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 3. Leave a comment with your results. 4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-07-18
Comment 21 Buovjaga 2015-10-23 17:41:35 UTC
Ok, I tested with Precios_Actuales Good Before.xls.
Saving it and reloading does not give the result observed in Precios_Actuales Error.xls

The file Costos US Before Fail.xls says:

The following external file could not be loaded. Data linked from this file did not get updated.

file:///C:/Mis Documentos/COSTOS/Maestro de Precios.xls

So I don't want to comment on that.

Closing as WFM. Note that this was never confirmed by anyone..

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: fcc2415ade6ae93710bbbda9f7e163045e323105
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-10-21_16:55:13
Locale: fi-FI (fi_FI)