Download it now!
Bug 74572 - EDITING: Embedded/Pasted images disappear
Summary: EDITING: Embedded/Pasted images disappear
Status: RESOLVED DUPLICATE of bug 46447
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: possibleRegression
Depends on:
Blocks:
 
Reported: 2014-02-05 16:39 UTC by James Murray
Modified: 2015-12-15 10:53 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description James Murray 2014-02-05 16:39:29 UTC
I consider this to be a show stopping issue.

Problem description: 
All of a sudden, embedded images (pasted into doc) vanish and are replaced by a placeholder.
This is reminiscent of the Word 6 red cross fiasco.

Actual version of is 4.2.0.2

Steps to reproduce:
1. open or view .odg file
2. possibly related to memory
3. ....

Current behavior:
Images randomly disappear.

Expected behavior:
Images never disappear.

This looks similar to bug 46447

It _appears_ to be related to current memory state on machine. Quitting all LibreOffice sessions and re-opening DID show more images in an older revision of the file that was had many images previously missing. I was then able to cut/paste the lost images into the current version of the file.

I have a broken .odg file that I can share with a developer, but it contains private information so I cannot post it here.
Operating System: Ubuntu
Version: 4.2.0.4 release
Comment 1 Cor Nouws 2014-02-05 20:46:42 UTC
Hi James,

thanks for the report.
Indeed, I guess there is some memory aspect in this.

Why don't you think this _is_ similar to bug 46447 ?

Best,
Cor
Comment 2 James Murray 2014-02-06 00:08:29 UTC
The symptoms look similar but this is in a different module. As I am not a Libreoffice developer I did not want to make a definitive judgement.
Comment 3 Kevin Suo 2014-08-04 12:21:57 UTC
I encounter the same problem when I was using draw version 4.3.0.4 today.

I was doing "Alt+PrintScreen" and "Paste" in draw, and insert some shapes, text and lines to make illustration. Suddendly some of the previous inserted images would randomly disapper, showing only placeholder. The shapes/lines/text are not lost.

This is really critical, but I am not sure what't the steps to 100% reproduce this behaviour.

I then switched to version 4.1.6.2, and finished my work with no images lost at all, so it's a possible regression.
Comment 4 Kevin Suo 2014-08-04 12:22:28 UTC
(In reply to comment #3)
Forgot to metion, my OS: Windows 7 x86.
Comment 5 ign_christian 2014-08-17 07:02:32 UTC
How about raising memory in: Tools > Options > Memory > Graphics cache ? 
Any significant effect?
Comment 6 Cor Nouws 2014-09-28 20:58:51 UTC
(In reply to comment #2)
> The symptoms look similar but this is in a different module. 

Internals of Impress and Draw are mostly the same. So I do set this as a duplicate. When 46447 is fixed, pls keep an eye on this.
thanks,
Cor

*** This bug has been marked as a duplicate of bug 46447 ***
Comment 7 Robinson Tryon (qubit) 2015-12-15 10:53:28 UTC
Migrating Whiteboard tags to Keywords: (possibleRegression)
[NinjaEdit]