Download it now!
Bug 74573 - In Calc, 'Paste Special' with 'Skip empty cells' does not work
Summary: In Calc, 'Paste Special' with 'Skip empty cells' does not work
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.0.0.alpha0+ Master
Hardware: x86 (IA32) All
: highest major
Assignee: Kohei Yoshida
URL:
Whiteboard: target:4.3.0 target:4.2.3
Keywords: regression
Depends on:
Blocks: mab4.2
  Show dependency treegraph
 
Reported: 2014-02-05 16:40 UTC by David Clayton
Modified: 2015-12-15 22:24 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Test case docuement to show the paste special fault (38.33 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-02-05 16:40 UTC, David Clayton
Details

Note You need to log in before you can comment on or make changes to this bug.
Description David Clayton 2014-02-05 16:40:33 UTC
Created attachment 93458 [details]
Test case docuement to show the paste special fault

In 4.2 the option of skipping empty cells on a paste special has broken since from the previous 3.6 release.

I have attached a test document with some instructions to re-produce and the expected result.

The actual operation of skipping the empty cells works as the summation (cell contents in the test document) remains intact, but the number data is not inserted, only an Value! error. IF you compare this to the paste without the skip empty cell option, the numbers are okay.

I have put the severity as major, because it makes this functionality impossible to use.
Comment 1 Joel Madero 2014-02-05 17:24:45 UTC
Please don't add your own bugs to MAB - we have a procedure. Removing
Comment 2 Joel Madero 2014-02-05 17:29:17 UTC
Also please include detailed steps on how to reproduce - even for simple things we prefer reproducible steps so QA and Devs don't have to guess at what you're doing. I know this can seem a bit tedious but it's much better for QA and devs if every bug report comes with enumerated steps that say 

1. Do X
2. Do y
3.
...

Observed:

Expected:


In terms of procedures that I was talking about:
1) Never should an unconfirmed bug be on MAB
2) Never should a bug be put on MAB by the reporter of the bug unless you are very involved with the project (ie. our top developers/QA occasionally do but it's only because we've seen thousands of bugs and know where one falls in the grand scheme of things)
3) We have specific things in terms of priority/severity that QA knows about - if you care to find out more please join our QA team, we're always looking for help

Also updating version to at least 4.0 as you said it's been broken since some 3.6 - our version field is the oldest release displaying the problem, not the newest. Since this bug as been around for so long and apparently you may be the first one to report it's likely not a MAB - MAB should be for the masses (bugs that affect many many users), but I'm not triaging currently as I have a few things to get done so I won't be the final call on that
Comment 3 V Stuart Foote 2014-02-05 17:41:33 UTC
@David,

Thanks for posting. 

Confirming on Windows 7 sp1, 64-bit
Version: 4.2.0.4
Build ID: 05dceb5d363845f2cf968344d7adab8dcfb2ba71

Also on a recent build of master
Version: 4.3.0.0.alpha0+
Build ID: a904aa609dddb80a44cf34a5e4299efe0dc2c49f
TinderBox: Win-x86@39, Branch:master, Time: 2014-01-30_05:15:33

However, we have a few QA steps before we can assign this as a MAB. Resetting to high major following Joel's removal from mab4.2

Working backward through 4.1.5 and 4.0.6 and if need be back to the 3.6.7 and earliers builds to see where it was introduced.
Comment 4 V Stuart Foote 2014-02-05 17:42:12 UTC
@David,

Thanks for posting. 

Confirming on Windows 7 sp1, 64-bit
Version: 4.2.0.4
Build ID: 05dceb5d363845f2cf968344d7adab8dcfb2ba71

Also on a recent build of master
Version: 4.3.0.0.alpha0+
Build ID: a904aa609dddb80a44cf34a5e4299efe0dc2c49f
TinderBox: Win-x86@39, Branch:master, Time: 2014-01-30_05:15:33

However, we have a few QA steps before we can assign this as a MAB. Resetting to high major following Joel's removal from mab4.2

Working backward through 4.1.5 and 4.0.6 and if need be back to the 3.6.7 and earliers builds to see where it was introduced.
Comment 5 V Stuart Foote 2014-02-05 17:43:02 UTC
lets try that with a status set ;)
Comment 6 Joel Madero 2014-02-05 17:45:48 UTC
If possible would be nice to get a bibisect as well (assuming it exists on Linux or OSX which almost definitely it does)
Comment 7 V Stuart Foote 2014-02-05 18:00:35 UTC
Confirming regression from 4.1 release where testing with
Version: 4.1.5.2
Build ID: a02f36998a4af5e2f9fbec2b7e9f70a8b0bc934

Have correct 'Paste Special' honoring the 'skip empty cells' and correct values for pasting just 'text' and 'numbers'.
Comment 8 V Stuart Foote 2014-02-05 18:22:29 UTC
Issue was introduced prior to the 4.2.0.0beta1 release, already present in
Version: 4.2.0.0.beta1
Build ID: f4ca7b35f580827ad2c69ea6d29f7c9b48ebbac7

Will need more complete bibisect
Comment 9 V Stuart Foote 2014-02-05 18:37:25 UTC
issue was already present with

Version: 4.2.0.0.alpha0+
Build ID: 5486fd99e185833f1defa9681ef48f50940a65db
TinderBox: Win-X86@42, Branch:master, Time: 2013-10-23_17:16:46

this is the oldest TB daily build of master I had archived and available at the moment.
Comment 10 Joel Madero 2014-02-05 18:58:45 UTC
@V Stuart Foote: Original poster admits that it was present at some point during 3.6 - I think we can safely assume at least 4.0 release
Comment 11 V Stuart Foote 2014-02-05 19:20:19 UTC
@Joel,
(In reply to comment #10)
> Original poster admits that it was present at some point
> during 3.6 - I think we can safely assume at least 4.0 release

Nope! OP does not. And the 'paste special' with 'skip empty cells' option works correctly through 4.1.5 release. Only reproducible, using OPs correct .ods sample document, from 4.2.0.0.alpha0 builds of master and newer.

Not certain, but suspect is has to do with defining 'empty cells' in Kohei's rework of cell type committed to master late-June, so not present at all in the 4.1.0 branch.
http://cgit.freedesktop.org/libreoffice/core/commit/?id=c008dc483f8c6840803983e7e351cec6fdd32070 and friends.
Comment 12 Joel Madero 2014-02-05 19:21:18 UTC
ah maybe I misinterpreted "has broken since from the previous 3.6 release" -- thanks for clarifying
Comment 13 David Clayton 2014-02-05 21:38:53 UTC
Hi all,

I am overwhelmed by the speed and number of responses, thank you all. Apologies that my post was late on, after a long day and I should have gone into greater detail with my explanation. 

As far as I know the bug was not present in either the 3.6 or more recently the 4.1.4 releases, I therefore believe it to have only come in with the most recent 4.2 version (sorry for the confusion with my first post).

I should have also typed the steps up to reproduce, but I had hoped that I had entered sufficient detail on my test case document to provide the necessary steps.

I hope that gives enough information to go at.
Comment 14 V Stuart Foote 2014-02-05 22:09:49 UTC
Verified the issue also exists on Linux builds 
Redhat EL6 (Centos build)
2.6.32-358.23.2.el6.x86_64 #1 SMP

With LibreOffice 4.2.0 final
Version: 4.2.0.4
Build ID: 05dceb5d363845f2cf968344d7adab8dcfb2ba71

So expect the same on OS X.

@David,
In reply to comment #13)
 > I should have also typed the steps up to reproduce, but I had hoped that I
> had entered sufficient detail on my test case document to provide the
> necessary steps.
> 
> I hope that gives enough information to go at.

Nah, as you said the .ods sample has all needed details. Only rub was dropping it directly in as a mab4.2 (bug 65675 )--although it may end up back there. 

Again thank you for posting! The refactoring across the entire Calc component for 4.2.0 was very substantial. There are liable to be some other "gotchas" like this lurking. Keep reporting.
Comment 15 Joel Madero 2014-02-05 22:15:32 UTC
Indeed, no harm no foul :) I've been a bit more aggressive about pulling bugs off of MAB because so many people are throwing their own bugs on there and it's clogging up the system ;)

As for steps - in general a good idea to include them but in this case since it was verified by one of our experts no need :) Knowing it exists on Linux now makes a bibisect even more helpful.

I may have time this weekend to do a couple bibisects but currently just overloaded
Comment 16 V Stuart Foote 2014-02-06 02:04:58 UTC
At home and dug out a few older TB builds of master, and it does seem to be related to the refactoring.

With the 2013-06-13_20.49.30 build
Version: 4.2.0.0.alpha0+
Build ID: 6372309a0d285f4a176dbcded3f18b72220e123
paste special with skip empty cells functioned correctly

With the 2013-06-27_01.06.16 build
Version: 4.2.0.0.alpha0+
Build ID: 7746de6e42d5957fa62fa278e2c46a0cb472dc01
paste special with skip empty cells fails as reported.
Comment 17 Joel Madero 2014-02-06 02:07:20 UTC
Okay I'm sold - let's toss it on the MAB list - Kohei doesn't monitor FDO emails but I think it'll get attention on MAB ad it belongs there as it's a confirmed recent regression.

@David - thanks for your patience and understanding about policies, in the end it got back where you put it but now it's been thoroughly vetted thanks to V Stuart Foote :)
Comment 18 Joel Madero 2014-02-06 02:16:23 UTC
Also changing it to "highest" per our new MAB procedures:)
Comment 19 V Stuart Foote 2014-02-06 02:17:22 UTC
@Joel,

Sounds like a plan, and to help your bibisect, just 600 commits for that period...

http://cgit.freedesktop.org/libreoffice/core/log/?qt=range&q=6372309a0d285f4a176dbcded3f18b72220e123..7746de6e42d5957fa62fa278e2c46a0cb472dc01
Comment 20 Kohei Yoshida 2014-02-06 15:05:38 UTC
I'll take this.  No bibisect needed.
Comment 21 Commit Notification 2014-02-06 19:10:22 UTC
Kohei Yoshida committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4f2482c6a82e2c32511cd9bd9adea863191f7199

fdo#74573: Write test for pasting with empty cells skipped.



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 22 Commit Notification 2014-02-06 19:10:37 UTC
Kohei Yoshida committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0c12aa670b83b76241077dfb8bc21f40a55b1667

fdo#74573: Skip deletion of destination area when 'skip empty' is on.



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 23 Commit Notification 2014-02-06 19:10:59 UTC
Kohei Yoshida committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4f2482c6a82e2c32511cd9bd9adea863191f7199

fdo#74573: Write test for pasting with empty cells skipped.



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 24 Commit Notification 2014-02-06 19:11:14 UTC
Kohei Yoshida committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0c12aa670b83b76241077dfb8bc21f40a55b1667

fdo#74573: Skip deletion of destination area when 'skip empty' is on.



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 25 Kohei Yoshida 2014-02-06 19:11:59 UTC
4.2 backport request: https://gerrit.libreoffice.org/7906
Comment 26 Commit Notification 2014-02-18 00:43:12 UTC
Kohei Yoshida committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d2a80bcd494039bcb54693a8461d1645e51d1c1b

fdo#74573: Test pasting of cell attributes as well.



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 27 Commit Notification 2014-02-18 00:43:27 UTC
Kohei Yoshida committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2f55cee39379a76920f3a4fb14e6c2774093bfcd

fdo#74573: Skip removing of cell notes on empty cells if the flag is set.



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 28 Commit Notification 2014-02-18 21:46:52 UTC
Kohei Yoshida committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=cdc8ebf9646e773351c91039a62f2414c7b02105

fdo#74573: Delete ranges that are non-empty before pasting from clipboard.



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 29 Kohei Yoshida 2014-02-25 16:44:41 UTC
We'll handle conditional formatting use case in a separate bug.  I've filed Bug 75500 for that.
Comment 30 Commit Notification 2014-02-26 05:01:53 UTC
Kohei Yoshida committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=166e2775d80b7e45ab258a4175d7b9e8a15a5dba&h=libreoffice-4-2

fdo#74573: Delete ranges that are non-empty before pasting from clipboard.


It will be available in LibreOffice 4.2.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 31 Kohei Yoshida 2014-02-26 05:09:55 UTC
I'll mark this fixed. As mentioned in Comment 29, the outstanding issue with conditional formatting paste situation will be handled in Bug 75500.
Comment 32 Robinson Tryon (qubit) 2015-12-15 22:24:05 UTC
Migrating Whiteboard tags to Keywords: ()
Remove redundant "regression" from Whiteboard.
[NinjaEdit]