Bug 74644 - EDITING: Fonts and text overlapping
Summary: EDITING: Fonts and text overlapping
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Khaled Hosny
QA Contact:
URL:
Whiteboard: BSA
Keywords: possibleRegression
: 74645 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-02-07 02:04 UTC by Julian Gutierrez
Modified: 2015-12-15 10:53 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of the text overlapped (383.16 KB, image/png)
2014-02-07 02:04 UTC, Julian Gutierrez
Details
Test document (18.98 KB, application/vnd.oasis.opendocument.text)
2014-02-16 18:48 UTC, Edward M. Grant
Details
Screenshot (104.63 KB, image/jpeg)
2014-02-16 18:49 UTC, Edward M. Grant
Details
Cardo font (1.01 MB, application/zip)
2014-02-16 18:50 UTC, Edward M. Grant
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Julian Gutierrez 2014-02-07 02:04:05 UTC
Created attachment 93579 [details]
Screenshot of the text overlapped

Problem description: Te fonts on a large doccument appear overlapped,not readable

Steps to reproduce:
1. Long text document (.docx)
2. Scroll down and the text shows overlapped

Current behavior: Text Overlapped, no change with zoom or font change on size or type, no chane when add new text to the paragraph, no change with screen or window resize

Expected behavior: Perfect readable text

              
Operating System: Ubuntu
Version: 4.2.0.4 release
Last worked in: 4.1.4.2 release
Comment 1 V Stuart Foote 2014-02-07 03:01:01 UTC
*** Bug 74645 has been marked as a duplicate of this bug. ***
Comment 2 V Stuart Foote 2014-02-07 03:09:09 UTC
@Julian,

The screen capture is good, and it certainly looks to be an issue. But it would be very helpful if you can attach the problem .docx format document, or a new example with similar formatting, that demonstrates this issue when opened in LibreOffice 4.2.0.4
Comment 3 Edward M. Grant 2014-02-16 18:48:04 UTC
I appear to be having the same problem. Files using Cardo font that worked fine on Linux Mint 15 (I think it's 4.0.x) and Scientific Linux 6 (again, I think it's 4.0.x) are rendered as garbage in Linux Mint 16 (4.1.3). I downloaded the official 4.2.0.4 in case it was fixed, but the display is still garbage.

Since this is the font I use for all my print on demand books, this is a pretty major issue.

I'll attach a sample document, screenshot and the Cardo font files in a moment.
Comment 4 Edward M. Grant 2014-02-16 18:48:58 UTC
Created attachment 94170 [details]
Test document
Comment 5 Edward M. Grant 2014-02-16 18:49:24 UTC
Created attachment 94171 [details]
Screenshot
Comment 6 Edward M. Grant 2014-02-16 18:50:05 UTC
Created attachment 94172 [details]
Cardo font
Comment 7 Edward M. Grant 2014-02-16 22:49:10 UTC
If it's any help, I found a Redhat bug related to the Cardo font:

https://bugzilla.redhat.com/show_bug.cgi?id=1000691

Changing the OS/2 metrics in the font to the values specified there cured this problem. I presume something has changed in how Libreoffice uses those values, and now it's hitting a bunch of fonts where they're incorrect.
Comment 8 Khaled Hosny 2014-02-17 08:30:12 UTC
(In reply to comment #7)
> If it's any help, I found a Redhat bug related to the Cardo font:
> 
> https://bugzilla.redhat.com/show_bug.cgi?id=1000691
> 
> Changing the OS/2 metrics in the font to the values specified there cured
> this problem. I presume something has changed in how Libreoffice uses those
> values, and now it's hitting a bunch of fonts where they're incorrect.

This is right, starting from 4.1, LibreOffice started using the correct vertical metrics for line spacing so broken fonts that went unnoticed before because they was relying on applications using the wrong metrics (common on Windows) are now exposed. I suggest repoerting this to Cardo developers in case they are unaware of it, but there is much we can do here.
Comment 9 Edward M. Grant 2014-02-19 04:49:21 UTC
Sure, I just sent an email to the Cardo font designer. I guess there are a bunch of other fonts that will have to be fixed, too.
Comment 10 chris.taylor 2014-10-01 13:37:51 UTC
Potential workaround:
I also experience this problem with Cardo. My workaround is as follows:

1. Begin typing in Cardo.
2. Make sure that at least one character on every line is either italicised or bold. The most convenient character to do this with is a space!

It's awkward, but it works for me. (Typing any character in Hebrew or Greek also 'fixes' the line height for me as well.)
Comment 11 Robinson Tryon (qubit) 2015-12-15 10:53:39 UTC
Migrating Whiteboard tags to Keywords: (possibleRegression)
[NinjaEdit]