Download it now!
Bug 74677 - empty Cells in SUMPRODOCT(...) are evaluated as 1
Summary: empty Cells in SUMPRODOCT(...) are evaluated as 1
Status: RESOLVED DUPLICATE of bug 74479
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.0.3 rc
Hardware: x86-64 (AMD64) Linux (All)
: high critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2014-02-07 14:39 UTC by karolus
Modified: 2015-01-23 11:10 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Calc-document Sumproducterror (15.11 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-02-07 14:39 UTC, karolus
Details

Note You need to log in before you can comment on or make changes to this bug.
Description karolus 2014-02-07 14:39:10 UTC
Created attachment 93614 [details]
Calc-document Sumproducterror

Hallo

Empty Cells in =SUMPRODUCT-formula-Arrays are evaluated as 1, if the corresponding Cell is *not* empty.

I expect that they are evaluated as 0 as in prior Version of LO up to 4.1 

Test with:
Version: 4.2.0.3
Build-ID: c63c03decdf780d8fb80823950665b782ec9ecd0


Karolus
Comment 1 Julien Nabet 2014-02-08 17:51:26 UTC
On pc Debian x86-64 with master sources updated today, I can reproduce this.

Kohei/Markus/Eike: one for you?
Comment 2 Jacques Guilleron 2014-02-08 20:14:43 UTC
Hi karolus, Julien,

I reproduce too with LO 4.2.0.4 and LO 4.2.1.0.0+
Build ID: 7a7ef5a915f7e4f4a9a21b819ab1013d6333a8d8
TinderBox: Win-x86@42, Branch:libreoffice-4-2, Time: 2014-01-28_05:46:06

In this case we have an option to set to True:
In Tools > Options > LibreOffice Calc > Formula > Custom > Details :
Comment 3 Jacques Guilleron 2014-02-08 20:34:31 UTC
Treat empty string as zero.
This leave confuse this case where a empty cell is always treated as 1, but understood by any user as 0.

Sorry for the message in two parts,
Kind regards,

Jacques
Comment 4 Kohei Yoshida 2014-02-09 14:31:21 UTC

*** This bug has been marked as a duplicate of bug 74479 ***