Bug 74681 - UI SIDEBAR: keyboard navigation ParaPropertyPanel has out of order sequence [a11y]
Summary: UI SIDEBAR: keyboard navigation ParaPropertyPanel has out of order sequence [...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: Other All
: medium enhancement
Assignee: Caolán McNamara
QA Contact:
URL:
Whiteboard: target:4.3.0 target:4.4.0
Keywords:
: 78132 (view as bug list)
Depends on:
Blocks: Sidebar-Accessibility
  Show dependency treegraph
 
Reported: 2014-02-07 16:03 UTC by V Stuart Foote
Modified: 2016-10-25 18:36 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
ParaPropertyPanel - Vertical Spacing (9.84 KB, image/png)
2014-02-07 16:03 UTC, V Stuart Foote
Details
ParaPropertyPanel - Horizontal Indents (9.85 KB, image/png)
2014-02-07 16:04 UTC, V Stuart Foote
Details
No tooltips defined for the horizontal indents spinner tools (10.93 KB, image/png)
2014-02-07 16:06 UTC, V Stuart Foote
Details
ParaPropertyPanel - Vertical Spacing (9.84 KB, image/png)
2014-02-07 16:19 UTC, V Stuart Foote
Details

Note You need to log in before you can comment on or make changes to this bug.
Description V Stuart Foote 2014-02-07 16:03:29 UTC
Created attachment 93618 [details]
ParaPropertyPanel - Vertical Spacing
Comment 1 V Stuart Foote 2014-02-07 16:04:27 UTC
Created attachment 93619 [details]
ParaPropertyPanel - Horizontal Indents
Comment 2 V Stuart Foote 2014-02-07 16:06:02 UTC
Created attachment 93620 [details]
No tooltips defined for the horizontal indents spinner tools
Comment 3 V Stuart Foote 2014-02-07 16:19:38 UTC
Created attachment 93621 [details]
ParaPropertyPanel - Vertical Spacing

corrected MIME type
Comment 4 V Stuart Foote 2014-02-07 16:33:58 UTC
From implementation, the Paragraph Properties Panel 

ref /core/svx/source/sidebar/paragraph/ParaPropertyPanel.hrc

Has elements that are navigated by keyboard out of sequence. Namely  the vertical 'Spacing:' and the horizontal 'Indent:' blocks of controls need to be grouped into a vertical progression of controls for each.

As is currently, <TAB> and <Shift><TAB> jump from vertical spacing tool to horizontal indentation tool.  Very confusing!

Also, the spinner boxes for the increase before, increase after, and set hanging indentation paragraph controls have not 'tool tip' assigned and so are not announced to AT tools. Necessary to guide AT usage.
Comment 6 V Stuart Foote 2014-02-13 07:00:44 UTC
Caolán, *,

Much better now. Having the tool tips help.

On Windows 7 sp1, 64-bit with
Version: 4.3.0.0.alpha0+
Build ID: 6364a3ec6f92fc1f4ac3c7a4e2bdce2a2140c736
TinderBox: Win-x86@39, Branch:master, Time: 2014-02-13_01:44:32

Would it be a lot of work to expand the attachments of the UI vertical box upward to include the 'Increase Spacing' and 'Decrease Spacing' buttons and then drop into the 'Above Paragraph Spacing' and down onto the other spacing spinner and dropdown?

And the same to move the 'Increase Indent', 'Decrease Indent' and 'Switch to Hanging Indent' buttons to be blocked above the 'Before Text Indent' and down onto the other two indent spinners?

Also should this be ported back for the 4.2.1 build?
Comment 7 Commit Notification 2014-02-18 10:11:22 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d48dacc737fbae113de30f63083c93f815e40ed5

fdo#74681 improve keyboard navigation more



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 Caolán McNamara 2014-02-18 11:42:52 UTC
How about that ? (I have no problem backporting the sequence to 4.2, but I'd like to make sure we're happy with the final master version first)
Comment 9 V Stuart Foote 2014-02-19 04:03:20 UTC
(In reply to comment #8)
> How about that ? (I have no problem backporting the sequence to 4.2, but I'd
> like to make sure we're happy with the final master version first)

On Windows 7 sp1, 64-bit with NVDA 2013.3
Version: 4.3.0.0.alpha0+
Build ID: 637353bb46d3c7d9537e47e4e003aef78a0c0ab3
TinderBox: Win-x86@39, Branch:master, Time: 2014-02-19_01:39:31

Sequence of the layout is great. Thanks!

Only issues are that the 'Increase spacing' and 'Decrease spacing' pushButtons on the 'Spacing' horizontal tool bar have no Accessible name assigned, so in AccProbe the MSAA accName is blank (and not announced in AT). Not sure what is happening for AX or ATK.

The same lack of name on the 'Indent' horizontal toolbar but just for the 'Switch to Hangning Indent' pushButtons. 

The 'Line Spacing' buttonDropdown also is not named, so its function is not apparent when landing on the button.

The other pushButtons and the singleLine editable text of the spinners all are correct.

Would be of great help to get some feedback from OS X and a Linux ORCA users on the implementation.
Comment 10 Maxim Monastirsky 2014-05-01 10:30:29 UTC
*** Bug 78132 has been marked as a duplicate of this bug. ***
Comment 11 Jacobo Aragunde Pérez 2014-06-16 14:50:04 UTC
(In reply to comment #9)
> 
> Only issues are that the 'Increase spacing' and 'Decrease spacing'
> pushButtons on the 'Spacing' horizontal tool bar have no Accessible name
> assigned, so in AccProbe the MSAA accName is blank (and not announced in
> AT). Not sure what is happening for AX or ATK.
> 

I'm taking a loot at this, I can confirm it also happens in ATK. I don't understand why only those names are missing - the item definition in the .ui file contains the same information. Smells like a bug :S

> 
> Would be of great help to get some feedback from OS X and a Linux ORCA users
> on the implementation.

The navigation sequence looks good to me now :)
Comment 12 Commit Notification 2014-06-16 15:41:59 UTC
Jacobo Aragunde Perez committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=9b2582064882bb1a1caea72fe7754b8872a16413

fdo#74681: quick help may be used as accessible text



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 13 Jacobo Aragunde Pérez 2014-06-16 15:54:18 UTC
Once the patch above is validated I can push it to 4.3 branch. I don't know if it's appropriate backporting the fixes to 4.2 at this point of the cycle.
Comment 14 Jacobo Aragunde Pérez 2014-06-25 12:02:38 UTC
I think this can be considered resolved. Feel free to reopen if there's something that doesn't fit.
Comment 15 V Stuart Foote 2014-06-26 00:32:17 UTC
Verified fixed on master. Would be a good back port to 4.3

Thanks Jacobo & Caolán!
Comment 16 Jacobo Aragunde Pérez 2014-06-26 08:08:09 UTC
(In reply to comment #15)
> Verified fixed on master. Would be a good back port to 4.3
> 

Caolan's patch is already in 4.3 and mine is waiting for review here:

https://gerrit.libreoffice.org/#/c/9900/
Comment 17 Commit Notification 2014-06-27 10:41:15 UTC
Jacobo Aragunde Perez committed a patch related to this issue.
It has been pushed to "libreoffice-4-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=091eeeab04807795a8bc8cd78b9adb369a207ee6&h=libreoffice-4-3

fdo#74681: quick help may be used as accessible text


It will be available in LibreOffice 4.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.