Bug 74683 - EDITING - ODB files no longer function correctly on 64bit OSX when Java 7 is installed
Summary: EDITING - ODB files no longer function correctly on 64bit OSX when Java 7 is ...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: x86-64 (AMD64) Mac OS X (All)
: high major
Assignee: Stephan Bergmann
URL:
Whiteboard: target:4.3.0 target:4.2.2
Keywords:
: 75927 76040 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-02-07 16:39 UTC by Alex Thurgood
Modified: 2014-03-11 17:48 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Thurgood 2014-02-07 16:39:53 UTC
LibreOffice production release 4.2.0.4 on OSX Mavericks (64 bit only)

Oracle Java 7

Start LO
Load an existing ODB file made with a previous 32bit version of LO.
Click on Tables, Queries, Reports, or Forms

An error message is displayed :

opened : java.lang.UnsatisfiedLinkError : com.sun.star.sdbcx.comp.hsqldb.StorageFileAccess.isStreamElement(Ljava/lang/String;Ljava/lang/String;)Z

No table, query, form or report can be displayed.


Alex
Comment 1 Alex Thurgood 2014-02-07 16:45:08 UTC
Confirmed separately by user on German ML and English user ML
Comment 2 Alex Thurgood 2014-02-07 16:52:19 UTC
Note that if a user installs Apple's JVM, then there is no problem. 

However, I don't know if Apple's JVM is actively maintained, there don't appear to have been any updates since Mavericks release. Indeed, the Java update page from August 28, 2013 (kb/HT5648) links to Oracles Java 7 download...
Comment 3 Alex Thurgood 2014-02-07 16:53:59 UTC
So now, on Mavericks, anyone who updates their Java via the System preferences Java panel will be led to the Oracle 7 download
Comment 4 Stephan Bergmann 2014-02-07 16:55:36 UTC
(In reply to comment #0)
> LibreOffice production release 4.2.0.4 on OSX Mavericks (64 bit only)

This is about the 64-bit build of LO, <http://donate.libreoffice.org/home/dl/mac-x86_64/4.2.0/en-US/LibreOffice_4.2.0_MacOS_x86-64.dmg>, not the 32-bit build, <http://donate.libreoffice.org/home/dl/mac-x86/4.2.0/en-US/LibreOffice_4.2.0_MacOS_x86.dmg>, right?

> Start LO
> Load an existing ODB file made with a previous 32bit version of LO.
> Click on Tables, Queries, Reports, or Forms
> 
> An error message is displayed :

Does the same problem occur with a freshly created ODB file, or only when loading an old one?
Comment 5 Alex Thurgood 2014-02-12 18:36:36 UTC
(In reply to comment #4)

Hi Stephan,


> Does the same problem occur with a freshly created ODB file, or only when
> loading an old one?

Don't know, will have to test with new ODB file, and report back here.

Alex
Comment 6 Alex Thurgood 2014-02-12 18:50:28 UTC
Slightly different error message, but end result the same :

Impossible d'établir la connexion à la source de données "testjvm7".
Statut SQL: S1000
Code d'erreur: -27

file input/output error java.lang.NullPointerException.properties /Users/alex/Documents/testjvm7.odb


Using the wizard to create a new embedded hsqldb ODB file leads to this error message (because the DB creation wizard switches to the Table creation wizard on saving the ODB file).

Closing the ODB file, reloading it and attempting to click on the "Tables" button also gives the same error message as indicated above.

Attempting to bypass the UI via Tools > SQL also leads to the same error message.

No tables can be created. The OBD is essentially useless.

LO only recognises Java 7 update 51, despite Java 1.6_65 being installed.
Comment 7 Alex Thurgood 2014-02-12 19:11:45 UTC
Ok, so restarting LO after completely quitting, enabled me to reselect Apple's Java 6.

However, even with Java 6 as the preferred JVM, attempting to click on the Tables icon with my test odb still leads to the same error message as in Comment 6.

Alex
Comment 8 Stephan Bergmann 2014-02-13 08:58:48 UTC
(In reply to comment #7)
> Ok, so restarting LO after completely quitting, enabled me to reselect
> Apple's Java 6.

I meanwhile fixed that with <http://cgit.freedesktop.org/libreoffice/core/commit/?h=libreoffice-4-2&id=09749c7751e4c12a898f0c2f98b0c71ebe67ba6d> "Don't set JAVA_HOME on Mac OS X" towards LO 4.2.1.
Comment 9 Commit Notification 2014-02-13 21:47:13 UTC
Stephan Bergmann committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a76261ac9e40eb57e942db2c7aea8b8a5e904ff2

fdo#74683: java.lang.System.mapLibraryName dylib vs. jnilib confusion



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 10 Stephan Bergmann 2014-02-13 21:57:05 UTC
requested backports to libreoffice-4-2 towards LO 4.2.2 (<https://gerrit.libreoffice.org/#/c/8034/>) and libreoffice-4-2-1 (<https://gerrit.libreoffice.org/#/c/8035/>)
Comment 11 Commit Notification 2014-02-14 10:25:47 UTC
Stephan Bergmann committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3804d1c27128992593fe2d770293bfb189d308b1&h=libreoffice-4-2

fdo#74683: java.lang.System.mapLibraryName dylib vs. jnilib confusion


It will be available in LibreOffice 4.2.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2014-02-14 10:27:07 UTC
Stephan Bergmann committed a patch related to this issue.
It has been pushed to "libreoffice-4-2-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b7bf74bd0a1ccd5f8c8732474bc3e180617481fb&h=libreoffice-4-2-1

fdo#74683: java.lang.System.mapLibraryName dylib vs. jnilib confusion


It will be available already in LibreOffice 4.2.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 13 Michael Stahl (CIB) 2014-02-21 10:54:09 UTC
correcting target, since 4.2.1.1 is 4.2.1 release
Comment 14 Stephan Bergmann 2014-03-10 08:50:07 UTC
*** Bug 75927 has been marked as a duplicate of this bug. ***
Comment 15 Stephan Bergmann 2014-03-11 17:48:59 UTC
*** Bug 76040 has been marked as a duplicate of this bug. ***