Download it now!
Bug 74697 - BlueZ 5.0 - need support for Android Impress Remote
Summary: BlueZ 5.0 - need support for Android Impress Remote
Status: RESOLVED FIXED
Alias: None
Product: Impress Remote
Classification: Unclassified
Component: Android Remote App (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All Linux (All)
: medium normal
Assignee: Andrzej Hunt
URL:
Whiteboard: BSA target:4.3.0 target:4.2.4 target:...
Keywords:
Depends on:
Blocks:
 
Reported: 2014-02-07 20:36 UTC by Munzir Taha
Modified: 2015-02-13 19:22 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Munzir Taha 2014-02-07 20:36:44 UTC
Problem description: 
I couldn't connect Android Impress Remote to my Arch Linux system via bluetooth. I managed, however, to make wifi work. To debug the problem I tried to transfer files via bluetooth and it's working. I double checked that "Enable remote control" in the options are checked.

I am using:
libreoffice 4.2.0.4
bluez 5.14-1

Steps to reproduce:
1. Started impress
2. In Android I can see my laptop in the bluetooth tab.
3. Touching the name "localhost-0" gives Connection failed
              
Operating System: Linux (Other)
Version: 4.2.0.4 release
Comment 1 rogern 2014-02-19 22:35:23 UTC
Same here with Fedora 20:

LibreOffice 4.1.5.3 and LibreOffice 4.2.0.4,
bluez 5.14-1
Impress Remote 2.0.0
Android 4.4.2

It used to work with the previous Impress Remote, but since then both the Android and LibreOffice versions have changed.
Comment 2 Sylvain Deverre 2014-03-08 11:32:16 UTC
Same issue here (I'm using archlinux too with bluez5).

After investigating, I noticed that LibreOffice Impress uses the old Bluez4 D-BUS API, instead of the new Bluez5 D-BUS API (cf http://cgit.freedesktop.org/libreoffice/core/tree/sd/source/ui/remotecontrol/Server.cxx).

One solution to fix the problem is to downgrade to bluez4 (even if it's an UGLY solution and may break a lot of things, since bluez5 "replaces" bluez4 and is not compatible with it.
Comment 3 Michael Meeks 2014-03-14 11:33:24 UTC
I had a quick look at this on the plane; in theory the BlueZ 4.0 changes are documented, but in terms of a quick & easy "change this to that" migration guide, I didn't find anything.

http://www.bluez.org/bluez-5-api-introduction-and-porting-guide/

was a bit sparse; anyhow - the code that handles Linux / BlueZ stuff is (luckily) located in just a single module here:

http://cgit.freedesktop.org/libreoffice/core/tree/sd/source/ui/remotecontrol/BluetoothServer.cxx

there's nothing else; so - I suspect for an expert this would be a ~trivial port. Having said that - we ship on old platforms too - so we'd want to retain support for the old BlueZ version as well, with some dynamic detection at run-time.

Caolan - any idea if a RedHat expert (perhaps Bastien?) could give some insight here ? it's a shame to have the remote-control bit-rot to non-functioningness on Linux =)
Comment 4 Adolfo Jayme 2014-04-03 08:12:36 UTC
WIP: https://gerrit.libreoffice.org/#/c/8821/
Comment 5 Commit Notification 2014-04-10 19:29:21 UTC
Andrzej Hunt committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=664ceee384c07884cdb4fd8dbc80971bcadaa9a2

fdo#74697 Add Bluez 5 support for impress remote.



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2014-04-10 19:58:56 UTC
Andrzej Hunt committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=351829b239b07a9126a7ec29cf9095e359c77adc

Revert "fdo#74697 Add Bluez 5 support for impress remote."



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2014-04-10 20:59:59 UTC
Andrzej Hunt committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b15666fd7582729c75bd0dd1bd0cb5d7c5a77f0c

fdo#74697 Add Bluez 5 support for impress remote.



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2014-04-17 09:27:04 UTC
Andrzej Hunt committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3adb6f809f19d3132062bed405de5ef4444128a8&h=libreoffice-4-2

fdo#74697 Add Bluez 5 support for impress remote.


It will be available in LibreOffice 4.2.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 9 Ian Morris 2014-04-20 14:13:58 UTC
I just wanted to thank you all for this conversation. I am having this issue and it was a little tricky to track the issue down. Bluez4 - Bluez5. I did not know they existed.

I just downloaded the latest nightly build :-

libreoffice-4-2~2014-04-20_09.46.10_LibreOfficeDev_4.2.5.0.0_Linux_x86-64_rpm.tar.gz

My setup: Bluez 5.8-3.9.1 on OpenSuse 13.1. Bluetooth can browse the android phone OK.

And found that this is patch is not included. Or at least it does not work. However I note that the latest patch was included 2014-04-17 so may not have made it yet.

It would be nice if the libreoffice site had a mention indicating the requirement for a particular Bluez version.

I love this Android remote feature. I think it is truly awesome. However there seems to be virtually no advertising that such a cool tool exists.

I too would hate to lose it.

If this is an inappropriate post then perhaps you can forward to someone as food for thought.

Thanks again.
Comment 10 Commit Notification 2014-04-22 21:26:00 UTC
Andrzej Hunt committed a patch related to this issue.
It has been pushed to "libreoffice-4-1-6":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f84e67dbc791e34d3480e096f3aed43709868374&h=libreoffice-4-1-6

fdo#74697 Add Bluez 5 support for impress remote.


It will be available already in LibreOffice 4.1.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 11 Sylvain Deverre 2014-04-23 09:57:45 UTC
Now, it seems to work well with the latest nightly in 4.2 branchn thanks :)
Comment 12 Commit Notification 2014-04-30 08:20:33 UTC
Andrzej Hunt committed a patch related to this issue.
It has been pushed to "libreoffice-4-2-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4482307ba537d42a9654a78e8bbe3c321f5f9017&h=libreoffice-4-2-4

fdo#74697 Add Bluez 5 support for impress remote.


It will be available already in LibreOffice 4.2.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 13 Robinson Tryon (qubit) 2015-02-13 19:22:47 UTC
Moving bug to (new) 'Impress Remote' product.