Download it now!
Bug 74708 - EDITING: File saved wih error
Summary: EDITING: File saved wih error
Status: RESOLVED DUPLICATE of bug 85496
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA odf
Keywords:
Depends on:
Blocks:
 
Reported: 2014-02-08 11:38 UTC by Nick222
Modified: 2014-12-04 22:35 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
File that I cannot open after editing (24.68 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-02-08 11:38 UTC, Nick222
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nick222 2014-02-08 11:38:05 UTC
Created attachment 93651 [details]
File that I cannot open after editing

Xubuntu 13.10
LibreOffice 4.2.0.4
ID: 420m0(Build:4)

When I saved file after editing - I see one cell became empty.

I closed file and then try to open it - and see error message:

"Ошибка считывания.
Ошибка формата файла в поддокументе content.xml в позиции 2,62874(строка, столбец)."
(Read error - format file error - in position...)
Operating System: Ubuntu
Version: 4.2.0.4 release
Last worked in: 4.1.4.2 release
Comment 1 Jens S 2014-02-25 15:11:31 UTC
First open the file with a zip-tool, you may need to rename it to 111.zip
You will now find some folders and files of which you open content.xml with a proper text-editor (best if you have one with syntax-highlighting and position-marking - Gedit will do)
Go to the position 2,62874 - mark the whole tag around this position and delete it. Save the file and compress all files and folders again and rename it finally to 111.ods   Now you can open it.

The tag I removed looks like a very complex style formatting with a lot of direct formatting in the cell, but here it is:

<style:style style:name="T19" style:family="text"><style:text-properties fo:font-style="normal" style:font-size-asian="12pt" style:font-size-complex="12pt" style:font-style-asian="normal" style:font-style-complex="normal" fo:font-style="italic" style:font-size-asian="10pt" style:font-size-complex="10pt" style:font-style-asian="italic" style:font-style-complex="italic" fo:font-weight="bold" style:font-weight-asian="bold" style:font-weight-complex="bold"/></style:style>
Comment 2 Joel Madero 2014-02-26 02:54:55 UTC
I can confirm I can't open the file but that just shows that the file is corrupt - not much in terms of I can reproduce the corruption. Requesting advice but likely this one will go into INVALID unless we can get steps to actually reproduce the problem (a clean file that we can save and see the corruption would suffice)
Comment 3 tommy27 2014-05-03 12:23:10 UTC
according to previous comment I set status to NEEDINFO until a clean file is provided along exact steps to reproduce the corruption
Comment 4 Michael Stahl (allotropia) 2014-12-04 22:35:44 UTC
this is most likely a duplicate of bug 85496 which was fixed this week

*** This bug has been marked as a duplicate of bug 85496 ***