Bug 74715 - Mixing Japanese and alphabet freezes Calc
Summary: Mixing Japanese and alphabet freezes Calc
Status: RESOLVED DUPLICATE of bug 72470
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: x86 (IA32) Windows (All)
: medium blocker
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-02-08 17:16 UTC by Massimo
Modified: 2014-02-09 19:51 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screenshot (47.40 KB, image/gif)
2014-02-08 17:16 UTC, Massimo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Massimo 2014-02-08 17:16:26 UTC
Created attachment 93665 [details]
Screenshot

This is a new bug in 4.2 - never seen before. To reproduce it do the following (you need the Japanese Input Method Editor)

Open a Calc spreadsheet
In a cell type some alphabet and hit TAB: it works fine
In another cell type some Japanese and it TAB: it works fine
In a third cell type some Japanese followed by some alphabet and hit TAB: Calc freezes.
I am experiencing this on two different PC, Win7 32bit English and Win7 64bit French, both with Japanese as default for non-Unicode programs. I haven't checked it yet on a Japanese native environment, because I have the PC with Japanese Windows at office and I am writing from home. In any case this is a serious bug which makes Calc to crash.
See a screenshot - it's a GIF image, I hope it is shown as such and not as a bunch of character as in the other bug I have submitted yesterday.
Comment 1 Jorendc 2014-02-08 20:02:52 UTC
Hi,

Thanks for your bug report! Looks already fixed. Please have a look at this email: http://nabble.documentfoundation.org/Libreoffice-qa-Calc-freeze-issues-td4096055.html

Kind regards,
Joren

*** This bug has been marked as a duplicate of bug 72470 ***
Comment 2 Massimo 2014-02-08 20:41:49 UTC
When can we expect a bug free version? I have just uninstalled 4.2 and reinstalled 4.1.4 - it was simply impossible to work with the new version.
Comment 3 Jorendc 2014-02-09 19:50:51 UTC
(In reply to comment #2)
> When can we expect a bug free version? I have just uninstalled 4.2 and
> reinstalled 4.1.4 - it was simply impossible to work with the new version.

Well, a general bug-free version will not exist in _any_ software :-). But this bug is fixed in upcoming 4.2.1 version (see bug 72470). Following the release plan this version will be released between 3 and 9 March 2014. (See https://wiki.documentfoundation.org/ReleasePlan#4.2_release)

You can test this fix already out using our daily builds (see this comment https://bugs.freedesktop.org/show_bug.cgi?id=72470#c32).

Kind regards,
Joren