Bug 74729 - EDITING: Dragging up a cell with a formula delete destination cells(show "Delete contents" over the cross)
Summary: EDITING: Dragging up a cell with a formula delete destination cells(show "Del...
Status: RESOLVED DUPLICATE of bug 81803
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.7.2 release
Hardware: Other All
: low minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2014-02-08 23:43 UTC by m.a.riosv
Modified: 2014-08-15 07:11 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description m.a.riosv 2014-02-08 23:43:08 UTC
With:
Win7x64Ultimate
Version: 4.3.0.0.alpha0+ Build ID: 38ce69a1d10bd18b45b192ee4a5e650f817be676
TinderBox: Win-x86@39, Branch:master, Time: 2014-02-08_02:01:12

Enter:

A1: =1
A2: =a1+1
drag A2 a few cells down
drag the last cell up, the message is "Delete contents" and select cell are deleted.
Comment 1 Kevin Suo 2014-06-10 15:25:50 UTC
(In reply to comment #0)

Hi m.a.riosv, to reproduce your bug, I did the following:
1. I typed "1" in A1;
2. I typed "=A1" in A2.

But how can I "drag A2 a few cells down"? Would you please provide more detailed steps to reproduce your bug?

I set this as NEEDINFO at this moment. Please set back to UNCONFIRMED once you have provided the above info.
Thanks.
Comment 2 Kevin Suo 2014-06-10 15:40:39 UTC
Hi  m.a.riosv, I think I have understood the steps.

Steps to reproduce:
1. Type "1", "2", "3" in A1, A2, A3.
2. Select range A1:A3.
3. Put your at the right-bottom "black box" of the selected range (so the cursor becomes a "+").
4. Drag your mouse up untill you reach the top of A1, then release your mouse.

Current Behaviour:
Contents in A1:A3 are deleted.

Expected behaviour: 
The selected cell range should shrink when you drag the mouse up.

Tested and reproduce in 4.3.0.0 beta2. 
Also reproducible in 3.6.7 release, setting the version to 3.6.7.
Set status to NEW.

However, I think this is a minor bug, and when dragging there is a message showing "delete contents", so users are warned about the possible result of the operation. Set to LOW MINOR.
Comment 3 Kevin Suo 2014-06-10 15:42:25 UTC
There is no evidence showing that this is a regression, as I can reproduce in 3.6.7.2 release. Removing keyword "regression".
Comment 4 pierre-yves samyn 2014-06-20 10:20:02 UTC
Hi

I reproduce on windows 7/64 & Version: 4.3.0.1
Build ID: 67f5430184326974072b65403ef1d9d934fc4481

Other steps to reproduce:
1. Type "1", "2", "3", "4", "5" in A1, A2, A3, A4, A5
2. In B3 type =A3
3. Position the mouse on the bottom right of B3, and continue holding down the mouse button until the pointer changes to a cross-hair symbol and drag your mouse down to B5, then release your mouse.

Expected & actual result : formula copied
=A4 in B4
=A5 in B5

4. Select B3, Position the mouse on the bottom right of B3, and continue holding down the mouse button until the pointer changes to a cross-hair symbol and drag your mouse up to B1, then release your mouse.

Expected result:
=A1 in B1
=A2 in B2

Actual result!
B1, B2 are empty

This is a regression indeed

In addition, the operation is inconsistent:
5. Select B3, Position the mouse on the bottom right of B3, and continue holding down the mouse button until the pointer changes to a cross-hair symbol and drag your mouse up to B2, then release your mouse.

Message "delete contents" appears but the formula is in B2 (=A2)
Therefore, copying works cell by cell.

Regards
Pierre-Yves
Comment 5 Jean-Baptiste Faure 2014-06-21 08:35:45 UTC
If you drag on only one cell it works but if you drag on several cells all cells are emptied.

Best regards. JBF
Comment 6 ign_christian 2014-08-15 04:58:01 UTC
Hi all.. I guess this is the same as Bug 81803 that was introduced in 4.3.x & has been fixed by Markus.

Could someone confirm that?
Comment 7 Kevin Suo 2014-08-15 07:11:47 UTC
I confirm this bug is fixed in 4.3.1.1, windows 7 x86.
Build ID: c4b15cd4d00dec6b266fa830b4ba73e31ae6ce73

*** This bug has been marked as a duplicate of bug 81803 ***