Bug Hunting Session
Bug 74732 - Cannot add glue point to a connector
Summary: Cannot add glue point to a connector
Status: RESOLVED DUPLICATE of bug 95141
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: low enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Connectors
  Show dependency treegraph
 
Reported: 2014-02-09 02:40 UTC by Owen Genat (retired)
Modified: 2016-05-03 15:46 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Owen Genat (retired) 2014-02-09 02:40:29 UTC
This appears to be a limitation in the current LO (and Apache OO) implementation of ODF. The related AOO issue is:

https://issues.apache.org/ooo/show_bug.cgi?id=18806

... but there does not appear to be a related LO bug report, hence this report.

The ODF v1.2 specification indicates for the draw:connector element (10.3.10, pp.212-213):

> Start and/or end points can be defined by references to glue points 10.3.16 
> or as absolute positions. ...
>
> The <draw:connector> element has the following child elements: 
> <draw:glue-point> 10.3.16 ...

For the `draw:glue-point` element (10.3.16, p.216) the spec states:

> The <draw:glue-point> element specifies a point in the area of a drawing object
> to which a connector shape can connect. All drawing objects have four standard
> glue points located at the center of the four edges of the object's bounding box.
> Additional glue points may be added to a drawing object by inserting one or more
> <draw:glue-point> elements into a drawing object element.
>
> The <draw:glue-point> element is usable within the following elements: ...
> <draw:connector> 10.3.10, 

It would therefore seem it is possible to add a glue point to a connector.

Steps to reproduce:
1. Start Draw (empty document).
2. Insert two shapes e.g., rectangle and ellipse.
3. Connect the rectange and ellipse with a connector.
4. Select one of the shapes.
5. Click Glue Points toolbar button.
6. Click Insert Glue Point button on Gluepoints toolbar.
7. Notice that glue points can be added to the shape as required (mouse pointer changes to crosshair).
8. Select the connector.
9. Repeat steps 5-6.

Observed behaviour:
- It is not possible to add a glue point to the connector (mouse point never changes to required mode and clicking on the connector is ineffective).

Expected behaviour:
- In accordance with the ODF v1.2 spec it should be possible to add a glue point to the connector in similar manner to that for a shape.

Tested with Debian v7.3.0 x86_64 using v4.1.4.2 Build ID: 0a0440ccc0227ad9829de5f46be37cfb6edcf72 and Crunchbang 11 x86_64 using v4.2.0.4 Build ID: 05dceb5d363845f2cf968344d7adab8dcfb2ba71.
Comment 1 Owen Genat (retired) 2014-02-09 02:43:11 UTC
Apache OO bug added to See Also list. The related bug indicates this functionality has never existed so I am setting the Severity to enhancement.
Comment 2 Alex Thurgood 2015-02-01 11:44:51 UTC
Seems valid request for enhancement. Setting as such. Inherited from OOo.
Comment 3 Heiko Tietze 2016-05-03 15:46:13 UTC
If connectors would accept user-defined glue points the resulting segments will not have a predictable behavior when the objects are moved around. I think it's a good idea to limit glue points for ordinary lines. 

Closing this as duplicate of 95141, which contains the same argumentation.

*** This bug has been marked as a duplicate of bug 95141 ***