Bug 95141 - Allow connectors to be drawn with custom segments (see comment 2)
Summary: Allow connectors to be drawn with custom segments (see comment 2)
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
5.0.2.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 74732 (view as bug list)
Depends on:
Blocks: Connectors
  Show dependency treegraph
 
Reported: 2015-10-17 12:01 UTC by Danixu
Modified: 2016-05-03 15:46 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Danixu 2015-10-17 12:01:58 UTC
Hi,

It's possible to add some enhacements to draw connectors?, for example:
- A way to set a free position in node border, instead one of four preselected points.
- A way to add split points to connector lines to allow the user to move the path and avoy other nodes for example

Just like the line or arrow tool but keeping the nodes connected.

Thanks!!
Comment 1 Buovjaga 2015-10-20 07:41:20 UTC
(In reply to Danixu from comment #0)
> Hi,
> 
> It's possible to add some enhacements to draw connectors?, for example:
> - A way to set a free position in node border, instead one of four
> preselected points.

This can be done by adding glue points. Edit - Glue points. View - Toolbars - Glue points. You see the mouse turn into a + and you can insert the points to your shapes.

> - A way to add split points to connector lines to allow the user to move the
> path and avoy other nodes for example

What do you think about bug 76872?
I'm not sure I understand what you want, though.. a picture would be good.
Comment 2 Danixu 2015-10-25 09:50:05 UTC
Thanks for the info about the border points, i was searching on google but i did not find anything about that. Maybe i've used the wrong words.

About the other, better than a picture is a vídeo ;)

https://youtu.be/K5-68E9DjvY

The other feature request is a good option, but will be good to allow the user to set the full path of the connector or add new points to the connector line like you can do in "line and arrow":

https://youtu.be/W1_29TBkv7A

Of course a line can be used too like i've done in the video, but a connector is better because i can move the node and keep it connected instead to have to move the line too.

Greetings!!
Comment 3 Buovjaga 2015-10-26 08:00:09 UTC
Those Youtube videos are private, though.
Comment 4 Danixu 2015-10-26 20:50:09 UTC
Sorry, I do not usually upload videos to youtube. Fixed ;)
Comment 5 Buovjaga 2015-10-28 17:35:09 UTC
Ok, adjusted summary and set to NEW.
Comment 6 Heiko Tietze 2016-04-29 11:01:07 UTC
> Of course a line can be used too like i've done in the video, but a
> connector is better because i can move the node and keep it connected
> instead to have to move the line too.

How do you expect your complex connectors with infinite segments to work when the objects are moved? Simple connectors have a predictable behavior, which is a big pro. So my suggestion is to keep it as it is and use lines for the segements (as in your video).

Two issues in one report does not work well. The thing with glue points is solved, the other more or less too. Closing this report therefore, but feel free to open another one.
Comment 7 Heiko Tietze 2016-05-03 15:46:13 UTC
*** Bug 74732 has been marked as a duplicate of this bug. ***