Download it now!
Bug 74748 - : FILESAVE Images not saved after exit/Read error in docx file on FILEOPEN in 4.1.4.2
Summary: : FILESAVE Images not saved after exit/Read error in docx file on FILEOPEN i...
Status: RESOLVED DUPLICATE of bug 52226
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.4.2 release
Hardware: Other Windows (All)
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-02-09 15:21 UTC by colin.mercer
Modified: 2014-03-18 13:06 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Zip has copies of the docx and pdf files - see pdfs for what should be there. (43.47 KB, application/zip)
2014-02-09 15:21 UTC, colin.mercer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description colin.mercer 2014-02-09 15:21:45 UTC
Created attachment 93712 [details]
Zip has copies of the docx and pdf files - see pdfs for what should be there.

Images are not preserved in docx files over exiting and restarting Libre Office.  The Read Error comes when Libre Office is next used and the file re-opened.  So whilst it looks like a Save fault it could be an Opening fault!  Most probably in Save as Libre Office oens docx with images OK.

Using 4.1.4.2 and it still has the image read bug in docx files.  

The fault is trivial to reproduce.  Just create a document with text and insert some pictures.  Saving and continuing working whilst the document is still open is not a problem. But Save and Exit Libre Office.  Re-start Libre Office and the open the file ( I used Recent Documents).

I have attached a zip file with the relevant docx and pdfs that describe the sequence explicitly.

This bug is related to 52226 but is for Libre Office 4.1.4.2

The text in the final file is below
"Words written  Image Inserted from file on disk using insert image icon
Image appears in centre of line, very small. All acceptable and better than large initial image. Moved it to the right and enlarged.
All Ok.  Had not saved file so now saved as docx – effectively Save As.  Still AOK.
Typed this text and did a Save.  All still looks OK after the Save.
To save at this stage I am about to make a pdf copy.  First do ordinary save.  Then went to Explorer and made a backup just in case that has useful info to help debug.  Now save as pdf
OK after doing pdf (NB why can't the pdf save use as its starting position the current location for the text file?) 
PDF looks good.
So end of document so will save using the Save icon and then exit.

This is the previous saved testImageSave01.docx after I had exited Libre Office, then re-entered and selected via Recent Documents.
Will now Save As testImageSave02.docx  OK done now as pdf (pdf was this time pointing at last used folder)
Colin"

This is an extremely upsetting bug and has caused many of my colleagues to give up on Libre Office.  Please, please resolve.  It is reality that many people use docx files.  At home I use Open Office but at work I use Microsoft Word.  Saying that only odt files are really supported is like putting your head in the sand!
Comment 1 colin.mercer 2014-02-09 16:59:50 UTC
Hi I have just downloaded and tried Version: 4.2.0.4
Build ID: 05dceb5d363845f2cf968344d7adab8dcfb2ba71

Image saving across exit worked - hurrah! Must be quickest fix ever!!

Saw from release notes that a lot of work had been done on docx things. Guess someone fixed image saving but did not make an announcement.  For me this is a major bug fixed. But will try more extensive tests very soon.
Comment 2 colin.mercer 2014-02-10 00:51:26 UTC
Tried more extensive tests.  Now we have a Curate's Egg challenge, good in parts but not every where.  But seems improvement.

Problem now is it occurs when there are two images which are in the same horizontal space.  The images themselves are not overlapping
Comment 3 sophie 2014-03-18 13:06:28 UTC
This is a dup of bug 52226 - Sophie

*** This bug has been marked as a duplicate of bug 52226 ***