Download it now!
Bug 74774 - Number of child nodes of tag CubicBezierTo are incorrect.
Summary: Number of child nodes of tag CubicBezierTo are incorrect.
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.0.0.alpha0+ Master
Hardware: IA64 (Itanium) Linux (All)
: medium normal
Assignee: Umesh Kadam
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-02-10 07:38 UTC by Umesh Kadam
Modified: 2014-02-14 12:26 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
File contains shapes (116.12 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2014-02-11 05:41 UTC, Umesh Kadam
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Umesh Kadam 2014-02-10 07:38:06 UTC
Number of children required by cubicBexTo is 3 of type "pt". Whereas the document contains less number of children.
Comment 1 Regina Henschel 2014-02-10 18:22:25 UTC
The context is not detailed enough. Do you want to report an error with reading a file, or with writing a file? Do you speak about native file format, or about import or export? Please attach a small file, that makes it easy to reproduce the problem.
Comment 2 Umesh Kadam 2014-02-11 05:35:24 UTC
@Regina Henschel : Sorry for the incomplete details, I just wanted to figure out the root cause and then add the comments/file.

Please find below are the details:

Issue :
---------
Unable to open the round trip file as it is resulting in corruption.

1) Open the attached file "3-A-SSI-Education-Program-2013.docx" in LibreOffice
2) Click File -> Save As (Microsoft Word 2007/2010 (.docx))
3) Try opening the saved file in MS Office 2010.

Expected behavior:
---------------------
File should be opened without any error messages

Observed behavior:
--------------------
While opening the file in MS Office an error is displayed saying "Unspecified Error"
Comment 3 Umesh Kadam 2014-02-11 05:41:44 UTC
Created attachment 93827 [details]
File contains shapes
Comment 4 Jorendc 2014-02-12 19:33:53 UTC
Reproducible, tested using Mac OSX 10.9 with LibreOffice Version: 4.3.0.0.alpha0+ Build ID: a315454f349469923490e4116806ee19263849b8

Kind regards,
Joren
Comment 5 Umesh Kadam 2014-02-14 12:26:07 UTC
code merged to master.