Bug 74785 - vertical operations on multiple cells cause program crash
Summary: vertical operations on multiple cells cause program crash
Status: RESOLVED DUPLICATE of bug 72470
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-02-10 11:20 UTC by Michael
Modified: 2015-01-24 13:12 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
smaple file, crashes spreadsheet (27.71 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-02-10 11:20 UTC, Michael
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael 2014-02-10 11:20:31 UTC
Created attachment 93755 [details]
smaple file, crashes spreadsheet

When doing operations on a vertical range of cells the program crashes. The same operations work normally when applied to an horizontal range of cells.

The issue occurs on a particular file (attached) that was imported from CSV so there are no formatting issues at least on the source file.

The same issue does not happen on manually created files with similar content.

The same issue does not occur on Ver. 4.1.4.2.

1. Open attachment
2. Select Column C -> Delete Column
or
2. Select about 10 cells on a vertical range -> delete
3. 100% CPU indefinitely

I suppose something in the import from CSV mechanism is broken.
Comment 1 m.a.riosv 2014-02-10 15:22:42 UTC
Hi Michael, thanks for reporting.

I think this problem happens when there are different type of languages.

This was fixed in https://bugs.freedesktop.org/show_bug.cgi?id=72470

Works for me with:
Win7x64Ultimate
Version: 4.2.1.0.0+ Build ID: 0d8253bc17cb5476fb558c0e17f5422d76f3e3db
TinderBox: Win-x86@42, Branch:libreoffice-4-2, Time: 2014-02-07_23:08:31

Please if you are not agree, reopen it.

*** This bug has been marked as a duplicate of bug 72470 ***