Bug Hunting Session
Bug 74794 - An image put in the right header only, appears on every odd and even pages on reload.
Summary: An image put in the right header only, appears on every odd and even pages on...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: x86 (IA32) Linux (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2014-02-10 14:11 UTC by pamartin64
Modified: 2015-07-07 19:34 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
The header image is anchored to paragraph (40.30 KB, application/vnd.oasis.opendocument.text)
2014-02-11 07:19 UTC, pamartin64
Details
The header image is anchored as character (40.29 KB, application/vnd.oasis.opendocument.text)
2014-02-11 07:22 UTC, pamartin64
Details
This document is created fine, but when you open it again bad image header (all pages, not only in izquiedas pages) appears (39.34 KB, application/vnd.oasis.opendocument.text)
2014-02-12 09:21 UTC, pamartin64
Details

Note You need to log in before you can comment on or make changes to this bug.
Description pamartin64 2014-02-10 14:11:20 UTC
When I put an image on top of the first page with the option of left / right just off content I image appears only on the left pages, but to save it as odt and reopen me appears on all pages, if I save it as doc appears good bone in the left pages only.

If to put the picture in the header, I say that the anchor is like character and save it as odt, if I respected.

I get this error from version 4.1.1 onwards.

I have ubuntu 10.04 (lucid) and download the packages from the page of Libreoffice.
Comment 1 Regina Henschel 2014-02-10 18:16:08 UTC
Please attach a small file showing the problem.
Comment 2 pamartin64 2014-02-11 07:19:13 UTC
Created attachment 93839 [details]
The header image is anchored to paragraph
Comment 3 pamartin64 2014-02-11 07:22:14 UTC
Created attachment 93840 [details]
The header image is anchored as character
Comment 4 Regina Henschel 2014-02-11 15:40:02 UTC
What I see: The page style has the option "Same content left/right" *not* checked. Therefore something on the right page header will not affect the left page header and vs. That is as expected.

Please try to reword your problem, I do not understand it.
Comment 5 pamartin64 2014-02-11 18:03:53 UTC
When I put an image on top of the first page and I have disabled it before left / right content and acitvado first page like me shows up well (only left pages) but when I keep the odt extension and I open me appears image in the header of all pages .

When I put text instead of image fails me when I open the document is still seen in the left pages including the first page .

When saved as doc also happens to me , looks good (only left pages including the first page).

When I put the image anchored as character , I get right to re-open the document (only visible in the left pages and the promera page).

When I put the image with another anchor , I get upset when I open it back to me appears on all pages , with the option same content left / right off .

All this happens on save with odt format to doc format when I save fails me , it all goes right
Comment 6 Regina Henschel 2014-02-11 22:42:59 UTC
OK, I've got it now.
Steps to reproduce:
1. Make document with about four pages with header on. Do *not* check "Same content left/right".
2. Put an image into the header of the right page, anchored to paragraph.
3. You need not write something into the header of the left page, it makes no difference.
4. Save the document.
5. Reopen the document.

Notice the inserted picture is on the left-side header too.

The error comes during opening. The document shows correctly in AOO.
Comment 7 pamartin64 2014-02-12 09:21:24 UTC
Created attachment 93921 [details]
This document is created fine, but when you open it again bad image header (all pages, not only in izquiedas pages) appears
Comment 8 pamartin64 2014-02-13 07:17:02 UTC
Sorry for the mistakes in my explanation of the problem, I hope you can now explain better.

What I want is to put an image and appear at the top of the left pages, bone on odd pages, but when I save the document in odt format and I open me not on the left pages, but appears in all the pages.

Here I list the steps I follow. 

1) Log Format - Page - Header - Same left / right and disable content.
2) Insert - Picture - From File in header.
3) The image appears on left pages only.
4) Save the document in odt format.
5) Return to open the document and the header image displayed on all pages.

attached

This document is created fine, but when you open it again bad image header (all pages, not only in left pages) appears
Comment 9 Regina Henschel 2014-02-13 09:58:10 UTC
Back to status NEW. The error is reproducible with Version: 4.2.0.4
Build ID: 05dceb5d363845f2cf968344d7adab8dcfb2ba71 on Windows 7.
Comment 10 pamartin64 2014-02-14 08:06:49 UTC
Any solution?
Comment 11 Regina Henschel 2014-02-14 10:57:27 UTC
Workaround: Use the page styles "Right Page" and "Left Page".
Comment 12 pamartin64 2014-02-14 17:04:51 UTC
But the documents that I have created and have pictures in the header of the left pages and in previous versions of the 4.1 is good showing now to open them is you show bad, I mean instead of appearing in the left pages, appear in all the pages.
Comment 13 pamartin64 2014-02-21 17:01:32 UTC
This is not important for nobody?
Comment 14 pamartin64 2014-04-10 07:27:16 UTC
Con la version 4.1.5 tambien falla.

With the 4.1.5 version also fail.

Sorry i am spanish.
Comment 15 Michael Weghorn 2015-07-06 19:31:08 UTC
I can reproduce the bug with "last42onmaster" in the "bibisect-43all" bibisect repository, but not with "last41onmaster".

However, the bug seems to have been fixed in the meanwhile.
I cannot reproduce it with with the latest commit in the "lo-linux-dbgutil-daily" bibisect repository (commit 64385c7555c6bbb089f3ab8b2a5b623cadd6ee7d) or with LibreOffice 4.3.7.2 ("LibreOffice Still") and 4.4.4.3 ("LibreOffice Fresh") just downloaded from the website.

Therefore I think, the bug should no more be present in all currently supported LibreOffice versions. Should it still be bibisected or can it be closed?
Comment 16 pamartin64 2015-07-07 06:10:03 UTC
Is all ok, can you close it.
Comment 17 Michael Weghorn 2015-07-07 19:34:54 UTC
I mark this bug as "resolved" according to the two previous comments.