Bug 74825 - Windows (x64): LibreOffice could not able to start as LCMS2.DLL is missing
Summary: Windows (x64): LibreOffice could not able to start as LCMS2.DLL is missing
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
4.3.0.0.alpha0+ Master
Hardware: x86-64 (AMD64) Windows (All)
: medium blocker
Assignee: Not Assigned
URL:
Whiteboard: target:4.3.0
Keywords:
Depends on:
Blocks:
 
Reported: 2014-02-11 07:15 UTC by Dushyant
Modified: 2014-02-13 06:37 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Detailed text from the System Event Viewer (1.13 KB, text/plain)
2014-02-11 07:15 UTC, Dushyant
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dushyant 2014-02-11 07:15:22 UTC
Created attachment 93837 [details]
Detailed text from the System Event Viewer

Installed the latest master build for WINDOWS(x64) from TinderBox # 42 (libo-master~2014-02-11_03.49.43_LibreOfficeDev_4.3.0.0.alpha0_Win_x86.msi)

While trying to open the LibreOffice, received and pop-up message that "The program can't start because LCMS2.DLL is missing from your computer. Try reinstalling the program to fix this problem."

Detailed text from the System Event Viewer is attached with the bug.
Comment 1 Adam CloudOn 2014-02-11 13:56:22 UTC
I am encountering the same problem on my Windows 8.1 machine.
After installing master from TinderBox#42 from today (11.02.2014) - cannot run it with same error.
Comment 2 Jorendc 2014-02-11 18:17:22 UTC
(In reply to comment #1)
> I am encountering the same problem on my Windows 8.1 machine.
> After installing master from TinderBox#42 from today (11.02.2014) - cannot
> run it with same error.

Lets mark as new then :)
Comment 3 Michael Stahl (CIB) 2014-02-11 19:04:02 UTC
problem was introduced by commit 4af38b099c741c3676aefeb20c515913aaeed666

got a fix locally but gerrit is down right now...
Comment 4 Michael Stahl (CIB) 2014-02-12 08:56:46 UTC
ah gerrit working again :)
Comment 5 Commit Notification 2014-02-12 08:57:11 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e3abec3f07f2a710bfce66f77b33f494e2aa4972

fdo#74825: fix missing lcms2/libxslt/curl in installation sets



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 6 V Stuart Foote 2014-02-13 06:37:39 UTC
confirmed fixed on Windows 7 sp1, 64-bit with
Version: 4.3.0.0.alpha0+
Build ID: 6364a3ec6f92fc1f4ac3c7a4e2bdce2a2140c736
TinderBox: Win-x86@39, Branch:master, Time: 2014-02-13_01:44:32