Download it now!
Bug 74886 - Charts - Data labels are not preserved after round trip
Summary: Charts - Data labels are not preserved after round trip
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
4.3.0.0.alpha0+ Master
Hardware: IA64 (Itanium) Linux (All)
: medium normal
Assignee: Markus Mohrhard
URL:
Whiteboard: target:5.0.0
Keywords:
: 80996 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-02-12 11:12 UTC by Umesh Kadam
Modified: 2015-04-20 03:40 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
File contains chart with data labels. (17.80 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2014-02-12 11:12 UTC, Umesh Kadam
Details
xlsx has the column chart with data lables. (11.12 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2014-04-23 08:55 UTC, Umesh Kadam
Details
RT file preserving the data lables. (7.39 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2014-04-23 08:56 UTC, Umesh Kadam
Details
Data labels still missing from exported Line Charts (13.22 KB, application/vnd.ms-excel.12)
2015-04-19 20:30 UTC, Luke
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Umesh Kadam 2014-02-12 11:12:07 UTC
Created attachment 93930 [details]
File contains chart with data labels.

The Data labels for the chart are not getting preserved after roundtrip.
Comment 1 Jorendc 2014-02-12 17:13:09 UTC
Reproduced, tested using Windows 8.1 with LibreOffice Version: 4.3.0.0.alpha0+
Build ID: 742d3987319944308a42fcdc19592bc441b761c2 TinderBox: Win-x86@39, Branch:master, Time: 2014-02-09_09:03:01

RT-file opened using MS Word 2010.

Kind regards,
Joren
Comment 2 Umesh Kadam 2014-04-23 08:55:45 UTC
Created attachment 97813 [details]
xlsx has the column chart with data lables.

test document.
Comment 3 Umesh Kadam 2014-04-23 08:56:27 UTC
Created attachment 97814 [details]
RT file preserving the data lables.

test document.
Comment 4 Matthew Francis 2015-01-16 15:36:43 UTC
*** Bug 80996 has been marked as a duplicate of this bug. ***
Comment 5 Luke 2015-04-18 10:04:49 UTC
Markus,
Both Excel and Calc open the round-tripped XLSX files without the data labels. 
Looking at the exported OOXML in xl\charts\chart1.xml we need to set:
<c:dLbls><c:spPr><c:showVal val="1"/>
For each data point in the chart. 

The XLS exporter doesn't appear to have any issue with Data Labels.
Comment 6 Markus Mohrhard 2015-04-18 17:42:27 UTC
That is actually again a MSO 2007 vs OOXML issue.

I have a fix for it based on my framework.
Comment 7 Commit Notification 2015-04-19 05:24:03 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=6f969d256fdbbc0b93d7baeec089afbbea94fc0e

use correct default value for OOXML and MSO 2007, tdf#74886

It will be available in 5.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2015-04-19 05:24:12 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=316f1505f1e0b1820c51913a11ae00b86a43cc13

add test case for data label default value import, related tdf#74886

It will be available in 5.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 9 Luke 2015-04-19 20:30:18 UTC
Created attachment 114926 [details]
Data labels still missing from exported Line Charts

Markus thanks to your recent work, the Bar and Pie charts are importing/exporting beautifully. Your effort is much appreciated.

The only issue I noticed is that the data labels are still being lost on round-tripping Line charts. Do you want to reopen this issue or should I file a new report?
Comment 10 Markus Mohrhard 2015-04-19 21:01:05 UTC
(In reply to Luke from comment #9)
> Created attachment 114926 [details]
> Data labels still missing from exported Line Charts
> 
> Markus thanks to your recent work, the Bar and Pie charts are
> importing/exporting beautifully. Your effort is much appreciated.
> 
> The only issue I noticed is that the data labels are still being lost on
> round-tripping Line charts. Do you want to reopen this issue or should I
> file a new report?

Please always a new bug with a test document. And just put me in CC: