Bug 74897 - Column delete causes crash
Summary: Column delete causes crash
Status: RESOLVED DUPLICATE of bug 72470
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-02-12 18:29 UTC by Tim G
Modified: 2014-02-13 00:46 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Original CSV (an export from X-CART 4.4.5) (1.00 MB, text/csv)
2014-02-12 18:29 UTC, Tim G
Details
ODS saved version of the CVS (151.76 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-02-12 18:33 UTC, Tim G
Details
.hang trace/dump from Mac OS X (333.63 KB, text/plain)
2014-02-12 18:39 UTC, Tim G
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tim G 2014-02-12 18:29:37 UTC
Created attachment 93953 [details]
Original CSV (an export from X-CART 4.4.5)

Problem description: Deleting a column from a specific document causes a crash

Steps to reproduce:
1. Import attached CSV with Character set "Unicode (UTF-8)", Language "Default - English (USA)", Separated by Comma, Text delimiter '"' (double quote) and all fields left at Standard for column type OR just open the ODS (it's the same thing saved in ODS, since LO will save the document fine)
2. Right-click the header of any populated column, select Delete Selected Columns

Current behavior:
Hangs ?indefinitely? (15+ minutes, so I'll call it a crash)

Expected behavior:
Column is deleted in about 1 second (as 3.6.0.4 can do it about that fast, see below)

Additional information:
Operating system is marked "All" because I reproduced it on both Windows 7 Professional (64-bit) and Mac OS X (10.7.4) 32-bit application, both 4.2.0.4. This problem does not exist in Mac OS X, program version 3.6.0.4 as I tried the exact same thing without issue and it takes about a second like one would expect. I got a .hang report from the Mac, so that's included.

In case the attachments don't work, files are also at:

http://www.pgrahamdunn.com/test/export_20140212_103811.csv
(Original CSV, an export from X_CART 4.4.5)

http://www.pgrahamdunn.com/test/export_20140212_103811.ods
(ODS saved version after CSV import; LO saves the doc just fine)

http://www.pgrahamdunn.com/test/soffice_2014-02-12-125744_LightSpeed-Dalton-Server.hang
(.hang report from the Mac)
Comment 1 Tim G 2014-02-12 18:33:04 UTC
Created attachment 93954 [details]
ODS saved version of the CVS

After importing the CSV, LO saves the file just fine, so here it is. I confirmed that using this file can reproduce the problem the same as doing the CSV import.
Comment 2 Tim G 2014-02-12 18:39:14 UTC
Created attachment 93955 [details]
.hang trace/dump from Mac OS X

I left the program for 15+ minutes before finally Force Quitting. This .hang dump was generated.
Comment 3 m.a.riosv 2014-02-13 00:46:08 UTC
Hi Tim, it is  not reproducible with:
Win7x64Ultimate
Version: 4.2.1.0.0+ Build ID: 684a0308dcb847f816967202ba87f536b83dcb4e
  TinderBox: Win-x86@42, Branch:libreoffice-4-2, Time: 2014-02-10_23:09:14

I think there were similar bugs, they were a duplicate of https://bugs.freedesktop.org/show_bug.cgi?id=72470, what I think is this.

Please if you are not agree, reopen it.

*** This bug has been marked as a duplicate of bug 72470 ***