Bug 74907 - CFBundleShortVersionString is set wrong
Summary: CFBundleShortVersionString is set wrong
Status: RESOLVED DUPLICATE of bug 74244
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: x86 (IA32) Mac OS X (All)
: medium trivial
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-02-12 22:16 UTC by Tim G
Modified: 2014-02-13 20:32 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
Excerpt from LibreOffice.app/Contents/Info.plist (line numbers included) (763 bytes, text/plain)
2014-02-12 22:16 UTC, Tim G
Details
Screenshot of Finder's Get Info for LibreOffice (30.56 KB, image/png)
2014-02-12 22:17 UTC, Tim G
Details
Screenshot of Finder window in 'columns' view (16.71 KB, image/png)
2014-02-12 22:19 UTC, Tim G
Details
Screenshot of LibreOffice download page (shows 4.2.0 as version number) (52.20 KB, image/png)
2014-02-12 22:23 UTC, Tim G
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tim G 2014-02-12 22:16:34 UTC
Created attachment 93963 [details]
Excerpt from LibreOffice.app/Contents/Info.plist (line numbers included)

I believe the CFBundleShortVersionString is set wrong for the 32-bit Mac OS X version. If the version is 4.2.0.4, I'd expect to see it written out entirely or to have 4.2.0 (as seen from the website download page, see mac_32_download_screen.png), or 4.2 (as seen on the root page of the LibreOffice website). The problem is that Mac OS X says 4.2.4 for the version because that's what the CFBundleShortVersionString is set to. Attachment Info_plist.txt shows the relevant excerpt from LibreOffice.app/Contents/Info.plist (line numbers included). The result is confusing to the end user as the results from the Finder's Get Info and what you see in the 'column' view in a Finder window don't make much sense; compare get_info.png and columns_view_info.png. Recommending that CFBundleShortVersionString be changed to 4.2.0.
Comment 1 Tim G 2014-02-12 22:17:55 UTC
Created attachment 93964 [details]
Screenshot of Finder's Get Info for LibreOffice

This location says "LibreOffice 4.2.0.4" as expected
Comment 2 Tim G 2014-02-12 22:19:16 UTC
Created attachment 93966 [details]
Screenshot of Finder window in 'columns' view

The Finder window in 'columns' view shows a confusing number 4.2.4; I'd expect 4.2.0.
Comment 3 Tim G 2014-02-12 22:23:50 UTC
Created attachment 93969 [details]
Screenshot of LibreOffice download page (shows 4.2.0 as version number)

The LibreOffice download page shows 4.2.0 for the three-section version number. This doesn't match the three-section version number seen in Mac OS X in the a Finder window set to 'columns' view (see columns_view_info.png)
Comment 4 Jorendc 2014-02-13 20:32:30 UTC
Thanks for reporting!

Looks already reported in bug 74244

*** This bug has been marked as a duplicate of bug 74244 ***