Bug 74915 - FILEOPEN: Certain doc/docx files won't open correctly.
Summary: FILEOPEN: Certain doc/docx files won't open correctly.
Status: RESOLVED DUPLICATE of bug 61594
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: high major
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2014-02-13 03:23 UTC by jaspionsystems
Modified: 2016-11-16 15:03 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
A 4-page file that Writer can't display correctly (shows only 1st page). (109.50 KB, application/msword)
2014-02-13 03:23 UTC, jaspionsystems
Details
Word document with table on two pages (17.92 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2015-11-26 10:35 UTC, Andrey Skvortsov
Details
Render of document with table on two pages in Word 2010 and LO 5.0.3 (145.29 KB, image/png)
2015-11-26 10:36 UTC, Andrey Skvortsov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jaspionsystems 2014-02-13 03:23:14 UTC
Created attachment 93985 [details]
A 4-page file that Writer can't display correctly (shows only 1st page).

Problem description: 
Certain files, I noticed most if not all have tables, do not open correctly in Writer. Normally they're only partly displayed, ending abruptly.

Steps to reproduce:
1. Just open the attached file.

Current behavior:
In this example Writer displays only one page. In fact the document it is 4 pages long. I have other examples I could send, let me know if you need them.

Expected behavior:
Correctly open the document.
              
Operating System: Windows 7
Version: 4.2.0.4 release
Comment 1 Jean-Baptiste Faure 2014-02-13 05:30:05 UTC
Reproducible with versions 4.2.1.0.0+ and the master under Ubuntu 13.10.

When opened in LO the table is inside a frame. It seems the problem comes from this frame, it seems that LO does not like frame larger than one page.

Best regards. JBF
Comment 2 Joel Madero 2015-05-02 15:44:18 UTC Comment hidden (obsolete)
Comment 3 jaspionsystems 2015-05-04 23:24:48 UTC
The bug is still present in version 4.4.2.2. It presents the same behaviour, showing only one page.
Comment 4 Andrey Skvortsov 2015-11-26 10:35:13 UTC
Created attachment 120809 [details]
Word document with table on two pages

I have similar issue with docx document. The simplified docx document to reproduce the problem is attached.  
In the next comment I'll attach screenshot of Word 2010 and LO side-by-side to show the problem.

Looks like LO doesn't split big frame into several pages. 
It just places the whole frame on one page and does not show the part of frame that does not fit into the page. 

This problem exists in
- Libreoffice 5.0.3 x64 (Windows)
- Libreoffice 5.0.3.2 x64 (Linux, from Debian repository).
Comment 5 Andrey Skvortsov 2015-11-26 10:36:39 UTC
Created attachment 120810 [details]
Render of document with table on two pages in Word 2010 and LO 5.0.3
Comment 6 Timur 2015-12-01 16:50:23 UTC
Both attachments have problem with reading table "Text wrapping" property. This can be verified by setting it from Around to None in Word. 
It's similar to Bug 78756, except problem there with attachment 99125 [details] started in 4.1, while here attachment 93985 [details] is wrong since OO and Andrey's attachment 120809 [details] is wrong since LO 4.0.
Comment 7 Timur 2016-09-29 15:38:15 UTC
This bug is about DOC attachment 93985 [details]. Looks to me like the same issue as Bug 78756, so I'll close. Please reopen if proved otherwise.
DOCX attachment 120809 [details] seems to be Bug 61594, which finally may be the same.

*** This bug has been marked as a duplicate of bug 78756 ***
Comment 8 Justin L 2016-11-16 15:03:40 UTC
bug 61594 is a closer duplicate for the problem in 947291 graficos REV.doc

*** This bug has been marked as a duplicate of bug 61594 ***