Bug 74979 - FILESAVE: Libreoffice calc screws formula when saving in sxc format
Summary: FILESAVE: Libreoffice calc screws formula when saving in sxc format
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: Other Linux (All)
: medium normal
Assignee: Kohei Yoshida
QA Contact:
URL:
Whiteboard: BSA
Keywords: regression
: 69489 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-02-14 13:29 UTC by alci
Modified: 2014-04-12 12:32 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description alci 2014-02-14 13:29:28 UTC
Problem description: 

Steps to reproduce:
- create a new spreadsheed document
- insert any formula
- save with sxc format
- re-open the file...

Current behavior:
all formulas are treated as text, and read as ooow:+formula

Expected behavior:
formulas work and my (potentialy big and important) document is not broken :-)
              
Operating System: Ubuntu
Version: 4.2.0.4 release
Comment 1 Björn Michaelsen 2014-02-15 20:32:53 UTC
confirmed by multiple downstream bugs
Comment 2 Björn Michaelsen 2014-02-15 21:17:43 UTC
*** Bug 69489 has been marked as a duplicate of this bug. ***
Comment 3 Kohei Yoshida 2014-02-15 21:36:16 UTC
.sxc export will be dropped in 4.3.0. Let's not make this a MAB.
Comment 4 Björn Michaelsen 2014-02-15 21:47:53 UTC
Ok, but maybe we should then drop the export in 4.2. too? Would be a in-series regression (well, sort of), but better removing the export than collecting more dupes here. As is the export isnt that useful: still better to force people to write ODS instead of broken sxc ...
Comment 5 Regina Henschel 2014-02-15 22:42:16 UTC
When will the sxc filter be removed? Currently they are still there.
(Version: 4.3.0.0.alpha0+ Build ID: ecf22894f522374cbdb8196d3bdef88e2fba7af9; TinderBox: Win-x86@47-TDF, Branch:MASTER, Time: 2014-02-15_01:01:54 )
Comment 6 Kohei Yoshida 2014-02-16 23:03:47 UTC
(In reply to comment #5)
> When will the sxc filter be removed? Currently they are still there.

Even in the Save as dialog?
Comment 7 Kohei Yoshida 2014-02-16 23:05:48 UTC
(In reply to comment #4)
> Ok, but maybe we should then drop the export in 4.2. too? Would be a
> in-series regression (well, sort of), but better removing the export than
> collecting more dupes here. As is the export isnt that useful: still better
> to force people to write ODS instead of broken sxc ...

Yeah I'd be fine with it.  We just need to backport the removal commit, plus some adjustment in the test that failed due to the removal.
Comment 8 Regina Henschel 2014-02-16 23:30:30 UTC
(In reply to comment #6)
> (In reply to comment #5)
> > When will the sxc filter be removed? Currently they are still there.
> 
> Even in the Save as dialog?

I've updated my version to Version: 4.3.0.0.alpha0+
Build ID: ecf22894f522374cbdb8196d3bdef88e2fba7af9
TinderBox: Win-x86@47-TDF, Branch:MASTER, Time: 2014-02-15_01:01:54

And indeed, it is no longer available, neither in "save" nor in "save as".
Comment 9 Kohei Yoshida 2014-04-11 16:01:34 UTC
4.2 backports:

https://gerrit.libreoffice.org/8937
https://gerrit.libreoffice.org/8938
Comment 10 Kohei Yoshida 2014-04-11 16:02:09 UTC
Those 2 backported commits will remove saving to those legacy file formats, including sxc.
Comment 11 Kohei Yoshida 2014-04-12 12:32:23 UTC
Fixed by removing sxc from the export filter list.