Bug 74994 - EDITING: Content disappears completely from sheet in various cells after cloning the sheet
Summary: EDITING: Content disappears completely from sheet in various cells after clon...
Status: RESOLVED DUPLICATE of bug 74414
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: Other All
: highest major
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: possibleRegression
Depends on:
Blocks: mab4.2
  Show dependency treegraph
 
Reported: 2014-02-14 17:08 UTC by Andy
Modified: 2015-12-15 10:53 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Calc file with sheet that loses data when copied/moved (70.04 KB, application/x-vnd.oasis.opendocument.spreadsheet)
2014-02-14 17:08 UTC, Andy
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andy 2014-02-14 17:08:01 UTC
Created attachment 94086 [details]
Calc file with sheet that loses data when copied/moved

Problem description: When you use the copy/move functions associated to each sheet of a calc file to duplicate a sheet into the same file or into another one, some cells completely lose their contents with no apparent reasons. Data is lost and nobody warns you if you do not check this thoroughly.
Moving instead of copying has the same problem, but it is even worse since you are left without the original sheet and your data are in this case totally gone if you do not spot the malfunction.
Also, if you clone the sheet in the same file, resulting in some wrongly empty cells in it, save it and reopen it, the content is gone not only on the the cloned sheet, but in the original one as well! S.O.S.

Steps to reproduce:
1. open attached calc file
2. right click on the tab of the only existing sheet "28-1-14" and choose move/copy
3. select "copy", choose the same file or another, new one at your will as destination. The newly obtained sheet is NOT a full copy of the original one: cells C2;D2;H2 and I2 are now empty while they were full of data in the original sheet.

Current behavior: the copy/move function worked correctly in 4.1.4

Expected behavior: the copied sheet should be a fully identical copy of the original one. As it is now, I cannot trust Calc in version 4.2 for any serious work. You're at risk of data loss.

              
Operating System: Windows 7
Version: 4.2.0.4 release
Last worked in: 4.1.4.2 release
Comment 1 sophie 2014-02-14 17:55:56 UTC
Reproduce by copying the sheet to a new file. Confirmed with Version: 4.2.0.4
Build ID: 05dceb5d363845f2cf968344d7adab8dcfb2ba71 Ubuntu 13.10 x64.
Set as New, raise to highest as there is dataloss and add to MAB. I didn't find duplicate. Sophie
Comment 2 Kohei Yoshida 2014-02-14 18:02:39 UTC
Sophie, Can you try reproducing this using a more recent 4.2.x build? We now have a pre-release 4.2.1 build available.  Thanks.
Comment 3 m.a.riosv 2014-02-15 03:16:39 UTC
Hi all.

Not reproducible.
Win7x64Ultimate.
Version: 4.2.1.1 Build ID: d7dbbd7842e6a58b0f521599204e827654e1fb8b

Maybe we can change to resolved-fixed.
Comment 4 Kohei Yoshida 2014-02-15 04:05:42 UTC
I remember fixing this one. There is a duplicate bug for this somewhere...
Comment 5 Kohei Yoshida 2014-02-15 04:07:28 UTC
Found it.

*** This bug has been marked as a duplicate of bug 74414 ***
Comment 6 Robinson Tryon (qubit) 2015-12-15 10:53:36 UTC
Migrating Whiteboard tags to Keywords: (possibleRegression)
[NinjaEdit]