Bug 75058 - Autofiler on column is extremely slow
Summary: Autofiler on column is extremely slow
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.1.1 release
Hardware: Other All
: medium normal
Assignee: Kohei Yoshida
QA Contact:
URL:
Whiteboard: target:4.3.0 target:4.2.5
Keywords: perf, regression
: 74650 75271 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-02-16 15:30 UTC by Baurzhan Muftakhidinov
Modified: 2015-12-15 11:40 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Example of CSV on which Calc's autofilter on column works slow (597.81 KB, application/octet-stream)
2014-02-16 15:30 UTC, Baurzhan Muftakhidinov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Baurzhan Muftakhidinov 2014-02-16 15:30:51 UTC
Created attachment 94163 [details]
Example of CSV on which Calc's autofilter on column works slow

Hello,

I am using Fedora 20 64-bit, LibreOffice 4.2.0 and 4.2.1 RC1

I import CSV file with ~150000 rows into Calc,
and then I add an autofilter to the one column.

But when I click on drop-down arrow, I get a filter
selection menu only after ~5-10 seconds, in that
time LO Calc is not responsive (it freezes).

Each action with autofilter on column is increadibly slow.

Regards

PS: I checked and autofilter on column works fast in Apache OpenOffice and in Gnumeric.

I have attached the file.
Comment 1 m.a.riosv 2014-02-18 01:23:46 UTC
Hi Baurzhan, thanks for reporting.

Please what is the character set and language of CSV file?
Comment 2 Baurzhan Muftakhidinov 2014-02-18 01:25:39 UTC
Hi,
It is Russian and UTF-8
Comment 3 m.a.riosv 2014-02-18 02:12:33 UTC
Reproducible with:
Win7x64Ult.
Version: 4.2.0.4 Build ID: 05dceb5d363845f2cf968344d7adab8dcfb2ba71
Version: 4.2.1.1 Build ID: d7dbbd7842e6a58b0f521599204e827654e1fb8b

Hangs with the processor at maximum. After five minutes I shut down the program.

With:
Version: 4.0.6.2 (Build ID: 2e2573268451a50806fcd60ae2d9fe01dd0ce24)
Version: 4.1.6.0.0+ Build ID: 2e2040401d99fe116b65b9661c3d4755091a660
doesn't hang, but doesn't offer the filter dialogue, does nothing.
Comment 4 Commit Notification 2014-04-30 01:31:25 UTC
Kohei Yoshida committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0b03f7ed575838f90e6b1ebec3538a3a214f81fb

fdo#75058: Optimize autofilter item filling for non-tree items.



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 Kohei Yoshida 2014-04-30 01:37:03 UTC
*** Bug 74650 has been marked as a duplicate of this bug. ***
Comment 6 Commit Notification 2014-04-30 14:43:09 UTC
Kohei Yoshida committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5e1fdc8cdf3bd35cee2e7c193827f5f5a1c534ac&h=libreoffice-4-2

fdo#75058: Optimize autofilter item filling for non-tree items.


It will be available in LibreOffice 4.2.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 Kohei Yoshida 2014-04-30 14:46:03 UTC
Fixed for 4.2.5.  There will still be a slight pause, but the pause should be a few seconds, not a few minutes.
Comment 8 Jean-Baptiste Faure 2014-04-30 18:01:22 UTC
(In reply to comment #7)
> Fixed for 4.2.5.  There will still be a slight pause, but the pause should
> be a few seconds, not a few minutes.

Indeed, it is not as fast as in LO 4.1 but it is far better than before.

Thank you Kohei !

Best regards. JBF
Comment 9 Jean-Baptiste Faure 2014-09-04 05:30:32 UTC
*** Bug 75271 has been marked as a duplicate of this bug. ***
Comment 10 Robinson Tryon (qubit) 2015-12-15 11:40:00 UTC
Migrating Whiteboard tags to Keywords: (perf)
[NinjaEdit]