Bug 75069 - Freeze or lock when clearing direct formatting from a URL containing Asian characters
Summary: Freeze or lock when clearing direct formatting from a URL containing Asian ch...
Status: RESOLVED DUPLICATE of bug 72470
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: x86-64 (AMD64) macOS (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-02-16 23:13 UTC by Daniel Ashton
Modified: 2014-02-19 15:32 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Ashton 2014-02-16 23:13:38 UTC
I copied some HTML from my PayPal account transaction history, including this value as a link: Details Payment To 鲍 天穗 23383394AY510781J 

This and another cell both containing a link with extended character-set characters each cause LO Calc to freeze (spinning beachball) when I try to Clear Direct Formatting from the context menu or from the main menu or with Ctrl-M.

The actual URL of the link uses normal characters. Similar cells above and below either of these, containing similar links with similar URLs, do not cause the spinning beachball. So I conclude that the Asian characters in the text of the link are causing the problem.
Comment 1 Daniel Ashton 2014-02-16 23:26:42 UTC
The same symptoms result if you try to paste the formatting from an adjacent cell into one of these cells.

Specifically, I used the formula bar to copy the text of the link, then deleted the link from the cell. I then use Edit -> Paste Special to paste the text as unformatted text (not RTF).  I copied one of the other cells (which had had direct formatting cleared from it) and tried to paste only the format into the Asian-text cell. This also caused a spinning-beachball freeze.
Comment 2 m.a.riosv 2014-02-18 01:18:20 UTC
Hi Daniel, thanks for reporting.

Seems a duplicate of https://bugs.freedesktop.org/show_bug.cgi?id=72470

The mentioned bug is resolved in 4.2.1.1, please download and test in:
http://downloadarchive.documentfoundation.org/libreoffice/old/4.2.1.1/

Please if you can reproduce with 4.2.1.1, reopen the bug, and if possible attach a minimal file for reproduce the issue.

*** This bug has been marked as a duplicate of bug 72470 ***
Comment 3 Daniel Ashton 2014-02-18 02:45:27 UTC
Confirm that I cannot recreate this behaviour using 4.2.1.1.

However, while mousing around in an unsaved spreadsheet trying to test this bug, I hit a pathological Save behaviour that seemed related to this.  The Save bar at the bottom of the window displayed and seemed to be "saving" repeatedly. While this was happening I could click in some cells, but the cell with the mixed Western and Asian characters would not accept my mouse-click.  I was eventually able to close the window using the Window menu: clicking the Mac OS X red candy close button seemed to have no effect.
Comment 4 m.a.riosv 2014-02-18 03:26:37 UTC
Please Daniel, can you fill a new bug.
I think it happens with a new files, with auto-recovery on, prior the first save of the file. I think it was reported before but I can't find it.
Comment 5 Daniel Ashton 2014-02-19 15:32:39 UTC
That looks similar to #73015
  https://bugs.freedesktop.org/show_bug.cgi?id=73015