Bug Hunting Session
Bug 75137 - Can't Move Cursor Between Footnotes with Up/Down Arrow Keys. Need to Click with Mouse
Summary: Can't Move Cursor Between Footnotes with Up/Down Arrow Keys. Need to Click wi...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: All All
: highest normal
Assignee: Takeshi Abe
URL:
Whiteboard: target:4.5.0 target:4.4.0.0.beta3 tar...
Keywords: bibisected, regression
: 76467 (view as bug list)
Depends on:
Blocks: mab4.3
  Show dependency treegraph
 
Reported: 2014-02-18 06:55 UTC by Kumāra
Modified: 2015-12-17 07:38 UTC (History)
10 users (show)

See Also:
Crash report or crash signature:


Attachments
footnote (9.36 KB, application/vnd.oasis.opendocument.text)
2014-11-30 07:31 UTC, Kumāra
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kumāra 2014-02-18 06:55:35 UTC
This new version (4.2.0.4) prevents me from moving the cursor between footnotes with the up/down arrow keys. I used to be able to do that just fine on 4.1.4.2
Comment 1 Regina Henschel 2014-03-21 20:47:18 UTC
*** Bug 76467 has been marked as a duplicate of this bug. ***
Comment 2 Kumāra 2014-04-30 04:34:38 UTC
The ability remains possible with 4.1.5.3. Something broke it in the 4.2 series.
Comment 3 Kumāra 2014-05-31 09:57:40 UTC
As the duplicate bug report says that "This misbehavior occurs also on Ubuntu 12.04 LTS and LO 4.2.0.4.", I'm correcting the Platform to All.
Comment 4 Nico Dorn 2014-06-12 13:42:34 UTC
Confirmed with Version: 4.2.4.2 Build ID: 420m0(Build:2) on Kubuntu 13.10.

Nasty bug for all science writers!
Comment 5 Kumāra 2014-06-13 00:37:59 UTC
(In reply to comment #4)
> Nasty bug for all science writers!

It's an annoyance for anyone who uses footnotes heavily. I'm still sticking with 4.1.6 just because of this.
Comment 6 Björn Michaelsen 2014-07-12 20:13:03 UTC
MABs should be priority highest.
Comment 7 Kumāra 2014-08-05 10:55:34 UTC
(In reply to comment #6)
> MABs should be priority highest.

Thanks. LO4.3 is out and still no sign of this regression being fixed.

Me, still sticking with 4.1.6.
Comment 8 sinai 2014-08-08 14:10:49 UTC
Please let you consider the priority of this bug as the highest. All scientific texts contains a lot of footnotes. It is very difficult to edit this kind of text. It is impossible to use the mouse permanently if you wish to go just to the nearest footnote up or below: if the next footnote is on the next page you have to scroll the page, to find the footnote, oh! The process of editing is really nightmare... Please fix this bug! Thanks in advance.
Comment 9 Kumāra 2014-08-09 02:53:25 UTC
(In reply to comment #8)
> The process of editing is really nightmare... Please fix this bug!

I feel your pain, sinai. To save yourself the frustration, consider downgrading to 4.1.6.2, where the bug is not present. For me, all the improvements in 4.2 onwards don't outweighs the trouble of this bug. So, I simply decide to stick to  4.1.6.2 until this is fixed. Cheers!
Comment 10 tommy27 2014-09-30 05:36:40 UTC
added bibisectRequest to whiteboard. this is a regression introduce in 4.2.x
Comment 11 Xisco Faulí 2014-10-03 13:03:54 UTC
bibisected:

5538975d35ff811afdc3e49f9c877e873e4ed646 is the first bad commit
commit 5538975d35ff811afdc3e49f9c877e873e4ed646
Author: Bjoern Michaelsen <bjoern.michaelsen@canonical.com>
Date:   Thu Oct 17 10:51:51 2013 +0000

    source-hash-6571193609f4fb4e5ac714b55787d172a86983fe
    
    commit 6571193609f4fb4e5ac714b55787d172a86983fe
    Author:     Takeshi Abe <tabe@fixedpoint.jp>
    AuthorDate: Sun Jun 9 20:20:50 2013 +0900
    Commit:     Takeshi Abe <tabe@fixedpoint.jp>
    CommitDate: Sun Jun 9 20:22:22 2013 +0900
    
        sal_Bool to bool
    
        Change-Id: Ib712c9ebf8d8e6aae5e04fec19be629d3393f5d5

:100644 100644 3cef19a8ce60b5d4c26d7c97cb38ff862e6d62a2 cd52f1397b4bc843ec1f6adf3661e957a272fd50 M	ccache.log
:100644 100644 7cbe45be6078e323ec502d62369f59d577e0f77a 7f3f7cb76a4e20ef26e9783de30dba6661b78a49 M	commitmsg
:100644 100644 e8794194ac96b80b7384b7780d042bde3cb351d6 8dc29427abcaeb3c71e9895d3f7d81a3d50dd7da M	dev-install.log
:100644 100644 584b09689360451bfd449114bbacaa9e9a30c774 555daeca16359ddc6e7b8eaaa6a5a61a13a5fc51 M	make.log
:040000 040000 ce5b252a776619b386e04ca67abba6113c43e5ec 0652a658e755ad9ddc1131b7942742b56b1b63d8 M	opt

# bad: [423a84c4f7068853974887d98442bc2a2d0cc91b] source-hash-c15927f20d4727c3b8de68497b6949e72f9e6e9e
# good: [65fd30f5cb4cdd37995a33420ed8273c0a29bf00] source-hash-d6cde02dbce8c28c6af836e2dc1120f8a6ef9932
git bisect start 'latest' 'oldest'
# good: [e02439a3d6297a1f5334fa558ddec5ef4212c574] source-hash-6b8393474974d2af7a2cb3c47b3d5c081b550bdb
git bisect good e02439a3d6297a1f5334fa558ddec5ef4212c574
# bad: [4850941efe43ae800be5c76e1102ab80ac2c085d] source-hash-980a6e552502f02f12c15bfb1c9f8e6269499f4b
git bisect bad 4850941efe43ae800be5c76e1102ab80ac2c085d
# skip: [a043626b542eb8314218d7439534dce2fc325304] source-hash-9379a922c07df3cdb7d567cc88dfaaa39ead3681
git bisect skip a043626b542eb8314218d7439534dce2fc325304
# skip: [aba65c3e4c0df07e4909aeefb758cdb688242bf6] source-hash-827524abfb4b577d08276fde40929a9adfb7ff1a
git bisect skip aba65c3e4c0df07e4909aeefb758cdb688242bf6
# skip: [aba65c3e4c0df07e4909aeefb758cdb688242bf6] source-hash-827524abfb4b577d08276fde40929a9adfb7ff1a
git bisect skip aba65c3e4c0df07e4909aeefb758cdb688242bf6
# bad: [c81a8a0dcfc1ed095a80e4485c89dd0fcaf73f31] source-hash-c69ed33628ec0b7abf6296539cf280d6c4265930
git bisect bad c81a8a0dcfc1ed095a80e4485c89dd0fcaf73f31
# bad: [c81a8a0dcfc1ed095a80e4485c89dd0fcaf73f31] source-hash-c69ed33628ec0b7abf6296539cf280d6c4265930
git bisect bad c81a8a0dcfc1ed095a80e4485c89dd0fcaf73f31
# bad: [1d4980621741d3050a5fe61b247c157d769988f2] source-hash-89d01a7d8028ddb765e02c116d202a2435894217
git bisect bad 1d4980621741d3050a5fe61b247c157d769988f2
# bad: [ba096f438393091574da98fe7b8e6b05182a8971] source-hash-8499e78ca03c792f4fa2650e02b519094ba0baa8
git bisect bad ba096f438393091574da98fe7b8e6b05182a8971
# bad: [9daa289e178460daaafa4b3911031df5b8736218] source-hash-704292996a3731a61339b1a4a5c90c9403aa095f
git bisect bad 9daa289e178460daaafa4b3911031df5b8736218
# bad: [69bf614869471f46413fe1d2af5976b2e6d85084] source-hash-76dea8b2db906156e77f78738a68f932a15afd4b
git bisect bad 69bf614869471f46413fe1d2af5976b2e6d85084
# bad: [91c3e68c86f5b7143ab0de18c70c46de8314d6e1] source-hash-4e41227dd6af52ec562d10efcb365defba6bd36e
git bisect bad 91c3e68c86f5b7143ab0de18c70c46de8314d6e1
# good: [04368f86c5bdaf6bd8264585ca378f3c280d237d] source-hash-a47a153a7f75edfe3bce33f0d34b723cbd2d5195
git bisect good 04368f86c5bdaf6bd8264585ca378f3c280d237d
# bad: [5538975d35ff811afdc3e49f9c877e873e4ed646] source-hash-6571193609f4fb4e5ac714b55787d172a86983fe
git bisect bad 5538975d35ff811afdc3e49f9c877e873e4ed646
# first bad commit: [5538975d35ff811afdc3e49f9c877e873e4ed646] source-hash-6571193609f4fb4e5ac714b55787d172a86983fe
Comment 12 Kumāra 2014-10-30 09:39:48 UTC
(In reply to Xisco Faulí from comment #11)
> bibisected:

I don't know what that means, but it sounds a lot like some kind of progress. Thank you very much. Wonder if we could move a little closer to fixing the bug.

Would it be bad manners to cc the authors involved the "bad commit"?
Comment 13 Xisco Faulí 2014-11-03 08:31:53 UTC
Please do not add anyone as CC as we don't know the problematic commit yet.
For the time being, we just know that this regression was introduced in range http://cgit.freedesktop.org/libreoffice/core/log/?qt=range&q=a47a153a7f75edfe3bce33f0d34b723cbd2d5195..6571193609f4fb4e5ac714b55787d172a86983fe
You can find more information about bibisect in https://wiki.documentfoundation.org/QA/HowToBibisect
Comment 14 tommy27 2014-11-30 05:46:28 UTC
@Kumāra
please attach a test file with footnotes so it's faster to reproduce the issue
Comment 15 Kumāra 2014-11-30 07:31:02 UTC
Created attachment 110258 [details]
footnote
Comment 16 Kumāra 2014-11-30 07:31:48 UTC
(In reply to tommy27 from comment #14)
> @Kumāra
> please attach a test file with footnotes so it's faster to reproduce the
> issue


I find it odd that a confirmed regression bug should require a test file. Anyway, here you go.
Comment 17 tommy27 2014-11-30 08:24:20 UTC
there's nothing odd. a test file should have been there from beginning.
it's necessary to speed up the QA job so we don't have to recreate from scratch such a file.

if users create complete reports with clear descriptions and test files and/or screenshots we can test more bugs in less time, otherwise we have to test less bugs in more time.

so having said that, this bug persists even in 4.5.0.0.alpha0+
Build ID: 84a6d8eeaab540e5b2ea3baffd919903dff8c247
TinderBox: Win-x86@39, Branch:master, Time: 2014-11-22_23:41:04

moving this to mab4.3 list since 4.2.x is end if life
Comment 18 omvsj 2014-12-09 13:51:15 UTC
This bug also affects me.

Versión: 4.3.4.1
Id. de compilación: 430m0(Build:1)
Linux Mint 17.1
Comment 19 Commit Notification 2014-12-10 21:53:40 UTC
Takeshi Abe committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=dad173d9588e6abc2a465198b7d2881d4629246a

fdo#75137: Can't Move Cursor Between Footnotes with Up/Down Arrow Keys

It will be available in 4.5.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 20 Michael Stahl (CIB) 2014-12-10 21:54:25 UTC
Takeshi Abe tracked it down, thanks!
Comment 21 Commit Notification 2014-12-10 21:57:09 UTC
Takeshi Abe committed a patch related to this issue.
It has been pushed to "libreoffice-4-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f25212197b7862575f8427f4a9c0b999ee6d5fd4&h=libreoffice-4-4

fdo#75137: Can't Move Cursor Between Footnotes with Up/Down Arrow Keys

It will be available in 4.4.0.0.beta3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 22 Commit Notification 2014-12-10 21:59:37 UTC
Takeshi Abe committed a patch related to this issue.
It has been pushed to "libreoffice-4-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=08b1f9ba6800193ed0fa38cd5545c690b02bc014&h=libreoffice-4-3

fdo#75137: Can't Move Cursor Between Footnotes with Up/Down Arrow Keys

It will be available in 4.3.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 23 Kumāra 2014-12-11 04:08:42 UTC
(In reply to Commit Notification from comment #22)
> It will be available in 4.3.6.

Whoopee!
Comment 24 Kumāra 2014-12-15 10:14:58 UTC
(In reply to Commit Notification from comment #22)
> It will be available in 4.3.6.
> 
> The patch should be included in the daily builds available at
> http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
> information about daily builds can be found at:
> http://wiki.documentfoundation.org/Testing_Daily_Builds
> Affected users are encouraged to test the fix and report feedback.

I'd like to test it, but don't know which one to download.

I suppose I should see under libreoffice-4-3/

In it I see
 Linux-rpm_deb-x86@45-TDF/    14-Dec-2014 00:05    -   
 Linux-rpm_deb-x86_64@46-TDF/ 14-Dec-2014 17:52    -   
 MacOSX-x86@49-TDF/           14-Dec-2014 18:02    -   
 Win-x86@42/                  14-Dec-2014 00:05    -   
 Win-x86@51-TDF/              09-Dec-2014 12:12    -   

I'm using Windows. Which of the 2 below should I click on?

Anyway, I'm guessing the one for me to download is this one. Correct?

http://dev-builds.libreoffice.org/daily/libreoffice-4-3/Win-x86@42/2014-12-11_02.18.45/libo-43~2014-12-11_02.18.45_LibreOfficeDev_4.3.6.0.0_Win_x86.msi
Comment 25 Takeshi Abe 2014-12-16 00:48:17 UTC
> Anyway, I'm guessing the one for me to download is this one. Correct?
> 
> http://dev-builds.libreoffice.org/daily/libreoffice-4-3/Win-x86@42/2014-12-
> 11_02.18.45/libo-43~2014-12-11_02.18.45_LibreOfficeDev_4.3.6.0.0_Win_x86.msi
It should be.

FYI, I have tested
http://dev-builds.libreoffice.org/daily/libreoffice-4-3/MacOSX-x86@49-TDF/2014-12-11_01.20.06/
on Mac OS X, and confirmed that the issue has solved with the test document you uploaded.
Comment 26 Commit Notification 2015-06-22 11:08:41 UTC
Varun committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=9d9fbbdc1ec57715305563817ce0a7a638da7bda

Add test for tdf#75137 crsr movement b/w footnote

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 27 Robinson Tryon (qubit) 2015-12-17 07:38:11 UTC
Migrating Whiteboard tags to Keywords: (bibisected)
[NinjaEdit]