Bug 75143 - FILESAVE: Cannot save cells with borders having different width in format of MS Excel 97-2003
Summary: FILESAVE: Cannot save cells with borders having different width in format of ...
Status: RESOLVED DUPLICATE of bug 75130
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.1.5.1 rc
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2014-02-18 08:12 UTC by Alexander
Modified: 2014-02-24 03:57 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
the example (9.76 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-02-18 08:12 UTC, Alexander
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander 2014-02-18 08:12:50 UTC
Created attachment 94267 [details]
the example

Problem description: 
Cannot save cells with borders having different width in format of MS Excel 97-2003

Steps to reproduce:
1. Find attached a file containing cells with borders having different width
2. Save it in format MS Excel 97-2003
3. Close it and open it again

Current behavior:
The cells that had different border width now have borders with of the same width

Expected behavior:
The cells have borders as they had before conversion


Operating System: Windows 8
Version: 4.1.5.1 rc
Comment 1 m.a.riosv 2014-02-18 23:46:35 UTC
Hi Alexander, thanks for reporting.

Reproducible with:
Win7x64Ultimate
Version: 4.1.6.0.0+ Build ID: 2e2040401d99fe116b65b9661c3d4755091a660
Version: 4.2.0.4 Build ID: 05dceb5d363845f2cf968344d7adab8dcfb2ba71

Reproducible but only save the thicker border lines:
Version: 4.2.1.1 Build ID: d7dbbd7842e6a58b0f521599204e827654e1fb8b
Version: 4.2.1.0.0+ Build ID: 58df669ac734f4740cf1112867edb808789aae43
   TinderBox: Win-x86@42, Branch:libreoffice-4-2, Time: 2014-02-12_13:26:56
Version: 4.3.0.0.alpha0+ Build ID: ecf22894f522374cbdb8196d3bdef88e2fba7af9
   TinderBox: Win-x86@39, Branch:master, Time: 2014-02-15_01:01:17


Last working.
Version 4.0.6.2 (Build ID: 2e2573268451a50806fcd60ae2d9fe01dd0ce24)
Comment 2 Kohei Yoshida 2014-02-24 03:57:58 UTC
The fix for Bug 75130 makes it a little better.  But saving to xls does not preserve line widths in all cases because Excel doesn't support arbitrary line width. And there is no way around it.

*** This bug has been marked as a duplicate of bug 75130 ***