Download it now!
Bug 75169 - FILESAVE: Current working directory in links is duplicated when saving in .doc
Summary: FILESAVE: Current working directory in links is duplicated when saving in .doc
Status: RESOLVED DUPLICATE of bug 48463
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.1.1 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2014-02-18 19:12 UTC by Jean-Sébastien Gosselin
Modified: 2014-02-27 18:40 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jean-Sébastien Gosselin 2014-02-18 19:12:19 UTC
Problem description: 
I am using LibreOffice Version: 4.2.1.1 Build ID: 420m0(Build:1) from http://ppa.launchpad.net/libreoffice/ppa/ubuntu in Ubuntu 13.10.

When saving in .xls, links to other documents are saved wrong. It seems to duplicate the current working directory in the path. The problem is not present when saving in the .ods format.

Steps to reproduce:
1. Create a .xls document.
2. Link a cell of the .xls document to a cell of another .xls or .ods document. For example:
='file:///home/jsgosselin/Desktop/DOC1.xls'#$Sheet1.A1
3. Save the file as .xls
4. Open the file. The reference you created is now wrong:
='file:///home/jsgosselin/Desktop/home/jsgosselin/Desktop/DOC1.xls'#$Sheet1.A1
              
Operating System: Ubuntu
Version: 4.2.0.4 release
Comment 1 Joel Madero 2014-02-26 03:20:42 UTC
This actually is not a bug - marking as a duplicate - please read comment 17 on that bug as it clearly explains what's going on and why it is not a bug.

*** This bug has been marked as a duplicate of bug 48463 ***
Comment 2 Jean-Sébastien Gosselin 2014-02-27 18:30:53 UTC
Thanks for pointing this out to me. I appreciate it.

I do understand now that it is not technically a bug. I understand also LibreOffice team can't really do anything about it, since the problem comes from the specification of .doc files, am I right?

However, from a end user perspective, who doesn't know anything about these technicalities, it really looks and feels like a bug. It is hidden, there is nothing preventing the user from using the feature, and it is not working as intended.

I don't know how it could be made possible so at least, an error or a warning is issued to inform the end user of this limitation...

Best regards

Jean-Sebastien
Comment 3 Joel Madero 2014-02-27 18:40:48 UTC
Thanks for the feedback - we are trying to work out some way to give "limitation" warnings - but it's quite difficult. We do understand that end users could find this to be very troublesome :-/ Hopefully we figure something out