Download it now!
Bug 75177 - FILESAVE: DRAW crashes when saving as fodg using custom colors
Summary: FILESAVE: DRAW crashes when saving as fodg using custom colors
Status: RESOLVED DUPLICATE of bug 87108
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
4.1.3.2 release
Hardware: x86 (IA32) Windows (All)
: high critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-02-18 22:34 UTC by marluwie
Modified: 2015-02-04 10:39 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description marluwie 2014-02-18 22:34:13 UTC
Create Problem:
1. Open Libre Office Draw (tested with Version 4.0.x and 4.1.5.3)
1. Format -> Area... -> Colors -> Load Color List
2. Load any .soc file (even standard.soc)
3. File -> Save As... (or just Save, if possible)
4. Choose file type .fodg

Observed behavior:
Libre Office Draw crashes, and will ask, if I want to recover.

Expected behavior:
Save the current file as in fodg-format

More details:
The description shows the shortest path to the error. I can modify, add, remove colors and still save a file as fodg. But as soon as I load a soc-file, saving it as fodg crashes.

It maybe has something to do with embedding the loaded color scheme in the fodg file!? But this is just a lucky guess.
Comment 1 marluwie 2014-02-18 22:44:27 UTC
Indeed, if the check box at Format -> Area... -> Colors -> Embed is unchecked, saving the file as fodg is working. Embedding any color scheme seems to be the real problem. Loading a new color scheme is not necessary to cause the problem. Just check the Embed check box.
Comment 2 sophie 2014-02-21 09:36:01 UTC
Hi, I've tried with several .soc files and can't reproduce with 4.1.5.3 under Debian. - Sophie
Comment 3 Florian Reisinger 2014-09-04 13:46:35 UTC
Tested with Windows 7 x64 with Version: 4.4.0.0.alpha0+ Build ID: 5ef4bdc7b15686e55fa19f2e98a828763a0cfae6 TinderBox: Win-x86@42, Branch:master, Time: 2014-09-03_10:10:14. Could reproduce the bug
Comment 4 Caolán McNamara 2015-02-04 10:39:02 UTC

*** This bug has been marked as a duplicate of bug 87108 ***