Bug 75183 - Chinese conversion cause Impress crash if there is English in-between
Summary: Chinese conversion cause Impress crash if there is English in-between
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: All All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-02-19 04:52 UTC by Cheng-Chia Tseng
Modified: 2014-03-22 02:53 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cheng-Chia Tseng 2014-02-19 04:52:35 UTC
Type Chinese and English at the same time in any Entry Box.

Steps to reproduce:

1. Copy "臺灣 is Taiwan." and paste it to Impress
2. Select Tools > Language > Chinese Conversion, and press OK button.
3. Impress crashes

Expected result:

Chinese Conversion should work fine even when there are some Engilsh words in the text beside Chinese characters.
Comment 1 Kevin Suo 2014-03-15 01:22:02 UTC
No crashing with LibreOffice 4.2.2.1 Build ID: 3be8cda0bddd8e430d8cda1ebfd581265cca5a0f

Cheng-Chia Tseng Will you please upgrade to 4.2.2 release and try again? If you can not reproduce in 4.2.2, this should be the same issue as discussed in:
Bug 72470 - EDITING: Calc freezes when typing Chinese characters following non-Chinese strings
Comment 2 Cheng-Chia Tseng 2014-03-15 15:46:12 UTC
Yeah, it does not occur again in 4.2.2. Thanks for notification.
Comment 3 Kevin Suo 2014-03-22 01:05:31 UTC
I believe the right status should be DUPLICATE OF Bug 72470, not WORKSFORME.

*** This bug has been marked as a duplicate of bug 72470 ***
Comment 4 Kohei Yoshida 2014-03-22 02:53:18 UTC
No, Bug 72470 has nothing to do with this.  That one is Calc only.  DUPLICATE is not appropriate.