Bug Hunting Session
Bug 75206 - .NET CLI: Could not load file or assembly 'cli_cppuhelper' ... Strong name validation failed.
Summary: .NET CLI: Could not load file or assembly 'cli_cppuhelper' ... Strong name v...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: sdk (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: Other All
: medium normal
Assignee: Andras Timar
URL:
Whiteboard: target:4.2.2
Keywords: regression
Depends on:
Blocks:
 
Reported: 2014-02-19 13:48 UTC by Michael Stahl (CIB)
Modified: 2014-03-05 12:58 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Stahl (CIB) 2014-02-19 13:48:47 UTC
filing this as "NEW" because 2 people reported it so it's confirmed.
(i don't actually know how to use this CLI stuff)

from https://bugs.freedesktop.org/show_bug.cgi?id=61503#c27 :

jvanderduim@eases.nl 2014-02-18 09:39:16 CET

When accessing libreoffice from our program via cli .net integration. I get the following message.

Could not load file or assembly 'cli_cppuhelper, Version=1.0.22.0, Culture=neutral, PublicKeyToken=ce2cb7e279207b9e' or one of its dependencies. Strong name validation failed. (Exception from HRESULT: 0x8013141A)


the current theory is that this is caused by signing the
CLI DLLs with sn.exe (or whatever it does) and then re-signing them
in release mode like every other DLL and thus invalidating the sn.exe.
Comment 1 Michael Stahl (CIB) 2014-02-19 13:51:41 UTC
there was just a commit to the signing script:

commit 77e48e23641846653691e54f315080c8d8a2d898
Author: Andras Timar <andras.timar@collabora.com>
Date:   Wed Feb 19 14:40:45 2014 +0100

    use 'ne' for string comparison


... but the tinderboxes don't actually do this signing step,
so it's difficult to test whether this helps.
Comment 2 Commit Notification 2014-02-19 14:29:04 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=25b1c6a1f16175fceec0176bf64e2e8fcc8871f1&h=libreoffice-4-2

fdo#75206: use 'ne' for string comparison


It will be available in LibreOffice 4.2.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 3 Commit Notification 2014-02-21 09:05:41 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "libreoffice-4-2-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=703566b1dd752f7099d589da8617382a255b1d5e&h=libreoffice-4-2-2

fdo#75206: use 'ne' for string comparison


It will be available already in LibreOffice 4.2.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 4 Michael Stahl (CIB) 2014-03-05 10:50:32 UTC
can reporters please check if this is problem is now fixed in the 4.2.2.1 RC:

http://permalink.gmane.org/gmane.comp.documentfoundation.libreoffice.devel/57436
Comment 5 Sebastian Brandt 2014-03-05 12:39:27 UTC
Looks good.

Removed all cli_ dll from gac.
Removed sn strong name "validated"
... > sn -Vl
...
No verification entries registered

Installed 4.2.2.1.
Can control via .Net 4.0 without any problems.