Bug 75213 - FORMATTING: double line borders are not printing or exporting properly to PDF (gap too wide)
Summary: FORMATTING: double line borders are not printing or exporting properly to PDF...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.1.1 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Kohei Yoshida
URL:
Whiteboard: target:4.2.3 target:4.3.0
Keywords: regression
: 75607 75700 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-02-19 15:47 UTC by David Burleigh
Modified: 2014-03-27 14:02 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
Simple example that shows the problem. (12.01 KB, application/vnd.oasis.opendocument.text)
2014-02-19 15:47 UTC, David Burleigh
Details
Exported PDF from my simple example (4.15 KB, application/pdf)
2014-02-19 15:48 UTC, David Burleigh
Details

Note You need to log in before you can comment on or make changes to this bug.
Description David Burleigh 2014-02-19 15:47:09 UTC
Created attachment 94366 [details]
Simple example that shows the problem.

I defined double-line borders in my page format for a title page, and they display correctly on the screen but don't print or export to PDF correctly. This is a NEW problem. The affected documents printed and exported just fine in previous versions of LibreOffice.
Comment 1 David Burleigh 2014-02-19 15:48:13 UTC
Created attachment 94367 [details]
Exported PDF from my simple example
Comment 2 Michael Stahl (CIB) 2014-02-20 13:29:11 UTC
worked in 4.2.0.4, regression in 4.2.1.1
Comment 3 Michael Stahl (CIB) 2014-03-03 16:41:34 UTC
*** Bug 75607 has been marked as a duplicate of this bug. ***
Comment 4 Jean-Baptiste Faure 2014-03-05 05:34:54 UTC
*** Bug 75700 has been marked as a duplicate of this bug. ***
Comment 5 Jean-Baptiste Faure 2014-03-05 05:38:47 UTC
*** Bug 75770 has been marked as a duplicate of this bug. ***
Comment 6 Bryan 2014-03-05 07:48:08 UTC
An identical problem occurs in Calc when a cell or group of cells are formatted with a double line border.  The borders also do not print or export to PDF correctly (Gap too wide)
Comment 7 Kohei Yoshida 2014-03-05 15:36:17 UTC
Hopefully this commit 

http://cgit.freedesktop.org/libreoffice/core/commit/?h=libreoffice-4-2&id=743d331357af5204108186f0428e949f68d966c7

which is originally for Bug 75260, will fix this one for 4.2.

The corresponding commit on the master branch is this

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2c62596cf264ef10749d8bfdb2bb2ebef2d98fbc