Bug 75236 - The hidden comments get disappeared after we delete a worksheet.
Summary: The hidden comments get disappeared after we delete a worksheet.
Status: RESOLVED DUPLICATE of bug 74325
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: x86 (IA32) All
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-02-20 01:38 UTC by mwu
Modified: 2015-01-24 13:24 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
a file to verify the hidden comments disappeared problem (19.33 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2014-02-20 01:38 UTC, mwu
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mwu 2014-02-20 01:38:05 UTC
Created attachment 94398 [details]
a file to verify the hidden comments disappeared problem

Although this is happened on CentOS 6, it may happened on Windows also. Below are the steps to show the phenomenon:

1. open the attached test file and copy the workshheet "hide" to a new one ( usually named "hide_2" ).
2. save and close the file.
3. reopen this file and check to see the hidden comments in the worksheets "hide_orig", "hide", and "hide_2" ( All the hidden comments should be existed. )
4. delete the worksheet "hide_2", then save and close the file.
5. reopen the file and we can see the hidden comments in the worksheets "hide_orig" and "hide" are disappeared.

    Because we use the hidden comments to help to memorize something, it will cause a big problem if the hidden comments suddenly get disappeared. Please help to check and fix it. Thank you and best regards.
Comment 1 Simo Sutela 2014-02-20 23:05:40 UTC
I can confirm this on Windows (Vista), LO version 4.2.0.4 final.

I had part of my Calc .ods spreadsheet document data in comments and now they are all gone, which is not a happy situation. This bug is nasty because comments are normally hidden so you may not notice until it's too late.
Comment 2 Simo Sutela 2014-02-24 02:54:23 UTC
The behaviour has changed in version 4.2.1.1. Deleting a sheet and saving no longer removes comments.

On the other hand, when you copy a sheet containing comments so that it is put somewhere before the original page, and save and close the document, the comments in the original page are gone when you open it again. This is perhaps a related but different bug.
Comment 3 Dominique Boutry 2014-02-25 09:10:56 UTC
LibO 4.2.1.1 on Win7 :

"On the other hand, when you copy a sheet containing comments so that it is put somewhere before the original page,":
Nno way to save at this point, getting the message "Error saving the document xxx: Write Error. The file could not be written".
Comment 4 retired 2014-02-27 12:34:47 UTC
I get a crash when creating a new worksheet, marking cmd a in worksheet "hide" and trying to paste (but LO crashes when copying already).

Something is broken. Now we have three different versions of problems related to this document.

1) mwu's variant
2) my crash when trying to copy and
3) Dominiques error msg

Whatever is going to be fixed, this is def NEW and confirmed.
Comment 5 m.a.riosv 2014-02-28 02:20:41 UTC
I only can reproduce comment #2 with:
Win7x64Ult.
Version: 4.2.0.4 Build ID: 05dceb5d363845f2cf968344d7adab8dcfb2ba71

I can't reproduce any of the commented issues, works for me with:
Win7x64Ult.
Version: 4.2.1.1 Build ID: d7dbbd7842e6a58b0f521599204e827654e1fb8b
Version: 4.2.2.1 Build ID: 3be8cda0bddd8e430d8cda1ebfd581265cca5a0f
Comment 6 Kohei Yoshida 2014-02-28 13:46:48 UTC

*** This bug has been marked as a duplicate of bug 74325 ***