Bug 75254 - FILESAVE: DOCX: PolyPolygon shape is not supported for DML (2010 schema) writing
Summary: FILESAVE: DOCX: PolyPolygon shape is not supported for DML (2010 schema) writing
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium major
Assignee: Rajashri
URL:
Whiteboard: target:4.3.0
Keywords:
Depends on:
Blocks:
 
Reported: 2014-02-20 12:14 UTC by Rajashri
Modified: 2014-03-18 18:20 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Original file (356.05 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2014-02-20 12:14 UTC, Rajashri
Details
RT file (611.14 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2014-02-20 12:15 UTC, Rajashri
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rajashri 2014-02-20 12:14:57 UTC
Created attachment 94427 [details]
Original file

a file contains a table with images inside it. After RT the file is showing blank. nothing is getting displayed.
PFA the file and RT file.
Comment 1 Rajashri 2014-02-20 12:15:40 UTC
Created attachment 94428 [details]
RT file
Comment 2 Commit Notification 2014-02-26 12:04:29 UTC
Nikhil Walvekar committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3c0a7cf4f67720f2cca2c4eb543f838d5b644e7f

fdo#75254 Unsupported shape in DML writing was causing document corruption.



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 3 Nikhil Walvekar 2014-02-26 12:15:40 UTC
Issue was due to PolyPloygon shape. It is currently not supported for DML (2010) writing. Currently we ignore shapes which are not supported for DML writing.
Comment 4 Jorendc 2014-03-18 18:20:22 UTC
(In reply to comment #3)
> Issue was due to PolyPloygon shape. It is currently not supported for DML
> (2010) writing. Currently we ignore shapes which are not supported for DML
> writing.

I assume that PolyPolygon is the Acer logo at the top right on the first page?

I can confirm the table is preserved, tested using Windows 8.1 with LibreOffice Version: 4.3.0.0.alpha0+
Build ID: 87efec9cc27b18aa09e50c289b503ba1127eb0b8
TinderBox: Win-x86@39, Branch:master, Time: 2014-03-18_02:50:50