Download it now!
Bug 75308 - FILESAVE: Asterisk (*) at the beginning of Paragraph not cover with "Nowiki" -- Writer Export ot MediaWiki
Summary: FILESAVE: Asterisk (*) at the beginning of Paragraph not cover with "Nowiki" ...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Extensions (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: Other Windows (All)
: medium normal
Assignee: Julien Nabet
URL:
Whiteboard: BSA target:4.3.0 target:4.2.4
Keywords: regression
Depends on:
Blocks:
 
Reported: 2014-02-21 09:28 UTC by steven
Modified: 2014-04-04 11:35 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description steven 2014-02-21 09:28:56 UTC
Steps to reproduce:

1. .... Asterisk (*) at the beginning of Paragraph 

2. .... Writer Export ot MediaWiki 

3. .... this kind of paragraph is Indentation

Current behavior:

Expected behavior: to be improved

              
Operating System: Windows 7
Version: 4.2.0.4 release
Comment 1 Julien Nabet 2014-02-22 04:26:48 UTC
steven: I'm not sure to understand, what should be the result of the mediawiki export? Do you mean "*" should be included in a "nowiki" tag?
Comment 2 steven 2014-02-22 04:32:55 UTC
(In reply to comment #1)
> steven: I'm not sure to understand, what should be the result of the
> mediawiki export? Do you mean "*" should be included in a "nowiki" tag?

Yes, "*" at the beginning of Paragraph should be included in a "nowiki" tag;

if not, the paragraph exported to MW, will be "Indentation""
Comment 3 Julien Nabet 2014-02-22 04:40:13 UTC
Ok, so a regression due to the patch for fdo#74875
Comment 4 Julien Nabet 2014-02-22 05:59:51 UTC
Steven: Just to be sure, have you received my email? (I put a modified xslt, an odt example with its mediawiki translation)
Comment 5 steven 2014-02-22 06:09:18 UTC
(In reply to comment #4)
> Steven: Just to be sure, have you received my email? (I put a modified xslt,
> an odt example with its mediawiki translation)

Got it and thank you so much!
Comment 6 Michael Stahl (CIB) 2014-03-13 13:03:33 UTC
Julien, does this fix the bug?

commit dbc78f2e41c22e0b25598c349e4496a5e0c53164
Author:     Julien Nabet <serval2412@yahoo.fr>
AuthorDate: Sat Feb 22 09:06:05 2014 +0100

    Resolves: fdo#75308 Asterisk at the beginning of Paragraph without "Nowiki"
Comment 7 Julien Nabet 2014-03-13 13:22:02 UTC
Michael: It's building right now on my laptop so can't retest it for the moment. But if I say so , it should be yes.

I tried to cherry-pick for 4.2 but had this:
julien@julienPC:~/compile-libreoffice/libo_4_2$ git cherry-pick dbc78f2e41c22e0b25598c349e4496a5e0c53164
[libreoffice-4-2 1b36431] Resolves: fdo#75308 Asterisk at the beginning of Paragraph without "Nowiki"
 1 file changed, 6 insertions(+), 15 deletions(-)
julien@julienPC:~/compile-libreoffice/libo_4_2$ ./logerrit submit
no branch specified, guessing current branch libreoffice-4-2
Counting objects: 21, done.
Delta compression using up to 4 threads.
Compressing objects: 100% (5/5), done.
Writing objects: 100% (5/5), 602 bytes | 0 bytes/s, done.
Total 5 (delta 4), reused 0 (delta 0)
remote: Resolving deltas: 100% (4/4)
remote: Processing changes: refs: 1, done    
To ssh://logerrit/core
 ! [remote rejected] HEAD -> refs/for/libreoffice-4-2 (change 8167 closed)
error: impossible de pousser des références vers 'ssh://logerrit/core'
(impossible to push refs towards 'ssh...')

Anyway, there are still problems with mediawiki but I don't know xslt to fix them (I had just seen some simple cases).
Comment 8 Julien Nabet 2014-03-13 19:51:47 UTC
Ok building is finished and putting this in a odt file:
*test1
* test2

gives:
<nowiki>*</nowiki>test1

<nowiki>* </nowiki>test2

Steven: do you confirm this behaviour is ok?
Comment 9 Björn Michaelsen 2014-03-18 09:08:37 UTC
Shamelessly assigning to Julien, as he is working on it and even seems to have it solved anyway. This should avoid duplication
Comment 10 Julien Nabet 2014-03-19 21:29:47 UTC
Ok i just restored the gerrit change for 4.2:
https://gerrit.libreoffice.org/#/c/8167/
Comment 11 Commit Notification 2014-03-21 11:22:01 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=895c13faf15b4ebf45be23c461f49a8ab0fd4e09&h=libreoffice-4-2

Resolves: fdo#75308 Asterisk at the beginning of Paragraph without "Nowiki"


It will be available in LibreOffice 4.2.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 12 Julien Nabet 2014-03-21 18:12:46 UTC
Let's put this as FIXED now.