Bug 75381 - FILESAVE: Rotation in text is lost when exporting as SVG
Summary: FILESAVE: Rotation in text is lost when exporting as SVG
Status: RESOLVED DUPLICATE of bug 57215
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2014-02-22 19:46 UTC by Luiz Angelo Daros de Luca
Modified: 2014-03-13 01:55 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
Simple graph with rotated labels (17.53 KB, application/vnd.oasis.opendocument.graphics)
2014-02-22 19:46 UTC, Luiz Angelo Daros de Luca
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Luiz Angelo Daros de Luca 2014-02-22 19:46:03 UTC
Created attachment 94580 [details]
Simple graph with rotated labels

Hello,

I created a simple graph with rotated labels (attached). When it is exported as svg, the rotation property is lost. I'll send an pdf and the svg files as well as the original odg.

FYI, I'm using 4.2.1.1 but it is still not listed in bugzilla.

Regards,
Operating System: Windows 7
Version: 4.2.0.4 release
Comment 1 A (Andy) 2014-02-23 12:15:58 UTC
reproducible with LO 4.2.1.1 (Win8.1)

Steps Done:
1. Open the attachment in DRAW
2. Go to FILE / EXPORT and select svg as file format and click SAVE
3. Open the svg file e.g. with Internet Explorer or Firefox

Result: The X-Axis label is no longer rotated.

But I experienced another strange bug if you try to open the exported svg file in DRAW.
This results in a svg file with a chart with black page background.  This does not happen in IE or Firefox when opening the same file.
Comment 2 stragu 2014-03-13 01:55:27 UTC
This is a duplicate of Bug 57215 - Wrong text rotation in SVG Export (rotated text appears as non-rotated)

*** This bug has been marked as a duplicate of bug 57215 ***