Download it now!
Bug 75399 - SUMPRODUCT function treat empty cells in different ways (1 instead of 0), as the order of column vectors are reversed
Summary: SUMPRODUCT function treat empty cells in different ways (1 instead of 0), as ...
Status: RESOLVED DUPLICATE of bug 74479
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-02-23 13:14 UTC by Laszlo Valy
Modified: 2015-01-24 13:37 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Asymetry in SUMPRODUCT (56.01 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-02-23 13:14 UTC, Laszlo Valy
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Laszlo Valy 2014-02-23 13:14:53 UTC
Created attachment 94597 [details]
Asymetry in SUMPRODUCT

SUMPRODUCT function treat empty cells as 1 when the arrays in the calculations in the argument are placed in reverse order, but treat empty cells as 0 when the arrays in the calculations in the argument are placed in the usual increasing order.
For example:
Increasing order: SUMPRODUCT($A3:$A11;H3:H11) treat empty cells as 0 in both vectors
Reverse order: SUMPRODUCT(H3:H11;$A3:$A11) treat empty cells as 1 in 
the H3:H11 vector but not in the $A3:$A11 vector
Comment 1 m.a.riosv 2014-02-23 15:11:05 UTC

*** This bug has been marked as a duplicate of bug 74479 ***