Bug 75423 - Style for numbering of old document is not displayed correctly and cannot be modified without sideeffects
Summary: Style for numbering of old document is not displayed correctly and cannot be ...
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:doc
Depends on:
Blocks: Chapter-Numbering DOC-Styles
  Show dependency treegraph
 
Reported: 2014-02-24 08:13 UTC by xtrailrunner
Modified: 2019-02-09 20:20 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Testcase for doc. file with incorrect heading 3 (21.00 KB, application/msword)
2014-02-24 09:18 UTC, xtrailrunner
Details
situation in Word 2010 (19.67 KB, image/png)
2019-02-09 20:20 UTC, Cor Nouws
Details

Note You need to log in before you can comment on or make changes to this bug.
Description xtrailrunner 2014-02-24 08:13:57 UTC
If I open existing documents in Word format (*.doc) the numbering style of heading 3 is not displayed correctly anymore as it was in previous releases of LibreOffice Writer. Instead of a number 5 rectangles will be displayed. 
The Character Style for the numbering of those documents is set to "WW8Num2z2". If I change that style to "None" the numbering is displayed correctly but is out of the normal sequence, i.e. starts again with 1.1.1..
The only workaround I found was to copy the complete content of the document in a new document.
Comment 1 Cor Nouws 2014-02-24 08:47:22 UTC
Hi Juergen,

Is it possible to attach a sample document, so that it can be tested?

thanks, also for reporting!

Cor
Comment 2 xtrailrunner 2014-02-24 09:18:37 UTC
Created attachment 94634 [details]
Testcase for doc. file with incorrect heading 3

Here is a testcase. You can see that also the numbers for the working styles are displayed in a strange way (quite small).
Comment 3 Cor Nouws 2014-02-24 12:57:20 UTC
thanks, I can confirm what you describe.

Als random opened the document in 
  3.3.0: no numbering at all with heading 3
  3.6.6: same as in 4.2.1.1

Looking at the behaviour and the huge number of word-character styles.... one could wonder if it's time to start with a clean document after 10 years...

Anyway, I would not find it easy to prepare a clean test case out of this situation. Sorry...
Comment 4 xtrailrunner 2014-02-24 18:22:44 UTC
Yes, the document is quite old and I have lot of these documents where I used to store notes about products and customers. But the problem with the Heading3 Style is something that I noticed only in the previous release of LibreOffice for the first time.
Comment 5 QA Administrators 2014-09-03 21:33:01 UTC Comment hidden (obsolete)
Comment 6 Cor Nouws 2014-09-03 22:10:23 UTC
Set as new, since the problem is recognised.
I doubt what could be done about it of course...

Cheers,
Cor
(Sorry for not responding earlier...)
Comment 7 QA Administrators 2015-09-04 02:48:51 UTC Comment hidden (obsolete)
Comment 8 QA Administrators 2016-09-20 10:30:02 UTC Comment hidden (obsolete)
Comment 9 Roman Kuznetsov 2019-02-09 17:20:44 UTC
still repro in

Version: 6.3.0.0.alpha0+
Build ID: b45289e48e0f354b9996e2846dd041db4a9947ce
CPU threads: 4; OS: Linux 4.18; UI render: default; VCL: kde5; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-02-08_12:51:03
Locale: ru-RU (ru_RU.UTF-8); UI-Language: en-US
Calc: threaded
Comment 10 Cor Nouws 2019-02-09 20:20:02 UTC
(In reply to Roman Kuznetsov from comment #9)
> still repro in
> Version: 6.3.0.0.alpha0+
Looking at the issue again, I'm going to close as won'tFix.
Mostly because in Word I see 5 image-characters too - apparently it's more a font issue than something else.
And if not, then it's prolly is a nightmare to find out all that has piled up in 10 years use  and causes the situation and no one will actively touch this.
I hope you understand, xrailrunner
Comment 11 Cor Nouws 2019-02-09 20:20:54 UTC
Created attachment 149058 [details]
situation in Word 2010