Download it now!
Bug 75437 - libreoffice writer crashes when saving using KDE file dialogs
Summary: libreoffice writer crashes when saving using KDE file dialogs
Status: RESOLVED DUPLICATE of bug 69002
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: haveBacktrace
Depends on:
Blocks:
 
Reported: 2014-02-24 11:42 UTC by Moritz Moeller-Herrmann
Modified: 2014-03-03 12:46 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Output of soffice --backtrace (41.05 KB, text/plain)
2014-02-24 11:42 UTC, Moritz Moeller-Herrmann
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Moritz Moeller-Herrmann 2014-02-24 11:42:21 UTC
Created attachment 94643 [details]
Output of soffice --backtrace

When I try to save a doxc file as odt, libreoffice crashes most of the time (but not always). I attach a backtrace (soffice --backtrace) - it seems as if this is KDE file dialog related. If I use the libreoffice dialogs, the crash does not occur. 

Libreoffice version in DEbian unstable - 4.1.5.3
Comment 1 Robert Großkopf 2014-03-02 18:27:10 UTC
I have tried it with OpenSUSE 12.3 64bit rpm. Set the dialog to the system-dialog of KDE. Saved three (new) writer-files as *.docx. No crash here.

The dialog, which appears here, looks like the old Konqueror-dialog.
Comment 2 Thomas Hackert 2014-03-03 08:36:57 UTC
Good morning Moritz, *,
I cannot confirm your bug with LO Version: 4.1.5.3 Build ID: 1c1366bba2ba2b554cd2ca4d87c06da81c05d24 (parallel installed, following the instructions from https://wiki.documentfoundation.org/Installing_in_parallel) nor with my installed Version: 4.2.2.1 Build-ID: 3be8cda0bddd8e430d8cda1ebfd581265cca5a0f – both with installed Germanophone lang- as well as helppack under Debian Testing i386, sorry ... :( I have tested it with three different docx files: two private ones, one searched and downloaded from Bugzilla. I just opened them, went to "File – Save as...", changed the file type to ODT, and clicked the "Save" button ... ;)

I have also created a completely new document, entered a sentence, pressed <CtrlY>+<S>, chose a name for this file, changed the file type to Docx (2007/2010), but still no crash ...

Have you done something completely different? Or would you be so kind to attach one of your problematic docx files to this bug, please? Then we others from QA could have a look on it, if there is something strange in it, what causes the crash ... ;)
Sorry for the inconvenience and HTH
Thomas.
Comment 3 Maxim Monastirsky 2014-03-03 12:46:13 UTC

*** This bug has been marked as a duplicate of bug 69002 ***