Download it now!
Bug 75481 - SSL-mode for serial e-mails not working
Summary: SSL-mode for serial e-mails not working
Status: RESOLVED DUPLICATE of bug 63388
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.5.3 release
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-02-25 07:30 UTC by CH
Modified: 2015-02-21 15:05 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Error message (67.84 KB, image/gif)
2014-02-25 07:32 UTC, CH
Details

Note You need to log in before you can comment on or make changes to this bug.
Description CH 2014-02-25 07:30:57 UTC
Under options --> writer --> serial e-mail a connection without SSL is working  perfectly.

Trying to establish a SSL-connection ends with an error although serveraddress and password are valid.

This is the message:

<class 'smtplib.SMTPServerDisconnected'>: Connection unexpectedly closed, traceback follows
  /usr/lib/python3.3/smtplib.py:374 in function getreply() [raise SMTPServerDisconnected("Connection unexpectedly closed")]
  /usr/lib/python3.3/smtplib.py:321 in function connect() [(code, msg) = self.getreply()]
  /usr/lib/python3.3/smtplib.py:240 in function __init__() [(code, msg) = self.connect(host, port)]
  /usr/lib/libreoffice/program/mailmerge.py:99 in function connect() [self.server = smtplib.SMTP(server, port,timeout=tout)]

The message is the same under Win 7 and Linux Mint.
Comment 1 CH 2014-02-25 07:32:50 UTC
Created attachment 94703 [details]
Error message
Comment 2 CH 2014-02-25 08:01:22 UTC
slightly different error message in Win 7

<class 'smtplib.SMTPServerDisconnected'>: Connection unexpectedly closed, traceback follows
  C:\Program Files\LibreOffice 4\program\python-core-3.3.3\lib\smtplib.py:374 in function getreply() [raise SMTPServerDisconnected("Connection unexpectedly closed")]
  C:\Program Files\LibreOffice 4\program\python-core-3.3.3\lib\smtplib.py:321 in function connect() [(code, msg) = self.getreply()]
  C:\Program Files\LibreOffice 4\program\python-core-3.3.3\lib\smtplib.py:240 in function __init__() [(code, msg) = self.connect(host, port)]
  C:\Program Files\LibreOffice 4\program\mailmerge.py:99 in function connect() [self.server = smtplib.SMTP(server, port,timeout=tout)]
Comment 3 FS 2014-10-05 16:32:29 UTC
Which server / port? I've encountered the same problem for a mail account at strato (smtp.strato.de, port 465, using ssl instead of starttls). It's possible to solve this issue by modifying mailmerge.py. Details depend whether the smtp server expects SMTPS or STARTTLS.
Comment 4 Julien Nabet 2015-02-21 15:05:45 UTC

*** This bug has been marked as a duplicate of bug 63388 ***