Bug Hunting Session
Bug 75498 - Live Cell Color with Formula
Summary: Live Cell Color with Formula
Status: RESOLVED DUPLICATE of bug 38304
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.3.0.0.alpha0+ Master
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-02-25 16:32 UTC by Joel Madero
Modified: 2016-09-15 19:30 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Joel Madero 2014-02-25 16:32:19 UTC
Due to Rachit's great work we now have multiple colors for cells that reference other cells in a formula. Currently though this isn't "live", the colors highlight after you leave the cell and then return to the cell.

Enhancement Request:
Live color highlighting for all cells referenced in another cell.

Steps:
Select A1
Type in = (then click on multiple different cells with a + in the middle for example A2+A3+A4 )


Observed: You'll see that only the last cell selected is highlighted and it's grey. It would be nice if we had the color scheme work there as well.
Comment 1 Rachit Gupta 2014-02-26 05:09:39 UTC
Joel, thanks for making me a CC of this bug. I'll surely look into it :)

Regards,
Rachit Gupta
Comment 2 GerardF 2014-07-17 17:43:55 UTC
@ Rachit,
Can you also look at this bug (may be related)?
https://bugs.freedesktop.org/show_bug.cgi?id=78221
Comment 3 Rachit Gupta 2014-07-17 17:50:47 UTC
Hi GerardF.
Sorry, but currently I am busy with my Google Summer of Code, so I won't be able to look at it for some time. But, you can surely ping me on IRC if you or someone else wishes to work on it. I am r4chi7 on IRC. :-)

Regards,
Rachit Gupta
Comment 4 Roeland 2016-09-15 19:16:28 UTC
This is a duplicate of Bug 38304. Someone uploaded a patch to solve this issue over there. Maybe someone can have a look and see if this really works?

*** This bug has been marked as a duplicate of bug 38304 ***
Comment 5 Mikeyy - L10n HR 2016-09-15 19:30:18 UTC
He started patch, but abandoned it, or at least it's marked abandoned in gerrit. Last comment on that patch was on May 11th and last patch work was on March 4th (6,5 months ago).