Download it now!
Bug 75522 - corruption while copying cells to irfanview
Summary: corruption while copying cells to irfanview
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.2.1.1 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-02-26 07:28 UTC by Burak Ural
Modified: 2014-04-02 07:31 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Original picture copied to MS Paint. (78.44 KB, image/jpeg)
2014-03-18 14:21 UTC, Burak Ural
Details
Copied picture in clipboard as Metafile. (149.45 KB, image/jpeg)
2014-03-18 14:22 UTC, Burak Ural
Details
Copied picture in clipboard as Picture. (147.31 KB, image/jpeg)
2014-03-18 14:23 UTC, Burak Ural
Details
Copied picture in clipboard as Bitmap. (143.32 KB, image/jpeg)
2014-03-18 14:23 UTC, Burak Ural
Details
4.3.0.0 alpha copy function errors 1/3 (20.44 KB, image/jpeg)
2014-03-24 09:20 UTC, Burak Ural
Details
4.3.0.0 alpha copy function errors 2/3 (38.36 KB, image/jpeg)
2014-03-24 09:21 UTC, Burak Ural
Details
4.3.0.0 alpha copy function errors 3/3 (21.57 KB, image/jpeg)
2014-03-24 09:21 UTC, Burak Ural
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Burak Ural 2014-02-26 07:28:04 UTC
Hi,

I do not know if this is a bug of Libreoffice or Irfanview.

When I select some cells in Libreoffice Calc , copy and paste into the image software called Irfanview, the image has some faults.

I am using Irfanview 4.37 on Windows XP SP3.

You can try it easily. Just open a simple spreadsheet file and select some area and hit copy.

Open irfanview click paste icon. You will see the image has some faults on sides.

I tried with MS Paint, the image paste operation is normal.

There seems to be some incompatibility between Libreoffice and Irfanview.

You can check the software on www.irfanview.com
It is free and very fast software.

Best Regards,
Burak Ural
Comment 1 Burak Ural 2014-03-06 11:39:50 UTC
Hi,

I also can confirm the bug that while copying pictures from Presentation to Irfanview the images get corrupted.

I will also try to contact and notify author of Irfanview software.

I am disappointed nobody has taken interest in this bug.

Regards,
Burak Ural
Comment 2 Joel Madero 2014-03-07 00:08:51 UTC
Well as you've stated that it pastes fine to other software - I have tested and confirm in Ifranview but do not see it in other software so it's their bug please report it with them.

As for "no interest" - we are all volunteers dedicating a lot of time to dig through thousands of bugs, a couple weeks passing without a comment is not enough to think there is "no interest." That being said - thanks for reporting and I hope you find the help you need over on their side.
Comment 3 Burak Ural 2014-03-12 10:18:25 UTC
Hi Joel ,

I have done some more tests and found out that this is actually a Libreoffice bug.

Here is what I found out:

I have copied some cells from Libreoffice.

I have creted an email in Mozilla Thunderbird in html and tried to paste into it.
Nothing seemed to happen, the paste does not work.

I have pasted the same clipboard to Microsoft Paint. I cut the image in Microsoft Paint (which changed it's clipboard properties or format) .
I could paste the image in Mozilla Thunderbird , and Irfanview.

This might only be happening in MS Windows platform, but I believe fixing this will be an important task.

Please help,

Kind Regards
Comment 4 Joel Madero 2014-03-12 16:21:42 UTC
ah yes the regression copy/paste bug - apologies for that you are correct. This is a duplicate and has been resolved - you'll see the fix in next stable release.

*** This bug has been marked as a duplicate of bug 74584 ***
Comment 5 Tomaz Vajngerl 2014-03-18 14:15:10 UTC
Reopened as it does not look like the duplicate bug is related to this one.
Comment 6 Joel Madero 2014-03-18 14:17:01 UTC
REOPENED is only for bugs that are assigned to a developer and marked as FIXED. Correct status here is NEW as I've confirmed the bug exists
Comment 7 Burak Ural 2014-03-18 14:21:41 UTC
Created attachment 96000 [details]
Original picture copied to MS Paint.
Comment 8 Tomaz Vajngerl 2014-03-18 14:21:52 UTC
But you can't go directly from DUPLICATE to NEW :)
Comment 9 Burak Ural 2014-03-18 14:22:22 UTC
Created attachment 96001 [details]
Copied picture in clipboard as Metafile.
Comment 10 Burak Ural 2014-03-18 14:23:01 UTC
Created attachment 96002 [details]
Copied picture in clipboard as Picture.
Comment 11 Burak Ural 2014-03-18 14:23:24 UTC
Created attachment 96003 [details]
Copied picture in clipboard as Bitmap.
Comment 12 Burak Ural 2014-03-18 14:27:11 UTC
Moving my comments from other thread...
==========================================
I am using Libreoffice 4.3.2.1

I can still confirm that this bug affects copying pictures to the image editor called Irfanview on Windows XP SP3.

Upon further investigation it can be said that there is some problem in Libreoffice about copying pictures to Windows clipboard.
Please note that Ms Paint can render the copied picture correctly.
However there are 4 types of clipboard data in memory when copied from Libreoffice and except one, they are corrupted. Therefore some image programs rendering a corrupted image when pasted.

Example;
Please check attached picture files.
1- Original picture copied to Ms Paint. (orj.jpg)

2- Original picture copied and Windows Clipboard is being used to display contents, using (view--> Enhanced Metafile) (metafile.jpg)
Please notice the difference in the image compared the orj.jpg

3- Original picture copied and Windows Clipboard is being used to display contents, using (view--> Picture) (picture.jpg)
Please notice this is a correct display of the image which MS Paint probably using to import.

4- Original picture copied and Windows Clipboard is being used to display contents, using (view--> Bitmap) (bitmap.jpg)
Please notice the corruption in the image. A lot of image software could be using the bitmap format for pasting images , and they would get corrupted image from Libreoffice most of the time.

5- There is a clipboard data type Dib Bitmap but it can not be displayed in clipboard viewer so I pass that one.

Not every image is being affected as severe as the ones I attached, however this bug has affected every copied image from Libreoffice.

The only workaround I have, is to paste the image to MS Paint first.
Later cut the image from MS Paint , and paste it to any software I want.
It works without any corruption. However it is very annoying to use this workaround instead of pasting directly to an image editor.

Best Regards,
Burak Ural
Comment 13 Tomaz Vajngerl 2014-03-18 14:30:41 UTC
Thanks!
Comment 14 Joel Madero 2014-03-18 14:58:24 UTC
Indeed you can't - it's on our long laundry list of things that need changed when we move to our own bug tracker :)

As for the bug still existing - that's unfortunate. I suspect it may be around for awhile as we have much more pressing issues to deal with but thanks for the update
Comment 15 Burak Ural 2014-03-18 15:18:37 UTC
Is it not possible to use some code from other openoffice derivatives to solve some problems that might already be solved?

For example Oxygenoffice was a fine fork before I switched to Libreoffice for better MS file compatibility.
Maybe you can use some code from it?

http://sourceforge.net/projects/ooop/

Regards,
Burak
Comment 16 Joel Madero 2014-03-18 16:12:20 UTC
The issue is tracking down what code it is - 10,000,000+ lines of code, sometimes it's like digging for a needle in a haystack to find out where things are going wrong. But if you want to try to poke at the code - please feel free to do so
Comment 17 Joel Madero 2014-03-18 16:13:37 UTC
Also please be aware that just because two products are forks from the same source (AOO) does not mean that the code is now compatible - we're having thousands of commits per month which is constantly making our code different from others -- and I'm sure similar things are happening on the other side
Comment 18 Burak Ural 2014-03-20 19:07:03 UTC
Hi,

Just wanted to confirm that the bugs I encountered does not happen in the 4.1.5.x series.

Therefore I believe you already have the solution to the image copy paste and lookup function bugs.

Kind Regards,
Burak Ural
Comment 19 Tomaz Vajngerl 2014-03-20 19:18:43 UTC
No, this is not how programming works. :)

Even if you know that it worked before you still have to go and check out what is wrong and where, what has changed in between and then you have to come up with a solution that also works in the new version.
Comment 20 Joel Madero 2014-03-21 00:02:52 UTC
yes please stop putting comments suggesting this is an easy fix - in that time frame there have been THOUSANDS of commits affecting tens if not hundreds of thousands of lines of code. It may very well be something easy but that doesn't change the fact that tracking it down could be quite hard.
Comment 21 Tomaz Vajngerl 2014-03-23 22:32:10 UTC
Actually I think this is fixed in LO daily build. There were changes to Windows clipboard handling like messing with DIBV5, adding support for PNG,... I guess DIBV5 is responsible which was disabled in master but not in 4.2, however I can't confirm this as I don't have a LO build environment on Windows.

Burak can you try to install LO daily build and confirm?
Comment 22 Burak Ural 2014-03-24 08:15:40 UTC
Hi Tomaz,

I removed all libreoffice.org.

I installed libo-42~2014-03-23_18.49.53_LibreOfficeDev_4.2.4.0.0_Win_x86.msi  on Windows XP SP3 with all updates.

The lookup function bug is fixed.

The copy-paste clipboard bug still not fixed.

Regards,
Burak Ural
Comment 23 Tomaz Vajngerl 2014-03-24 08:45:55 UTC
Hi Burak,

I didn't mean 4.2 daily build.. I meant 4.3 (master) daily build, for example [1] or newer. Sorry for the confusion. 

Regards, Tomaž

[1]: http://dev-builds.libreoffice.org/daily/master/Win-x86@39/2014-03-22_00.09.58/
Comment 24 Burak Ural 2014-03-24 09:20:39 UTC
Created attachment 96278 [details]
4.3.0.0 alpha copy function errors 1/3
Comment 25 Burak Ural 2014-03-24 09:21:00 UTC
Created attachment 96279 [details]
4.3.0.0 alpha copy function errors 2/3
Comment 26 Burak Ural 2014-03-24 09:21:24 UTC
Created attachment 96280 [details]
4.3.0.0 alpha copy function errors 3/3
Comment 27 Burak Ural 2014-03-24 09:23:40 UTC
Hi,

I did download and install both the one in your post and current one master~2014-03-24_05.49.26_LibreOfficeDev_4.3.0.0.alpha0_Win_x86.msi

However, while both worked fine the lookup function, they both failed to copy picture in Impress.

I guess the software is early alpha stage to perform basic functions.

Please check attached 3 files. (  4.3.0.0 alpha copy function errors 1/3; 2/3 ; 3/3 )

Regards,
Burak
Comment 28 Tomaz Vajngerl 2014-03-24 09:34:44 UTC
Ah OK.  I'll ask someone with a windows build to find the correct patch and backport it to 4.2.
Comment 29 Tomaz Vajngerl 2014-04-01 11:51:28 UTC
Can you try it now with LO 4.2 daily build [1].

[1]: http://dev-builds.libreoffice.org/daily/libreoffice-4-2/
Comment 30 Burak Ural 2014-04-01 13:23:56 UTC
Which one, is the current one ok?

http://dev-builds.libreoffice.org/daily/libreoffice-4-2/Win-x86@42/current/
Comment 31 Tomaz Vajngerl 2014-04-01 14:17:25 UTC
(In reply to comment #30)
> Which one, is the current one ok?
> 
> http://dev-builds.libreoffice.org/daily/libreoffice-4-2/Win-x86@42/current/

Yes, it's OK.. but just to be safe I used [1].

[1] http://dev-builds.libreoffice.org/daily/libreoffice-4-2/Win-x86@42/2014-04-01_09.38.08/
Comment 32 Burak Ural 2014-04-02 07:02:37 UTC
Hi,

I have tested
libo-42~2014-04-01_09.38.08_LibreOfficeDev_4.2.4.0.0_Win_x86.msi on Windows
XP SP3.

It works fine , I tested for both clipboard copy paste and lookup function
bugs, they are both solved.

Thanks for all the help.


On Tue, Apr 1, 2014 at 5:17 PM, <bugzilla-daemon@freedesktop.org> wrote:

>   *Comment # 31 <https://bugs.freedesktop.org/show_bug.cgi?id=75522#c31>
> on bug 75522 <https://bugs.freedesktop.org/show_bug.cgi?id=75522> from
> Tomaz Vajngerl <quikee@gmail.com> *
>
> (In reply to comment #30 <https://bugs.freedesktop.org/show_bug.cgi?id=75522#c30>)> Which one, is the current one ok?
> >
> > http://dev-builds.libreoffice.org/daily/libreoffice-4-2/Win-x86@42/current/
>
> Yes, it's OK.. but just to be safe I used [1].
>
> [1]http://dev-builds.libreoffice.org/daily/libreoffice-4-2/Win-x86@42/2014-04-01_09.38.08/
>
>  ------------------------------
> You are receiving this mail because:
>
>    - You are on the CC list for the bug.
>    - You reported the bug.
>
>