Download it now!
Bug 74584 - Can no longer copy spreadsheet cells from libreoffice calc to another app like thunderbird and paste as html table.
Summary: Can no longer copy spreadsheet cells from libreoffice calc to another app lik...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: framework (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: x86-64 (AMD64) Windows (All)
: highest major
Assignee: Kohei Yoshida
URL:
Whiteboard: target:4.3.0 target:4.2.2
Keywords: regression
: 74381 74537 74638 74659 74674 74738 74806 74949 75184 75266 75312 75396 75402 75417 75575 75606 75677 75842 76262 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-02-05 19:49 UTC by 9f4geq2y36
Modified: 2014-03-18 14:17 UTC (History)
30 users (show)

See Also:
Crash report or crash signature:


Attachments
ODS saved to XLSX file, no fram controls in Excel. (284.19 KB, image/jpeg)
2014-03-07 21:18 UTC, kevin.soukup
Details
Original picture copied to MS Paint. (78.44 KB, image/jpeg)
2014-03-18 07:57 UTC, Burak Ural
Details
Copied picture in clipboard as Metafile. (149.45 KB, image/jpeg)
2014-03-18 07:59 UTC, Burak Ural
Details
Copied picture in clipboard as Picture. (147.31 KB, image/jpeg)
2014-03-18 08:00 UTC, Burak Ural
Details
Copied picture in clipboard as Bitmap. (143.32 KB, image/jpeg)
2014-03-18 08:00 UTC, Burak Ural
Details

Note You need to log in before you can comment on or make changes to this bug.
Description 9f4geq2y36 2014-02-05 19:49:57 UTC
Can no longer copy spreadsheet cells from libreoffice calc to another app like thunderbird and paste as html table. Was working in 4.1.1.2. No longer works in 4.2.0.x. Uninstalled 4.2.0.x, reinstalled 4.1.1.2, worked again.

Desired action:
- create spreadsheet in LibreOffice calc
- open target app (in this case, thunderbird, create new email message)
- copy cell range
- paste into thunderbird message
- from LO calc 4.2, nothing happens. from LO calc 4.1, paste works fine
Comment 1 Cor Nouws 2014-02-05 20:59:15 UTC
Hi

No problem for me...
There mus be something elase wrong on your system?

Pls ask the user-support. For exmaple there is a group of users with a great variety of skills that can offer help with questions:
  http://www.libreoffice.org/get-help/

Regards,
Cor
Comment 2 biocidedevelopmentcorp 2014-02-05 23:42:21 UTC
I know that you said you could not replicate the problem but I am now having the same problem on my system and so is a co-worker.  If you'd be so kind Cor Nouws, could you please try once more and make sure?

I agree that it's possible it is some other issue with the machines, but it may also be possible that you made a mistake with program versions or something.

Thanks for your hard work and sorry if I mis-set any fields on this response (like "invalid")....I am new to this process.
Comment 3 biocidedevelopmentcorp 2014-02-05 23:50:49 UTC
Update - I can copy from calc to writer, so perhaps it's a Thunderbird issue not a calc issue?

Just a thought...

Also if I save the file as .XLSX first it still doesn't work.  If I make an XLSX spreadsheet using Excel though, it works.
Comment 4 Regina Henschel 2014-02-06 00:52:32 UTC
I can confirm the problem. Write some content with formatting in Calc. Copy it and paste it "as HTML". It failed in:
Seamokey Composer
Excel 2010
Word 2010

In Editor PSPad I can insert it as HTML-Source. There I notice, that it has the doctype
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
and tags in lower case.
Previous versions (e.g. Version: 4.2.0.0.alpha0+
Build ID: 8624906bc437b242ea0df17801bc77d0f273f32c
TinderBox: Win-x86@6, Branch:master, Time: 2013-07-05_04:07:10) had doctype
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2//EN">
and tags in upper case. With that paste works in the other applications.

I use Version: 4.3.0.0.alpha0+
Build ID: 160db96a882a2be8c3307e8a04beda4ae93a13c4
TinderBox: Win-x86@39, Branch:master, Time: 2014-01-19_09:25:52
on 32-bit Windows 7.
Comment 5 9f4geq2y36 2014-02-06 01:31:58 UTC
That is a thought, and I tried that, too, but it felt like it was pasting not as HTML in writer but more as an OLE object (or equivalent - I am showing my age with that one...). And again, LO 4.1.1.2 pastes just fine. I uninstalled 4.2.x.x and downgraded back to the earlier version.

> Comment # 3 on bug 74584 from biocidedevelopmentcorp@gmail.com
> Update - I can copy from calc to writer, so perhaps it's a Thunderbird issue
> not a calc issue?
> 
> Just a thought...
> 
> Also if I save the file as .XLSX first it still doesn't work.  If I make an
> XLSX spreadsheet using Excel though, it works.
> You are receiving this mail because:
> You are on the CC list for the bug.
> You reported the bug.
Comment 6 Jim McKane 2014-02-06 01:39:43 UTC
I reverted to ver 4.1 and it works well so it definitely is caused by ver 4.2
Comment 7 Cor Nouws 2014-02-06 10:25:59 UTC
Hi,

It works fine for me, so looks as a Windows specific problem.
Someone was so friendly to mail me directly to confirm the existence of the problem form him.

Regards,
Cor
Comment 8 jm 2014-02-06 15:45:41 UTC
I can confirm the problem with windows 7. Write some content with formatting in Calc. Copy it and paste it in a text area in my browser (chrome) and you get only the content (no formating). used to work fine before.
Comment 9 Ivan Williams 2014-02-07 12:18:01 UTC
I can also confirm this bug. After upgrading to LibreOffice Version: 4.2.0.4 I cannot paste selected text or Calc cells into Mozilla Thunderbird email body. I can paste the clipboard contents into Notepad, or into Thunderbird Subject box.
I can also paste it into Firefox Form fields like this one: (EXAMPLE COPIED TEXT)

In Thunderbird it seems to paste a "backspace" instead of the actual text if you have a signature text in the email body.

HTML Before paste attempt:
<br>
<div class="moz-signature">-- <br>
  <b>Ivan Williams
    <br>
    <br>
  </b></div>

HTML After paste attempt:
<!--DOCTY--><!--DOCTY-->
<div class="moz-signature">-- <br>
  <b>Ivan Williams
    <br>
    <br>
  </b></div>

However RightClick -> Paste Without Formatting does still work.
Comment 10 jkonecny 2014-02-07 17:06:07 UTC
I'm seeing this same behavior.  Cannot paste from 4.2.0.4 (Windows XP x86) into Thunderbird when composing in html mode unless you do "paste without formatting".
Comment 11 Ivan Williams 2014-02-08 07:05:53 UTC
This is my work around:
Save LibreOffice document as HTML document.
Open in your favourite browser. Copy from browser and paste into Thunderbird.
This way you retain formatting such as tables and font.
Comment 12 Richard Hafke 2014-02-10 19:15:31 UTC
Find this report too late (my bugreport was 74806).
I can confirm the behavior.
Under Win 7, copy several Spreadsheets cells in Libre Office version 4.2.0.4, and pasting them into a new Thunderbird message (version 24.3.0), does not work.
A paste without formatting works.
It  works under Libre Office 4.1.1.2.
Richard
Comment 13 Richard Hafke 2014-02-10 19:16:29 UTC
*** Bug 74806 has been marked as a duplicate of this bug. ***
Comment 14 Ivan Williams 2014-02-11 08:58:25 UTC
(In reply to comment #4)
> I can confirm the problem. Write some content with formatting in Calc. Copy
> it and paste it "as HTML". It failed in:
> Seamokey Composer
> Excel 2010
> Word 2010
> 
> In Editor PSPad I can insert it as HTML-Source. There I notice, that it has
> the doctype
> <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
> and tags in lower case.
> Previous versions (e.g. Version: 4.2.0.0.alpha0+
> Build ID: 8624906bc437b242ea0df17801bc77d0f273f32c
> TinderBox: Win-x86@6, Branch:master, Time: 2013-07-05_04:07:10) had doctype
> <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2//EN">
> and tags in upper case. With that paste works in the other applications.
> 
> I use Version: 4.3.0.0.alpha0+
> Build ID: 160db96a882a2be8c3307e8a04beda4ae93a13c4
> TinderBox: Win-x86@39, Branch:master, Time: 2014-01-19_09:25:52
> on 32-bit Windows 7.

Also fails in Yahoo Mail
Comment 15 Narayan Pawar 2014-02-12 06:58:28 UTC
This problem also come in our company. We need to revert back old version until this problem solve in current version.
Comment 16 Robb Topolski 2014-02-17 14:13:26 UTC
It's as easy as
1.  Copy a range from calc
2.  Attempt to paste into a gmail body

a.  In Firefox 27.0.1, the cursor blinks but nothing else happens.
b.  In Chrome 32.0.1700.107, I get the table unformatted

This is fairly important in my company. I can't submit my time sheet. :-)
Comment 17 Ivan Williams 2014-02-18 06:51:37 UTC
Ditto on the importance.
How do we get somebody assigned to this bug? More posts?
Get all your colleagues to submit?
Comment 18 Kohei Yoshida 2014-02-19 19:00:06 UTC
Please don't add any more noise here. That would only repel people from looking into it.
Comment 19 Kohei Yoshida 2014-02-19 20:13:17 UTC
I got this.  Looks like someone's "cleanup" of lower-casing the html tag names caused has this regression.  On Windows, the HTML tags *must* be uppercase.
Comment 20 Kohei Yoshida 2014-02-19 20:23:39 UTC
*** Bug 74537 has been marked as a duplicate of this bug. ***
Comment 21 Commit Notification 2014-02-19 20:34:06 UTC
Kohei Yoshida committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3d481254a07fe82d11953f9825a2f8fc6eeabc0b

fdo#74584, fdo#74537: HTML tags *must* be UPPERCASE.



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 22 Kohei Yoshida 2014-02-19 20:36:39 UTC
4.2 backport request: https://gerrit.libreoffice.org/8132
Comment 23 Kohei Yoshida 2014-02-19 20:40:26 UTC
BTW, Regina's comment in Comment 4 about the tags being lowercase helped me find the cause.  Thanks a lot.
Comment 24 Kohei Yoshida 2014-02-19 21:13:33 UTC
Unfortunately the change affected the HTML detection code.  Looking into it.
Comment 25 Commit Notification 2014-02-19 21:36:49 UTC
Kohei Yoshida committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1f74a3ce201bad68f160584900285e2c087ab2c0

fdo#74584: Upcase the tag name before searching.



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 26 Michael Stahl (CIB) 2014-02-19 23:59:44 UTC
by way of a failing unit test i noticed there were some followup commits that needed to be reverted too...
Comment 27 Commit Notification 2014-02-20 00:01:26 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=96a1f60aeb2a7954533da9b4aa4947efb7a65e70

fdo#74584: Revert "html: Options need to be lowercase, too"



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 28 Commit Notification 2014-02-20 00:01:42 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3c84fa61570113d1dfb2523ab88f268eeeb46c3c

fdo#74584: Revert "fix html tests"



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 29 Jürgen 2014-02-20 13:57:53 UTC
is this a duplicate of bug #74738? 
there ist the same problem with LO writer
Comment 30 Kohei Yoshida 2014-02-20 14:38:50 UTC
*** Bug 74659 has been marked as a duplicate of this bug. ***
Comment 31 Jacques Guilleron 2014-02-20 15:00:36 UTC
*** Bug 74674 has been marked as a duplicate of this bug. ***
Comment 32 Jacques Guilleron 2014-02-20 16:01:49 UTC
*** Bug 74738 has been marked as a duplicate of this bug. ***
Comment 33 Commit Notification 2014-02-21 01:48:54 UTC
Kohei Yoshida committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f1f8b3bfdc3406ea79b662a2fda3d0c1cb87bb10

fdo#74584: Revert various previous changes to upcase HTML tags.



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 34 Commit Notification 2014-02-21 01:49:08 UTC
Kohei Yoshida committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=88c6cbda921f1e3627910f9028ff2e29f26160e7

fdo#74584: These tags should be lowercase for correct clipboard handling.



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 35 Kohei Yoshida 2014-02-21 01:56:21 UTC
Here is a better fix for 4.2: https://gerrit.libreoffice.org/8154
Comment 36 Commit Notification 2014-02-21 09:03:00 UTC
Kohei Yoshida committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3ba02e9ec03df980803f35c4b16ce8b8ce90cb66&h=libreoffice-4-2

fdo#74584: These tags should be lowercase for correct clipboard handling.


It will be available in LibreOffice 4.2.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 37 Commit Notification 2014-02-21 10:13:36 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=456b92609cdd0795e165ca4487419d1f329bb158

fdo#74584: complete revert various previous changes to upcase HTML tags



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 38 Commit Notification 2014-02-21 12:47:02 UTC
Kohei Yoshida committed a patch related to this issue.
It has been pushed to "libreoffice-4-2-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=9ffb9d0baa22f85cc7c22a198760f90a4a857458&h=libreoffice-4-2-2

fdo#74584: These tags should be lowercase for correct clipboard handling.


It will be available already in LibreOffice 4.2.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 39 Jacques Guilleron 2014-02-21 12:49:39 UTC
*** Bug 75312 has been marked as a duplicate of this bug. ***
Comment 40 Kohei Yoshida 2014-02-21 13:49:29 UTC
Finally fixed. Finally.
Comment 41 Ivan Williams 2014-02-21 14:21:56 UTC
To Kohei Yoshida and all the other developers involved, I thank you.
Comment 42 Todd 2014-02-21 16:55:19 UTC
Did this make it to 4.2.1?
Comment 43 Tomaz Vajngerl 2014-02-21 17:40:10 UTC
(In reply to comment #42)
> Did this make it to 4.2.1?

Unfortunately no as 4.2.1 is already released. It will be in 4.2.2 that will be released in about 2 weeks.
Comment 44 Maarten 2014-02-22 19:09:05 UTC
Wonderful! Thank you all for you hard work, making LO a amazing office
suite and fixing bugs!!
Maarten


2014-02-21 18:40 GMT+01:00 <bugzilla-daemon@freedesktop.org>:

>   *Comment # 43 <https://bugs.freedesktop.org/show_bug.cgi?id=74584#c43>
> on bug 74584 <https://bugs.freedesktop.org/show_bug.cgi?id=74584> from
> Tomaz Vajngerl <quikee@gmail.com> *
>
> (In reply to comment #42 <https://bugs.freedesktop.org/show_bug.cgi?id=74584#c42>)
> > Did this make it to 4.2.1?
>
>
> Unfortunately no as 4.2.1 is already released. It will be in 4.2.2 that will be
> released in about 2 weeks.
>
>  ------------------------------
> You are receiving this mail because:
>
>    - You are on the CC list for the bug.
>
>
Comment 45 Jacques Guilleron 2014-02-23 15:37:19 UTC
*** Bug 74381 has been marked as a duplicate of this bug. ***
Comment 46 Jacques Guilleron 2014-02-23 15:41:28 UTC
*** Bug 75396 has been marked as a duplicate of this bug. ***
Comment 47 Jacques Guilleron 2014-02-23 15:44:08 UTC
*** Bug 75402 has been marked as a duplicate of this bug. ***
Comment 48 Maxim Monastirsky 2014-02-25 12:44:49 UTC
*** Bug 75417 has been marked as a duplicate of this bug. ***
Comment 49 Maxim Monastirsky 2014-02-25 12:47:39 UTC
*** Bug 75184 has been marked as a duplicate of this bug. ***
Comment 50 Maxim Monastirsky 2014-02-25 12:49:46 UTC
*** Bug 74949 has been marked as a duplicate of this bug. ***
Comment 51 Maxim Monastirsky 2014-02-25 12:56:44 UTC
*** Bug 74638 has been marked as a duplicate of this bug. ***
Comment 52 sophie 2014-02-27 15:04:51 UTC
*** Bug 75575 has been marked as a duplicate of this bug. ***
Comment 53 sophie 2014-02-28 16:22:04 UTC
*** Bug 75606 has been marked as a duplicate of this bug. ***
Comment 54 Maxim Monastirsky 2014-03-06 08:40:15 UTC
*** Bug 75677 has been marked as a duplicate of this bug. ***
Comment 55 Jacques Guilleron 2014-03-06 13:07:56 UTC
*** Bug 74513 has been marked as a duplicate of this bug. ***
Comment 56 walid 2014-03-06 13:12:51 UTC
It did not work!
I just installed 4.2.2
only text are pasted not the table
Comment 57 Ashok 2014-03-06 14:57:43 UTC
I have today installed 4.2.2 RC on a couple of Windows 7 and Windows 8.1 machines and copy - paste works fine. I have copied from Calc to Windows Live Mail and the table has been copied along with single line borders.  I had un-installed the old version before installing this version.  There was another problem in one of the PCs and it was rectified by reseting the User profile.  This is how it was done:
1.   Close Libre Office (including quickstart from system tray)
2.   Open folder %appdata%\libreoffice\4
3.   Rename folder "user"
4.   Open Libre Office
Comment 58 Kohei Yoshida 2014-03-07 19:32:33 UTC
*** Bug 75842 has been marked as a duplicate of this bug. ***
Comment 59 kevin.soukup 2014-03-07 21:18:48 UTC
Created attachment 95314 [details]
ODS saved to XLSX file, no fram controls in Excel.
Comment 60 Jorendc 2014-03-07 21:23:42 UTC
Comment on attachment 95314 [details]
ODS saved to XLSX file, no fram controls in Excel.

not-related to this bug. Sorry for the noise (currently guiding attacher at IRC). Ignore it please :)
Comment 61 Maxim Monastirsky 2014-03-11 20:17:07 UTC
*** Bug 75266 has been marked as a duplicate of this bug. ***
Comment 62 Joel Madero 2014-03-12 16:21:42 UTC
*** Bug 75522 has been marked as a duplicate of this bug. ***
Comment 63 Mark12547 2014-03-14 07:59:54 UTC
Confirmed fixed: can now paste both Calc region and Writer document via copy from LO to Thunderbird.

LibreOffice:
Version: 4.2.2.1
Build ID: 3be8cda0bddd8e430d8cda1ebfd581265cca5a0f

Thunderbird: 24.3.0

OS: Windows 7 Home Premium SP1 (64-bit)

Thank you!
Comment 64 Maxim Monastirsky 2014-03-18 06:16:02 UTC
*** Bug 76262 has been marked as a duplicate of this bug. ***
Comment 65 Burak Ural 2014-03-18 07:57:32 UTC
Created attachment 95984 [details]
Original picture copied to MS Paint.
Comment 66 Burak Ural 2014-03-18 07:59:21 UTC
Created attachment 95985 [details]
Copied picture in clipboard as Metafile.
Comment 67 Burak Ural 2014-03-18 08:00:00 UTC
Created attachment 95986 [details]
Copied picture in clipboard as Picture.
Comment 68 Burak Ural 2014-03-18 08:00:38 UTC
Created attachment 95987 [details]
Copied picture in clipboard as Bitmap.
Comment 69 Burak Ural 2014-03-18 08:02:28 UTC
Hi,

I am using Libreoffice 4.3.2.1

I can still confirm that this bug affects copying pictures to the image editor called Irfanview on Windows XP SP3.

Upon further investigation it can be said that there is some problem in Libreoffice about copying pictures to Windows clipboard.
Please note that Ms Paint can render the copying picture correctly.
However there are 4 types of clipboard data in memory when copied from Libreoffice and except one, they are corrupted. Therefore some image programs rendering corrupted image when pasted.

Example;
Please check attached picture files.
1- Original picture copied to Ms Paint. (orj.jpg)

2- Original picture copied and Windows Clipboard is being used to display contents, using (view--> Enhanced Metafile) (metafile.jpg)
Please notice the difference in the image compared the orj.jpg

3- Original picture copied and Windows Clipboard is being used to display contents, using (view--> Picture) (picture.jpg)
Please notice this is a correct display of the image which MS Paint probably using to import.

4- Original picture copied and Windows Clipboard is being used to display contents, using (view--> Bitmap) (bitmap.jpg)
Please notice the corruption in the image. A lot of image software could be using the bitmap format for pasting images , and they would get corrupted image from Libreoffice most of the time.

5- There is a clipboard data type Dib Bitmap but it can not be displayed in clipboard viewer so I pass that one.

Not every image is being affected as severe as the ones I attached, however this is affected every copied image from Libreoffice.

The only workaround I have is to paste the image to MS Paint first.
Later cut the image from MS Paint , and paste it to any software I want.
It works without any corruption. However this is very annoying to use this workaround instead of pasting directly to an image editor.

Best Regards,
Burak Ural
Comment 70 Tomaz Vajngerl 2014-03-18 08:33:03 UTC
Hi Burak,

Thanks for reporting this but the bug you describe has nothing to do with this bug (except both happen at copy/paste). The problem of this bug was that we changed html tags from upper-case to lower-case and unintentionally broke some things that relied on upper-case tag names. Can you please open a new bug for your problem. I remember seeing a bug related to irfanview and copy/paste - maybe try to find that one.

Regards, Tomaž
Comment 71 Burak Ural 2014-03-18 13:44:09 UTC
Hi Tomaž,

I had previously reported this as a new bug 75522.
However Joel Madero marked it as a duplicate of 74584.
How should I proceed , I am new here :)

Regards,
Burak Ural
Comment 72 Tomaz Vajngerl 2014-03-18 14:17:07 UTC
Ah.. I see. 

Sorry I didn't know the original bug was marked as duplicate. I have reopened that bug as I think it is not related to this one. Please can you copy everything to that bug. I will take a look at it during weekend. Sorry for the inconvenience, you did everything correct. :)

Regards, Tomaž