Download it now!
Bug 74949 - Cannot Copy/Paste from Writer to Gmail email in Firefox
Summary: Cannot Copy/Paste from Writer to Gmail email in Firefox
Status: RESOLVED DUPLICATE of bug 74584
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: x86-64 (AMD64) Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 75444 75555 75793 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-02-13 19:57 UTC by Dan C
Modified: 2014-03-05 11:04 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dan C 2014-02-13 19:57:36 UTC
I think I may have found a bug/strange combo with the release 4.2.0.4. I have some users of LO that are unable to copy/paste text in Writer into Gmail emails. They can copy paste into Firefox search bars and url bars just fine, but nothing gets copy/pasted in an email in Firefox. I’ve cleared the cache in Firefox, reinstalled Firefox and restarted the 4.2 computers multiple times and nothing has fixed this issue. Only downgrading to 4.1 restores copy/paste.
 
I’ve tried copy pasting from LO to Gmail open in IE 11 and Chrome 32.XXX.107 and they work, but only in Firefox does this function fail. I’ve made sure the documents are editable and I’m sure it’s not an issue of PEBKAC. I’ve reproduced this bug on my own machine as well (which shares the same Windows 7 image as the rest of our company).
 
Downgrading to LO 4.1 fixes this issue. Am I missing something or can anyone else confirm this on 4.2?
 
Just so you know, we’re running:
 
Windows 7 SP1 Pro (x64) w/ the latest patches
Java 7 u51
Flash 12.0.44
Firefox 24.3 ESR
 
Let me know if you need more info.
Comment 1 tommy27 2014-02-24 14:37:46 UTC
*** Bug 75444 has been marked as a duplicate of this bug. ***
Comment 2 tommy27 2014-02-24 14:39:50 UTC
status to NEW according to Duplicate Bug 75444
I copy here the steps to reproduce from that report:

--------------------------------------------------

Mark Ellse  2014-02-24 13:14:35 UTC 
Problem description: Can't paste from Writer to Gmail in Firefox

Steps to reproduce:
1. Create new document in writer. 
2. Select some text.
3. Copy text to clipboard with Ctrl-C
4. Create new Gmail document in Firefox. 
5. Move to body text and paste with Ctrl-V

Current behavior: Nothing happens.

Expected behavior: Copied text should paste.

Pasting works when opening Gmail in Internet Explorer. It works when pasting from Writer to a text document. It seems that it is the interaction between LO and Firefox that is the issue.

              
Operating System: Windows 8
Version: 4.2.0.4 release
Comment 3 Mark Ellse 2014-02-24 19:28:02 UTC
The problem also seems to affect Google Docs, i.e. documents that are on Google Drive. If you copy text from LO documents, it doesn't paste into Google Docs. If you first paste the text into Notepad and copy it from Notepad, it will then paste into Google Docs
Comment 4 Dan C 2014-02-24 23:24:18 UTC
This bug also persists in version 4.2.1.1. Same environment as the 4.2.0.4 bug.
Comment 5 tommy27 2014-02-25 11:39:52 UTC
does this issue affect just the Gmailsite in Firefox or any other webmail service?
Comment 6 Maxim Monastirsky 2014-02-25 12:49:46 UTC

*** This bug has been marked as a duplicate of bug 74584 ***
Comment 7 tommy27 2014-02-27 06:43:19 UTC
*** Bug 75555 has been marked as a duplicate of this bug. ***
Comment 8 Greg Wilson 2014-02-27 09:53:23 UTC
Thank you so much for your help!!!!!!!!

*Greatly appreciated*!

greg


On Wed, Feb 26, 2014 at 10:43 PM, <bugzilla-daemon@freedesktop.org> wrote:

>  tommy27 <barta@quipo.it> changed bug 74949<https://bugs.freedesktop.org/show_bug.cgi?id=74949>
>  What Removed Added  CC   awakeningherenow@gmail.com
>
>  *Comment # 7 <https://bugs.freedesktop.org/show_bug.cgi?id=74949#c7> on
> bug 74949 <https://bugs.freedesktop.org/show_bug.cgi?id=74949> from tommy27
> <barta@quipo.it> *
>
> *** Bug 75555 <https://bugs.freedesktop.org/show_bug.cgi?id=75555> has been marked as a duplicate of this bug. ***
>
>  ------------------------------
> You are receiving this mail because:
>
>    - You are on the CC list for the bug.
>
>
Comment 9 Mark Ellse 2014-03-04 13:38:43 UTC
Bug now solved for me with 4.2.3 daily build. Thanks
Comment 10 Maxim Monastirsky 2014-03-05 11:04:13 UTC
*** Bug 75793 has been marked as a duplicate of this bug. ***